Reinstate EPEL-5 compatibility

- Reinstate EPEL-5 compatibility
- Drop redundant patch for building with ExtUtils::MakeMaker < 6.30
epel9
Paul Howarth 13 years ago
parent 8b4fb2b834
commit 3bed51c60b

@ -1,30 +0,0 @@
--- Test-EOL/Makefile.PL
+++ Test-EOL/Makefile.PL
@@ -4,7 +4,7 @@
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -17,7 +17,7 @@
"Test::More" => 0
},
"CONFIGURE_REQUIRES" => {
- "ExtUtils::MakeMaker" => "6.30"
+ "ExtUtils::MakeMaker" => "0"
},
"DISTNAME" => "Test-EOL",
"EXE_FILES" => [],
@@ -55,6 +55,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

@ -1,15 +1,12 @@
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.30) ? 1 : 0);' 2>/dev/null || echo 0)
Name: perl-Test-EOL
Version: 1.3
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Check the correct line endings in your project
Group: Development/Libraries
License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Test-EOL/
Source0: http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/Test-EOL-%{version}.tar.gz
Patch0: Test-EOL-1.0-old-EU::MM.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch
BuildRequires: perl(Cwd)
BuildRequires: perl(ExtUtils::MakeMaker)
@ -22,7 +19,7 @@ BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Test::Builder)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoTabs) >= 1.2
BuildRequires: perl(Test::Pod) >= 1.41
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage) >= 1.08
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
@ -34,16 +31,12 @@ whitespace.
%prep
%setup -q -n Test-EOL-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%if %{old_eumm}
%patch0 -p1
%endif
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
rm -rf %{buildroot}
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
%{_fixperms} %{buildroot}
@ -51,12 +44,19 @@ find %{buildroot} -type f -name .packlist -exec rm -f {} \;
%check
make test RELEASE_TESTING=1
%clean
rm -rf %{buildroot}
%files
%doc Changes LICENSE README
%{perl_vendorlib}/Test/
%{_mandir}/man3/Test::EOL.3pm*
%changelog
* Tue Aug 7 2012 Paul Howarth <paul@city-fan.org> - 1.3-6
- Reinstate EPEL-5 compatibility
- Drop redundant patch for building with ExtUtils::MakeMaker < 6.30
* Tue Aug 7 2012 Jitka Plesnikova <jplesnik@redhat.com>
- Update BR and clean up spec for modern rpmbuild

Loading…
Cancel
Save