- New upstream release 1.0 - Fix misleading test failure diagnostics when only issue is trailing whitespace - No longer blindly assume utf8 on input files (CPAN RT#59877) - Properly document testing options - This release by RIBASUSHI -> update source URL - Drop upstreamed patch for CPAN RT#59877 - Update patch for building with old ExtUtils::MakeMaker versionsepel9
parent
f8de5a2553
commit
022c49db7c
@ -1 +1 @@
|
||||
Test-EOL-0.9.tar.gz
|
||||
/Test-EOL-[0-9.]*.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
--- Test-EOL-0.8/Makefile.PL 2010-06-11 00:06:27.000000000 +0100
|
||||
+++ Test-EOL-0.8/Makefile.PL 2010-06-16 09:25:51.477819134 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.31;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -16,7 +16,7 @@
|
||||
'Test::More' => '0'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Test-EOL',
|
||||
'EXE_FILES' => [],
|
||||
@@ -52,6 +52,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
@ -1,40 +0,0 @@
|
||||
When a tested file contains Latin-1 chars, Test::EOL issues warnings and
|
||||
fails if trailing_whitespace option is turned on.
|
||||
|
||||
diff -up Test-EOL-0.9/lib/Test/EOL.pm Test-EOL-0.9/lib/Test/EOL.pm
|
||||
--- Test-EOL-0.9/lib/Test/EOL.pm 2010-06-16 15:05:07.000000000 +0100
|
||||
+++ Test-EOL-0.9/lib/Test/EOL.pm 2010-10-18 09:58:18.077182938 +0100
|
||||
@@ -104,7 +104,7 @@ sub eol_unix_ok {
|
||||
|
||||
open my $fh, $file or do { $Test->ok(0, $test_txt); $Test->diag("Could not open $file: $!"); return; };
|
||||
# Windows-- , default is :crlf, which hides \r\n -_-
|
||||
- binmode( $fh, ':raw:utf8' );
|
||||
+ binmode( $fh, ':raw' );
|
||||
my $line = 0;
|
||||
my @fails;
|
||||
while (<$fh>) {
|
||||
diff -up /dev/null Test-EOL-0.9/t/13-latin1.t
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ Test-EOL-0.9/t/13-latin1.t 2010-10-18 09:57:00.019168309 +0100
|
||||
@@ -0,0 +1,21 @@
|
||||
+use strict;
|
||||
+
|
||||
+use Test::More tests => 1;
|
||||
+
|
||||
+use Test::EOL;
|
||||
+
|
||||
+use File::Temp 'tempfile';
|
||||
+
|
||||
+my $file5 = make_file5();
|
||||
+eol_unix_ok( $file5, { trailing_whitespace => 1 });
|
||||
+
|
||||
+unlink $file5;
|
||||
+
|
||||
+sub make_file5 {
|
||||
+ my ($fh, $filename) = tempfile();
|
||||
+ print $fh <<'DUMMY';
|
||||
+#!/usr/bin/perl
|
||||
+print "Grüße!\n";
|
||||
+DUMMY
|
||||
+ return $filename;
|
||||
+}
|
@ -0,0 +1,30 @@
|
||||
--- Test-EOL/Makefile.PL
|
||||
+++ Test-EOL/Makefile.PL
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.30;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
"Test::More" => 0
|
||||
},
|
||||
"CONFIGURE_REQUIRES" => {
|
||||
- "ExtUtils::MakeMaker" => "6.30"
|
||||
+ "ExtUtils::MakeMaker" => "0"
|
||||
},
|
||||
"DISTNAME" => "Test-EOL",
|
||||
"EXE_FILES" => [],
|
||||
@@ -55,6 +55,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
Loading…
Reference in new issue