Update to 1.0

- New upstream release 1.0
  - Fix misleading test failure diagnostics when only issue is trailing
    whitespace
  - No longer blindly assume utf8 on input files (CPAN RT#59877)
  - Properly document testing options
- This release by RIBASUSHI -> update source URL
- Drop upstreamed patch for CPAN RT#59877
- Update patch for building with old ExtUtils::MakeMaker versions
epel9
Paul Howarth 13 years ago
parent f8de5a2553
commit 022c49db7c

2
.gitignore vendored

@ -1 +1 @@
Test-EOL-0.9.tar.gz /Test-EOL-[0-9.]*.tar.gz

@ -1,30 +0,0 @@
--- Test-EOL-0.8/Makefile.PL 2010-06-11 00:06:27.000000000 +0100
+++ Test-EOL-0.8/Makefile.PL 2010-06-16 09:25:51.477819134 +0100
@@ -4,7 +4,7 @@
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker;
@@ -16,7 +16,7 @@
'Test::More' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Test-EOL',
'EXE_FILES' => [],
@@ -52,6 +52,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

@ -1,40 +0,0 @@
When a tested file contains Latin-1 chars, Test::EOL issues warnings and
fails if trailing_whitespace option is turned on.
diff -up Test-EOL-0.9/lib/Test/EOL.pm Test-EOL-0.9/lib/Test/EOL.pm
--- Test-EOL-0.9/lib/Test/EOL.pm 2010-06-16 15:05:07.000000000 +0100
+++ Test-EOL-0.9/lib/Test/EOL.pm 2010-10-18 09:58:18.077182938 +0100
@@ -104,7 +104,7 @@ sub eol_unix_ok {
open my $fh, $file or do { $Test->ok(0, $test_txt); $Test->diag("Could not open $file: $!"); return; };
# Windows-- , default is :crlf, which hides \r\n -_-
- binmode( $fh, ':raw:utf8' );
+ binmode( $fh, ':raw' );
my $line = 0;
my @fails;
while (<$fh>) {
diff -up /dev/null Test-EOL-0.9/t/13-latin1.t
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ Test-EOL-0.9/t/13-latin1.t 2010-10-18 09:57:00.019168309 +0100
@@ -0,0 +1,21 @@
+use strict;
+
+use Test::More tests => 1;
+
+use Test::EOL;
+
+use File::Temp 'tempfile';
+
+my $file5 = make_file5();
+eol_unix_ok( $file5, { trailing_whitespace => 1 });
+
+unlink $file5;
+
+sub make_file5 {
+ my ($fh, $filename) = tempfile();
+ print $fh <<'DUMMY';
+#!/usr/bin/perl
+print "Grüße!\n";
+DUMMY
+ return $filename;
+}

@ -0,0 +1,30 @@
--- Test-EOL/Makefile.PL
+++ Test-EOL/Makefile.PL
@@ -4,7 +4,7 @@
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -17,7 +17,7 @@
"Test::More" => 0
},
"CONFIGURE_REQUIRES" => {
- "ExtUtils::MakeMaker" => "6.30"
+ "ExtUtils::MakeMaker" => "0"
},
"DISTNAME" => "Test-EOL",
"EXE_FILES" => [],
@@ -55,6 +55,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

@ -1,26 +1,26 @@
# We don't really need ExtUtils::MakeMaker ≥ 6.31 # We don't really need ExtUtils::MakeMaker > 6.30
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0) %global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.30 ? 1 : 0;' 2>/dev/null || echo 0)
Name: perl-Test-EOL Name: perl-Test-EOL
Version: 0.9 Version: 1.0
Release: 5%{?dist} Release: 1%{?dist}
Summary: Check the correct line endings in your project Summary: Check the correct line endings in your project
Group: Development/Libraries Group: Development/Libraries
License: GPL+ or Artistic License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Test-EOL/ URL: http://search.cpan.org/dist/Test-EOL/
Source0: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Test-EOL-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/R/RI/RIBASUSHI/Test-EOL-%{version}.tar.gz
Patch0: Test-EOL-0.8-old-EU::MM.patch Patch0: Test-EOL-1.0-old-EU::MM.patch
Patch1: Test-EOL-0.9-rt59877.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch BuildArch: noarch
BuildRequires: perl(ExtUtils::MakeMaker) BuildRequires: perl(ExtUtils::MakeMaker)
# Simplify breaking dependency loops at bootstrap time
%if 0%{!?perl_bootstrap:1}
BuildRequires: perl(Pod::Coverage::TrustPod)
%endif
BuildRequires: perl(Test::More) BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoTabs) BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Pod) BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage) BuildRequires: perl(Test::Pod::Coverage)
%if 0%{!?perl_bootstrap:1}
BuildRequires: perl(Pod::Coverage::TrustPod)
%endif
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version)) Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
%description %description
@ -31,14 +31,11 @@ whitespace.
%prep %prep
%setup -q -n Test-EOL-%{version} %setup -q -n Test-EOL-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.31 # We don't really need ExtUtils::MakeMaker > 6.30
%if %{old_eumm} %if %{old_eumm}
%patch0 -p1 %patch0 -p1
%endif %endif
# Don't assume tested files are UTF-8 encoded (CPAN RT#59877)
%patch1 -p1
%build %build
perl Makefile.PL INSTALLDIRS=vendor perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags} make %{?_smp_mflags}
@ -63,6 +60,16 @@ rm -rf %{buildroot}
%{_mandir}/man3/Test::EOL.3pm* %{_mandir}/man3/Test::EOL.3pm*
%changelog %changelog
* Thu Jan 5 2012 Paul Howarth <paul@city-fan.org> 1.0-1
- Update to 1.0
- Fix misleading test failure diagnostics when only issue is trailing
whitespace
- No longer blindly assume utf8 on input files (CPAN RT#59877)
- Properly document testing options
- This release by RIBASUSHI -> update source URL
- Drop upstreamed patch for CPAN RT#59877
- Update patch for building with old ExtUtils::MakeMaker versions
* Thu Jun 30 2011 Paul Howarth <paul@city-fan.org> - 0.9-5 * Thu Jun 30 2011 Paul Howarth <paul@city-fan.org> - 0.9-5
- Restore EPEL-4 compatibility - Restore EPEL-4 compatibility
- perl(Pod::Coverage::TrustPod) is available everywhere now - perl(Pod::Coverage::TrustPod) is available everywhere now

@ -1 +1 @@
b3b4453d0caed2954a93585924ab15f2 Test-EOL-0.9.tar.gz 38407e5dcc00004693b3ba0afc59d3ae Test-EOL-1.0.tar.gz

Loading…
Cancel
Save