Fix building on Perl without "." in @INC

f38
Petr Písař 8 years ago
parent 2f3cb7c552
commit 7f088c1ce2

@ -0,0 +1,28 @@
On Fri Feb 03 01:25:56 2017, TODDR wrote:
> oops! push not pop
>
HIO,
This library is a prerequisite for other CPAN distributions such as
DBIx-Class-Schema-Loader. Those other distributions will not work with
perl-5.26.0 unless this distribution works with that upcoming release. So if
you could review the patch, apply as needed and generate a new CPAN release,
that would be great!
Thank you very much.
Jim Keenan
diff --git a/Makefile.PL b/Makefile.PL
index 19d495e..ac78b9a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,6 +1,8 @@
use strict;
use warnings;
use ExtUtils::MakeMaker;
+
+BEGIN { push @INC, "." }
use inc::ExtUtils::MY_Metafile qw(my_metafile);
my_metafile {

@ -1,18 +1,29 @@
Name: perl-String-CamelCase
Version: 0.02
Release: 13%{?dist}
Release: 14%{?dist}
Summary: Convert underscore_text to CamelCase and back
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/String-CamelCase/
Source0: http://www.cpan.org/authors/id/H/HI/HIO/String-CamelCase-%{version}.tar.gz
# Fix building on Perl without "." in @INC, CPAN RT#120079
Patch0: String-CamelCase-0.02-inc.patch
BuildArch: noarch
BuildRequires: make
BuildRequires: perl
BuildRequires: perl-generators
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(strict)
BuildRequires: perl(vars)
BuildRequires: perl(warnings)
# Run-time:
BuildRequires: perl(base)
BuildRequires: perl(Exporter)
# Tests:
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
# Optional tests:
BuildRequires: perl(Test::Pod) >= 1.14
BuildRequires: perl(Test::Pod::Coverage) >= 1.04
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
%description
This module exports two functions to convert underscore_text to CamelCase and
@ -20,17 +31,14 @@ back again.
%prep
%setup -q -n String-CamelCase-%{version}
%patch0 -p1
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
make %{?_smp_mflags}
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} %{buildroot}/*
%check
@ -42,6 +50,9 @@ make test
%{_mandir}/man3/*
%changelog
* Wed May 17 2017 Petr Pisar <ppisar@redhat.com> - 0.02-14
- Fix building on Perl without "." in @INC (CPAN RT#120079)
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.02-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

Loading…
Cancel
Save