Adapt to ExtUtils-MakeMaker-7.48

f38
Petr Písař 4 years ago
parent 438b809b8a
commit 75dbe7f297

@ -0,0 +1,60 @@
From f0c2f407a1ff7faf4c5467a0f0aa49ec4ebd0384 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 8 Oct 2020 12:38:33 +0200
Subject: [PATCH] Fix MIN_PERL_VERSION
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
CPAN RT#133489
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
META.yml | 2 +-
Makefile.PL | 2 +-
lib/SVN/Look.pm | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/META.yml b/META.yml
index 139ad25..e38b5db 100644
--- a/META.yml
+++ b/META.yml
@@ -25,7 +25,7 @@ requires:
List::MoreUtils: '0'
MIME::Base64: '0'
XML::Simple: '0'
- perl: 5.008_000
+ perl: 5.008000
strict: '0'
warnings: '0'
resources:
diff --git a/Makefile.PL b/Makefile.PL
index 80cdc0c..68219bd 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -38,7 +38,7 @@ my %WriteMakefileArgs = (
},
'DISTNAME' => 'SVN-Look',
'LICENSE' => 'perl',
- 'MIN_PERL_VERSION' => '5.008_000',
+ 'MIN_PERL_VERSION' => '5.008000',
'NAME' => 'SVN::Look',
'PREREQ_PM' => {
'Carp' => '0',
diff --git a/lib/SVN/Look.pm b/lib/SVN/Look.pm
index 39faf07..16ae0f1 100644
--- a/lib/SVN/Look.pm
+++ b/lib/SVN/Look.pm
@@ -1,6 +1,6 @@
## no critic (Modules::RequireExplicitPackage, InputOutput::RequireBriefOpen)
-use 5.008_000;
+use 5.008000;
use strict;
use warnings;
--
2.25.4

@ -1,10 +1,13 @@
Name: perl-SVN-Look
Version: 0.41
Release: 15%{?dist}
Release: 16%{?dist}
Summary: Caching wrapper around the svnlook command
License: GPL+ or Artistic
URL: https://metacpan.org/release/SVN-Look
Source0: https://cpan.metacpan.org/authors/id/G/GN/GNUSTAVO/SVN-Look-%{version}.tar.gz
# Adapt to ExtUtils-MakeMaker-7.48,
# <https://github.com/gnustavo/SVN-Look/issues/5>
Patch0: SVN-Look-0.41-Fix-MIN_PERL_VERSION.patch
BuildArch: noarch
BuildRequires: make
BuildRequires: perl-interpreter
@ -44,6 +47,7 @@ repetitious calls.
%prep
%setup -q -n SVN-Look-%{version}
%patch0 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
@ -63,6 +67,9 @@ make test
%{_mandir}/man3/*
%changelog
* Thu Oct 08 2020 Petr Pisar <ppisar@redhat.com> - 0.41-16
- Adapt to ExtUtils-MakeMaker-7.48
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

Loading…
Cancel
Save