Update to 0.12

- New upstream release 0.12:
  - Fix tests to pass with Carp 1.25 (CPAN RT#75520)
- BR: perl(Test::Spelling), aspell-en
- Add patch to accept "deprecations" as a valid dictionary word
- Update patches to apply cleanly
- Don't need to remove empty directories from buildroot
- Don't use macros for commands
- Drop EPEL-4 support:
  - Drop patch supporting build with ExtUtils::MakeMaker < 6.30
epel9
Paul Howarth 13 years ago
parent a21dadb79e
commit da2d63dc23

@ -1,30 +0,0 @@
--- Package-DeprecationManager/Makefile.PL
+++ Package-DeprecationManager/Makefile.PL
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -17,7 +17,7 @@ my %WriteMakefileArgs = (
'Test::Requires' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.30'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Package-DeprecationManager',
'EXE_FILES' => [],
@@ -52,6 +52,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

@ -1,8 +1,8 @@
--- Package-DeprecationManager-0.10/t/basic.t 2010-10-27 09:27:42.000000000 +0100 --- t/basic.t
+++ Package-DeprecationManager-0.10/t/basic.t 2010-10-27 09:28:07.699161151 +0100 +++ t/basic.t
@@ -4,9 +4,10 @@ use warnings; @@ -4,9 +4,10 @@ use warnings;
use Test::More;
use Test::Fatal; use Test::Fatal;
use Test::More;
-use Test::Requires { -use Test::Requires {
- 'Test::Output' => '0.16', - 'Test::Output' => '0.16',

@ -1,7 +1,13 @@
diff -up Package-DeprecationManager-0.11/t/basic.t.orig Package-DeprecationManager-0.11/t/basic.t --- t/basic.t
--- Package-DeprecationManager-0.11/t/basic.t.orig 2011-06-20 03:32:49.000000000 +0100 +++ t/basic.t
+++ Package-DeprecationManager-0.11/t/basic.t 2011-06-20 10:57:16.388489180 +0100 @@ -2,12 +2,14 @@ use strict;
@@ -8,6 +8,8 @@ use Test::Requires { use warnings;
use Test::Fatal;
-use Test::More 0.88;
+use Test::More;
use Test::Requires {
'Test::Output' => '0.16', 'Test::Output' => '0.16',
}; };
@ -16,23 +22,21 @@ diff -up Package-DeprecationManager-0.11/t/basic.t.orig Package-DeprecationManag
} }
- -
-done_testing(); -done_testing();
diff -up Package-DeprecationManager-0.11/t/compile.t.orig Package-DeprecationManager-0.11/t/compile.t --- t/compile.t
--- Package-DeprecationManager-0.11/t/compile.t.orig 2011-06-20 03:32:49.000000000 +0100 +++ t/compile.t
+++ Package-DeprecationManager-0.11/t/compile.t 2011-06-20 10:57:16.398490068 +0100
@@ -1,9 +1,7 @@ @@ -1,9 +1,7 @@
use strict; use strict;
use warnings; use warnings;
-use Test::More; -use Test::More 0.88;
+use Test::More tests => 1; +use Test::More tests => 1;
eval "require Package::DeprecationManager"; eval "require Package::DeprecationManager";
ok( ! $@, 'no errors loading require Package::DeprecationManager' ); ok( ! $@, 'no errors loading require Package::DeprecationManager' );
- -
-done_testing(); -done_testing();
diff -up Package-DeprecationManager-0.11/t/release-cpan-changes.t.orig Package-DeprecationManager-0.11/t/release-cpan-changes.t --- t/release-cpan-changes.t
--- Package-DeprecationManager-0.11/t/release-cpan-changes.t.orig 2011-06-20 03:32:49.000000000 +0100 +++ t/release-cpan-changes.t
+++ Package-DeprecationManager-0.11/t/release-cpan-changes.t 2011-06-20 11:00:39.775567270 +0100
@@ -1,15 +1,11 @@ @@ -1,15 +1,11 @@
#!perl #!perl

@ -0,0 +1,7 @@
--- t/release-pod-spell.t
+++ t/release-pod-spell.t
@@ -31,3 +31,4 @@
PayPal
Rolsky
api
+deprecations

@ -1,8 +1,5 @@
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%global old_eumm %(%{__perl} -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.30 ? 1 : 0;' 2>/dev/null || echo 0)
# We need to patch the test suite if we have an old version of Test::More # We need to patch the test suite if we have an old version of Test::More
%global old_test_more %(%{__perl} -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0) %global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
# Test::Kwalitee and Test::Requires not available in EPEL < 6 # Test::Kwalitee and Test::Requires not available in EPEL < 6
%global extra_tests_available %(expr 0%{?fedora} + 0%{?rhel} '>' 5) %global extra_tests_available %(expr 0%{?fedora} + 0%{?rhel} '>' 5)
@ -11,23 +8,27 @@
%global cpan_changes_available %(expr 0%{?fedora} + 0%{?rhel} '>' 6) %global cpan_changes_available %(expr 0%{?fedora} + 0%{?rhel} '>' 6)
Name: perl-Package-DeprecationManager Name: perl-Package-DeprecationManager
Version: 0.11 Version: 0.12
Release: 3%{?dist} Release: 1%{?dist}
Summary: Manage deprecation warnings for your distribution Summary: Manage deprecation warnings for your distribution
Group: Development/Libraries Group: Development/Libraries
License: Artistic 2.0 License: Artistic 2.0
URL: http://search.cpan.org/dist/Package-DeprecationManager/ URL: http://search.cpan.org/dist/Package-DeprecationManager/
Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz
Patch0: Package-DeprecationManager-0.11-old-EU::MM.patch Patch1: Package-DeprecationManager-0.12-old-Test::More.patch
Patch1: Package-DeprecationManager-0.11-old-Test::More.patch Patch2: Package-DeprecationManager-0.12-no-Test::Requires.patch
Patch2: Package-DeprecationManager-0.10-no-Test::Requires.patch Patch3: Package-DeprecationManager-0.12-stopwords.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch BuildArch: noarch
BuildRequires: perl(Carp) BuildRequires: perl(Carp)
BuildRequires: perl(ExtUtils::MakeMaker) BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(List::MoreUtils) BuildRequires: perl(List::MoreUtils)
BuildRequires: perl(Params::Util) BuildRequires: perl(Params::Util)
BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Sub::Install) BuildRequires: perl(Sub::Install)
%if %{cpan_changes_available}
BuildRequires: perl(Test::CPAN::Changes)
%endif
BuildRequires: perl(Test::EOL) BuildRequires: perl(Test::EOL)
BuildRequires: perl(Test::Fatal) BuildRequires: perl(Test::Fatal)
BuildRequires: perl(Test::More) BuildRequires: perl(Test::More)
@ -35,10 +36,7 @@ BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Output) BuildRequires: perl(Test::Output)
BuildRequires: perl(Test::Pod) BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage) BuildRequires: perl(Test::Pod::Coverage)
BuildRequires: perl(Pod::Coverage::TrustPod) BuildRequires: perl(Test::Spelling), aspell-en
%if %{cpan_changes_available}
BuildRequires: perl(Test::CPAN::Changes)
%endif
%if %{extra_tests_available} %if %{extra_tests_available}
BuildRequires: perl(Test::Kwalitee) BuildRequires: perl(Test::Kwalitee)
BuildRequires: perl(Test::Requires) BuildRequires: perl(Test::Requires)
@ -55,21 +53,19 @@ the version when that feature was deprecated.
%prep %prep
%setup -q -n Package-DeprecationManager-%{version} %setup -q -n Package-DeprecationManager-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%if %{old_eumm}
%patch0 -p1
%endif
# Fix tests for Test::More prior to 0.88 # Fix tests for Test::More prior to 0.88
%if %{old_test_more} %if %{old_test_more}
%patch1 -p1 %patch1
%endif %endif
# If we don't have Test::Requires, we need to patch it out of the test suite # If we don't have Test::Requires, we need to patch it out of the test suite
%if ! %{extra_tests_available} %if ! %{extra_tests_available}
%patch2 -p1 %patch2
%endif %endif
# "deprecations" not a common dictionary word
%patch3
%build %build
perl Makefile.PL INSTALLDIRS=vendor perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags} make %{?_smp_mflags}
@ -78,7 +74,6 @@ make %{?_smp_mflags}
rm -rf %{buildroot} rm -rf %{buildroot}
make pure_install DESTDIR=%{buildroot} make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} \; find %{buildroot} -type f -name .packlist -exec rm -f {} \;
find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
%{_fixperms} %{buildroot} %{_fixperms} %{buildroot}
%check %check
@ -94,6 +89,17 @@ rm -rf %{buildroot}
%{_mandir}/man3/Package::DeprecationManager.3pm* %{_mandir}/man3/Package::DeprecationManager.3pm*
%changelog %changelog
* Mon Mar 5 2012 Paul Howarth <paul@city-fan.org> - 0.12-1
- Update to 0.12:
- Fix tests to pass with Carp 1.25 (CPAN RT#75520)
- BR: perl(Test::Spelling), aspell-en
- Add patch to accept "deprecations" as a valid dictionary word
- Update patches to apply cleanly
- Don't need to remove empty directories from buildroot
- Don't use macros for commands
- Drop EPEL-4 support:
- Drop patch supporting build with ExtUtils::MakeMaker < 6.30
* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.11-3 * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.11-3
- Fedora 17 mass rebuild - Fedora 17 mass rebuild

@ -1 +1 @@
d09664839b730997c591a5c891a2972b Package-DeprecationManager-0.11.tar.gz 5f7f21db151fa7f19c10cb6009a735d4 Package-DeprecationManager-0.12.tar.gz

Loading…
Cancel
Save