- New upstream release 0.12: - Fix tests to pass with Carp 1.25 (CPAN RT#75520) - BR: perl(Test::Spelling), aspell-en - Add patch to accept "deprecations" as a valid dictionary word - Update patches to apply cleanly - Don't need to remove empty directories from buildroot - Don't use macros for commands - Drop EPEL-4 support: - Drop patch supporting build with ExtUtils::MakeMaker < 6.30epel9
parent
a21dadb79e
commit
da2d63dc23
@ -1,30 +0,0 @@
|
||||
--- Package-DeprecationManager/Makefile.PL
|
||||
+++ Package-DeprecationManager/Makefile.PL
|
||||
@@ -4,7 +4,7 @@ use warnings;
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.30;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -17,7 +17,7 @@ my %WriteMakefileArgs = (
|
||||
'Test::Requires' => '0'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.30'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Package-DeprecationManager',
|
||||
'EXE_FILES' => [],
|
||||
@@ -52,6 +52,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- Package-DeprecationManager-0.10/t/basic.t 2010-10-27 09:27:42.000000000 +0100
|
||||
+++ Package-DeprecationManager-0.10/t/basic.t 2010-10-27 09:28:07.699161151 +0100
|
||||
--- t/basic.t
|
||||
+++ t/basic.t
|
||||
@@ -4,9 +4,10 @@ use warnings;
|
||||
use Test::More;
|
||||
use Test::Fatal;
|
||||
use Test::More;
|
||||
|
||||
-use Test::Requires {
|
||||
- 'Test::Output' => '0.16',
|
@ -0,0 +1,7 @@
|
||||
--- t/release-pod-spell.t
|
||||
+++ t/release-pod-spell.t
|
||||
@@ -31,3 +31,4 @@
|
||||
PayPal
|
||||
Rolsky
|
||||
api
|
||||
+deprecations
|
Loading…
Reference in new issue