Update to 0.06

- New upstream release 0.06:
  - Removed hard dep on Test::Warn for the benefit of Moose
  - Fixed what looked like a bug in -ignore handling
  - The -ignore parameter now accepts regexes as well as package names
- Update compatibility patches
- BR: List::MoreUtils
- BR: Test::Requires where possible, patch it out elsewhere
epel9
Paul Howarth 14 years ago
parent 3b85d9bdcc
commit ac9b164105

2
.gitignore vendored

@ -1 +1 @@
Package-DeprecationManager-0.04.tar.gz
/Package-DeprecationManager-0.06.tar.gz

@ -1,17 +0,0 @@
--- Package-DeprecationManager-0.04/t/basic.t 2010-07-14 19:39:58.000000000 +0100
+++ Package-DeprecationManager-0.04/t/basic.t 2010-07-26 10:03:44.041991697 +0100
@@ -2,7 +2,7 @@
use warnings;
use Test::Exception;
-use Test::More;
+use Test::More tests => 20;
use Test::Warn;
{
@@ -180,5 +180,3 @@
q{},
'no wanrning when calling My::Bar::foo()';
}
-
-done_testing();

@ -0,0 +1,16 @@
--- Package-DeprecationManager-0.06/t/basic.t.orig 2010-10-15 09:09:36.747221411 +0100
+++ Package-DeprecationManager-0.06/t/basic.t 2010-10-15 09:08:35.411161054 +0100
@@ -4,9 +4,10 @@
use Test::Exception;
use Test::More;
-use Test::Requires {
- 'Test::Warn' => '0.21',
-};
+BEGIN {
+ eval "use Test::Warn 0.21;";
+ plan skip_all => "Test::Warn 0.21 is required for this test" if $@;
+}
plan tests => 22;

@ -1,6 +1,6 @@
--- Package-DeprecationManager-0.04/Makefile.PL 2010-07-14 19:39:58.000000000 +0100
+++ Package-DeprecationManager-0.04/Makefile.PL 2010-07-26 09:59:08.206003168 +0100
@@ -4,7 +4,7 @@
--- Package-DeprecationManager-0.06/Makefile.PL 2010-10-14 20:49:26.000000000 +0100
+++ Package-DeprecationManager-0.06/Makefile.PL 2010-10-15 08:53:12.176176856 +0100
@@ -4,7 +4,7 @@ use warnings;
@ -9,8 +9,8 @@
@@ -17,7 +17,7 @@
'Test::Warn' => '0'
@@ -16,7 +16,7 @@ my %WriteMakefileArgs = (
'Test::More' => '0.88'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
@ -18,7 +18,7 @@
},
'DISTNAME' => 'Package-DeprecationManager',
'EXE_FILES' => [],
@@ -51,6 +51,9 @@
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

@ -0,0 +1,17 @@
--- Package-DeprecationManager-0.06/t/basic.t 2010-10-14 20:49:26.000000000 +0100
+++ Package-DeprecationManager-0.06/t/basic.t 2010-10-15 09:09:36.747221411 +0100
@@ -8,6 +8,8 @@
'Test::Warn' => '0.21',
};
+plan tests => 22;
+
{
throws_ok {
eval 'package Foo; use Package::DeprecationManager;';
@@ -221,5 +223,3 @@
q{},
'no warning when calling My::Package2::foo()';
}
-
-done_testing();

@ -4,19 +4,24 @@
# We need to patch the test suite if we have an old version of Test::More
%global old_test_more %(%{__perl} -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0)
# Test::Kwalitee and Test::Requires not available in EPEL < 6
%global extra_tests_available %(expr 0%{?fedora} + 0%{?rhel} '>' 5)
Name: perl-Package-DeprecationManager
Version: 0.04
Release: 2%{?dist}
Version: 0.06
Release: 1%{?dist}
Summary: Manage deprecation warnings for your distribution
Group: Development/Libraries
License: Artistic 2.0
URL: http://search.cpan.org/dist/Package-DeprecationManager/
Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz
Patch0: Package-DeprecationManager-0.04-old-EU::MM.patch
Patch1: Package-DeprecationManager-0.04-old-Test::More.patch
Patch0: Package-DeprecationManager-0.06-old-EU::MM.patch
Patch1: Package-DeprecationManager-0.06-old-Test::More.patch
Patch2: Package-DeprecationManager-0.06-no-Test::Requires.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: perl(Carp)
BuildRequires: perl(List::MoreUtils)
BuildRequires: perl(Params::Util)
BuildRequires: perl(Sub::Install)
BuildRequires: perl(Test::EOL)
@ -26,10 +31,13 @@ BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage)
BuildRequires: perl(Test::Warn)
# Pod::Coverage::TrustPod and Test::Kwalitee not yet in EPEL
# Pod::Coverage::TrustPod not yet in EPEL
%if 0%{?fedora}
BuildRequires: perl(Pod::Coverage::TrustPod)
%endif
%if %{extra_tests_available}
BuildRequires: perl(Test::Kwalitee)
BuildRequires: perl(Test::Requires)
%endif
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
@ -53,6 +61,11 @@ the version when that feature was deprecated.
%patch1 -p1
%endif
# If we don't have Test::Requires, we need to patch it out of the test suite
%if ! %{extra_tests_available}
%patch2 -p1
%endif
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
@ -77,6 +90,15 @@ rm -rf %{buildroot}
%{_mandir}/man3/Package::DeprecationManager.3pm*
%changelog
* Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
- Update to 0.06:
- Removed hard dep on Test::Warn for the benefit of Moose
- Fixed what looked like a bug in -ignore handling
- The -ignore parameter now accepts regexes as well as package names
- Update compatibility patches
- BR: List::MoreUtils
- BR: Test::Requires where possible, patch it out elsewhere
* Tue Jul 27 2010 Paul Howarth <paul@city-fan.org> - 0.04-2
- Clean up for Fedora submission

@ -1 +1 @@
bc1d60d004b8b4d6aa8c11f3c4ccbc5f Package-DeprecationManager-0.04.tar.gz
7523d8acf3aebad186cea0969dbd8844 Package-DeprecationManager-0.06.tar.gz

Loading…
Cancel
Save