This module allows you to manage a set of deprecations for one or more modules. When you import Package::DeprecationManager, you must provide a set of deprecations as a hash ref. The keys are "feature" names, and the values are the version when that feature was deprecated.epel9
parent
6c26c702f6
commit
3b85d9bdcc
@ -0,0 +1 @@
|
||||
Package-DeprecationManager-0.04.tar.gz
|
@ -0,0 +1,30 @@
|
||||
--- Package-DeprecationManager-0.04/Makefile.PL 2010-07-14 19:39:58.000000000 +0100
|
||||
+++ Package-DeprecationManager-0.04/Makefile.PL 2010-07-26 09:59:08.206003168 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.31;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
'Test::Warn' => '0'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Package-DeprecationManager',
|
||||
'EXE_FILES' => [],
|
||||
@@ -51,6 +51,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
@ -0,0 +1,17 @@
|
||||
--- Package-DeprecationManager-0.04/t/basic.t 2010-07-14 19:39:58.000000000 +0100
|
||||
+++ Package-DeprecationManager-0.04/t/basic.t 2010-07-26 10:03:44.041991697 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use warnings;
|
||||
|
||||
use Test::Exception;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 20;
|
||||
use Test::Warn;
|
||||
|
||||
{
|
||||
@@ -180,5 +180,3 @@
|
||||
q{},
|
||||
'no wanrning when calling My::Bar::foo()';
|
||||
}
|
||||
-
|
||||
-done_testing();
|
@ -0,0 +1,84 @@
|
||||
# We don't really need ExtUtils::MakeMaker > 6.31
|
||||
%global old_eumm %(%{__perl} -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
# We need to patch the test suite if we have an old version of Test::More
|
||||
%global old_test_more %(%{__perl} -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
Name: perl-Package-DeprecationManager
|
||||
Version: 0.04
|
||||
Release: 2%{?dist}
|
||||
Summary: Manage deprecation warnings for your distribution
|
||||
Group: Development/Libraries
|
||||
License: Artistic 2.0
|
||||
URL: http://search.cpan.org/dist/Package-DeprecationManager/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz
|
||||
Patch0: Package-DeprecationManager-0.04-old-EU::MM.patch
|
||||
Patch1: Package-DeprecationManager-0.04-old-Test::More.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(Params::Util)
|
||||
BuildRequires: perl(Sub::Install)
|
||||
BuildRequires: perl(Test::EOL)
|
||||
BuildRequires: perl(Test::Exception)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::NoTabs)
|
||||
BuildRequires: perl(Test::Pod)
|
||||
BuildRequires: perl(Test::Pod::Coverage)
|
||||
BuildRequires: perl(Test::Warn)
|
||||
# Pod::Coverage::TrustPod and Test::Kwalitee not yet in EPEL
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: perl(Pod::Coverage::TrustPod)
|
||||
BuildRequires: perl(Test::Kwalitee)
|
||||
%endif
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
|
||||
%description
|
||||
This module allows you to manage a set of deprecations for one or more modules.
|
||||
|
||||
When you import Package::DeprecationManager, you must provide a set of
|
||||
-deprecations as a hash ref. The keys are "feature" names, and the values are
|
||||
the version when that feature was deprecated.
|
||||
|
||||
%prep
|
||||
%setup -q -n Package-DeprecationManager-%{version}
|
||||
|
||||
# We don't really need ExtUtils::MakeMaker > 6.31
|
||||
%if %{old_eumm}
|
||||
%patch0 -p1
|
||||
%endif
|
||||
|
||||
# Fix tests for Test::More prior to 0.88
|
||||
%if %{old_test_more}
|
||||
%patch1 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
%check
|
||||
make test RELEASE_TESTING=1
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc Changes LICENSE README
|
||||
%{perl_vendorlib}/Package/
|
||||
%{_mandir}/man3/Package::DeprecationManager.3pm*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 27 2010 Paul Howarth <paul@city-fan.org> - 0.04-2
|
||||
- Clean up for Fedora submission
|
||||
|
||||
* Mon Jul 26 2010 Paul Howarth <paul@city-fan.org> - 0.04-1
|
||||
- Initial RPM version
|
Loading…
Reference in new issue