Update to 0.08

- New upstream release 0.08:
  - The use of regular expressions in ignores didn't really work in 0.06
  - Added missing deps on List::MoreUtils and Test::Requires
  - Replaced Test::Warn with Test::Output in the tests
  - Made the tests actually test what they should be testing
- BR: Test::Output rather than Test::Warn
- Update patches
epel9
Paul Howarth 14 years ago
parent ac9b164105
commit 658eaa2258

2
.gitignore vendored

@ -1 +1 @@
/Package-DeprecationManager-0.06.tar.gz
/Package-DeprecationManager-0.08.tar.gz

@ -1,16 +0,0 @@
--- Package-DeprecationManager-0.06/t/basic.t.orig 2010-10-15 09:09:36.747221411 +0100
+++ Package-DeprecationManager-0.06/t/basic.t 2010-10-15 09:08:35.411161054 +0100
@@ -4,9 +4,10 @@
use Test::Exception;
use Test::More;
-use Test::Requires {
- 'Test::Warn' => '0.21',
-};
+BEGIN {
+ eval "use Test::Warn 0.21;";
+ plan skip_all => "Test::Warn 0.21 is required for this test" if $@;
+}
plan tests => 22;

@ -1,17 +0,0 @@
--- Package-DeprecationManager-0.06/t/basic.t 2010-10-14 20:49:26.000000000 +0100
+++ Package-DeprecationManager-0.06/t/basic.t 2010-10-15 09:09:36.747221411 +0100
@@ -8,6 +8,8 @@
'Test::Warn' => '0.21',
};
+plan tests => 22;
+
{
throws_ok {
eval 'package Foo; use Package::DeprecationManager;';
@@ -221,5 +223,3 @@
q{},
'no warning when calling My::Package2::foo()';
}
-
-done_testing();

@ -0,0 +1,16 @@
--- Package-DeprecationManager-0.08/t/basic.t 2010-10-15 21:09:58.000000000 +0100
+++ Package-DeprecationManager-0.08/t/basic.t 2010-10-15 21:10:50.632225765 +0100
@@ -4,9 +4,10 @@ use warnings;
use Test::Exception;
use Test::More;
-use Test::Requires {
- 'Test::Output' => '0.16',
-};
+BEGIN {
+ eval "use Test::Output 0.16;";
+ plan skip_all => "Test::Output 0.16 is required for this test" if $@;
+}
plan tests => 25;

@ -1,5 +1,5 @@
--- Package-DeprecationManager-0.06/Makefile.PL 2010-10-14 20:49:26.000000000 +0100
+++ Package-DeprecationManager-0.06/Makefile.PL 2010-10-15 08:53:12.176176856 +0100
--- Package-DeprecationManager-0.08/Makefile.PL 2010-10-15 17:39:30.000000000 +0100
+++ Package-DeprecationManager-0.08/Makefile.PL 2010-10-15 21:04:14.211191379 +0100
@@ -4,7 +4,7 @@ use warnings;
@ -9,8 +9,8 @@
@@ -16,7 +16,7 @@ my %WriteMakefileArgs = (
'Test::More' => '0.88'
@@ -17,7 +17,7 @@ my %WriteMakefileArgs = (
'Test::Requires' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
@ -18,7 +18,7 @@
},
'DISTNAME' => 'Package-DeprecationManager',
'EXE_FILES' => [],
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
@@ -52,6 +52,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

@ -0,0 +1,17 @@
--- Package-DeprecationManager-0.08/t/basic.t 2010-10-15 17:39:30.000000000 +0100
+++ Package-DeprecationManager-0.08/t/basic.t 2010-10-15 21:08:31.669098682 +0100
@@ -8,6 +8,8 @@ use Test::Requires {
'Test::Output' => '0.16',
};
+plan tests => 25;
+
{
throws_ok {
eval 'package Foo; use Package::DeprecationManager;';
@@ -216,5 +218,3 @@ use Test::Requires {
q{},
'no deprecation warning for second call to My::Package1::foo()';
}
-
-done_testing();

@ -8,16 +8,16 @@
%global extra_tests_available %(expr 0%{?fedora} + 0%{?rhel} '>' 5)
Name: perl-Package-DeprecationManager
Version: 0.06
Version: 0.08
Release: 1%{?dist}
Summary: Manage deprecation warnings for your distribution
Group: Development/Libraries
License: Artistic 2.0
URL: http://search.cpan.org/dist/Package-DeprecationManager/
Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz
Patch0: Package-DeprecationManager-0.06-old-EU::MM.patch
Patch1: Package-DeprecationManager-0.06-old-Test::More.patch
Patch2: Package-DeprecationManager-0.06-no-Test::Requires.patch
Patch0: Package-DeprecationManager-0.08-old-EU::MM.patch
Patch1: Package-DeprecationManager-0.08-old-Test::More.patch
Patch2: Package-DeprecationManager-0.08-no-Test::Requires.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: perl(Carp)
@ -28,9 +28,9 @@ BuildRequires: perl(Test::EOL)
BuildRequires: perl(Test::Exception)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Output)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage)
BuildRequires: perl(Test::Warn)
# Pod::Coverage::TrustPod not yet in EPEL
%if 0%{?fedora}
BuildRequires: perl(Pod::Coverage::TrustPod)
@ -90,6 +90,15 @@ rm -rf %{buildroot}
%{_mandir}/man3/Package::DeprecationManager.3pm*
%changelog
* Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
- Update to 0.08:
- The use of regular expressions in ignores didn't really work in 0.06
- Added missing deps on List::MoreUtils and Test::Requires
- Replaced Test::Warn with Test::Output in the tests
- Made the tests actually test what they should be testing
- BR: Test::Output rather than Test::Warn
- Update patches
* Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
- Update to 0.06:
- Removed hard dep on Test::Warn for the benefit of Moose

@ -1 +1 @@
7523d8acf3aebad186cea0969dbd8844 Package-DeprecationManager-0.06.tar.gz
b7b43011968fedc2e05bcba38d9d15e6 Package-DeprecationManager-0.08.tar.gz

Loading…
Cancel
Save