commit
b2b6d6b5bd
@ -0,0 +1 @@
|
|||||||
|
SOURCES/Net-Ping-2.75.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
c13fcf60d1c6527cf71f2062dfa9cb67fc29a7c7 SOURCES/Net-Ping-2.75.tar.gz
|
@ -0,0 +1,187 @@
|
|||||||
|
From a37894585ba4894f54a3d35487acafa1350c91fa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||||
|
Date: Thu, 18 May 2023 11:42:29 +0200
|
||||||
|
Subject: [PATCH] Upgrade to 2.76
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.PL | 8 ++++----
|
||||||
|
lib/Net/Ping.pm | 2 +-
|
||||||
|
t/000_load.t | 2 +-
|
||||||
|
t/001_new.t | 5 +++++
|
||||||
|
t/010_pingecho.t | 6 +++++-
|
||||||
|
t/450_service.t | 4 ++--
|
||||||
|
t/500_ping_icmp.t | 5 ++---
|
||||||
|
t/501_ping_icmpv6.t | 5 ++---
|
||||||
|
8 files changed, 22 insertions(+), 15 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.PL b/Makefile.PL
|
||||||
|
index dadc57f..ebf05a0 100644
|
||||||
|
--- a/Makefile.PL
|
||||||
|
+++ b/Makefile.PL
|
||||||
|
@@ -30,11 +30,11 @@ push @extras,
|
||||||
|
resources => {
|
||||||
|
# TODO: 26 old issues still open at RT
|
||||||
|
# https://rt.cpan.org/Public/Dist/Display.html?Name=Net-Ping
|
||||||
|
- bugtracker => 'https://github.com/rurban/Net-Ping/issues',
|
||||||
|
+ bugtracker => 'https://github.com/Perl/perl5/issues',
|
||||||
|
repository => {
|
||||||
|
type => 'git',
|
||||||
|
- url => 'https://github.com/rurban/Net-Ping.git',
|
||||||
|
- web => 'https://github.com/rurban/Net-Ping',
|
||||||
|
+ url => 'https://github.com/Perl/perl5.git',
|
||||||
|
+ web => 'https://github.com/Perl/perl5',
|
||||||
|
},
|
||||||
|
license => [ 'http://dev.perl.org/licenses/' ],
|
||||||
|
},
|
||||||
|
@@ -55,7 +55,7 @@ WriteMakefile(
|
||||||
|
'Test::Pod' => '1.22',
|
||||||
|
'Test::More' => 0,
|
||||||
|
},
|
||||||
|
- INSTALLDIRS => ($ENV{PERL_CORE} ? 'perl' : 'site'),
|
||||||
|
+ INSTALLDIRS => ( $] < 5.011 ? 'perl' : 'site' ),
|
||||||
|
clean => { FILES => 'Net-Ping-*' },
|
||||||
|
@extras
|
||||||
|
);
|
||||||
|
diff --git a/lib/Net/Ping.pm b/lib/Net/Ping.pm
|
||||||
|
index 0b7be8c..b4c8f2f 100644
|
||||||
|
--- a/lib/Net/Ping.pm
|
||||||
|
+++ b/lib/Net/Ping.pm
|
||||||
|
@@ -22,7 +22,7 @@ use Time::HiRes;
|
||||||
|
@ISA = qw(Exporter);
|
||||||
|
@EXPORT = qw(pingecho);
|
||||||
|
@EXPORT_OK = qw(wakeonlan);
|
||||||
|
-$VERSION = "2.75";
|
||||||
|
+$VERSION = "2.76";
|
||||||
|
|
||||||
|
# Globals
|
||||||
|
|
||||||
|
diff --git a/t/000_load.t b/t/000_load.t
|
||||||
|
index 4bf05c6..87f55d9 100644
|
||||||
|
--- a/t/000_load.t
|
||||||
|
+++ b/t/000_load.t
|
||||||
|
@@ -12,5 +12,5 @@ BEGIN {
|
||||||
|
use_ok( 'Net::Ping' ) || print "No Net::Ping!\n";
|
||||||
|
}
|
||||||
|
|
||||||
|
-diag( "Testing Net::Ping $Net::Ping::VERSION, Perl $] on $^O, $^X" );
|
||||||
|
+note( "Testing Net::Ping $Net::Ping::VERSION, Perl $], $^X" );
|
||||||
|
|
||||||
|
diff --git a/t/001_new.t b/t/001_new.t
|
||||||
|
index 6b097d7..46965b7 100644
|
||||||
|
--- a/t/001_new.t
|
||||||
|
+++ b/t/001_new.t
|
||||||
|
@@ -1,11 +1,16 @@
|
||||||
|
use warnings;
|
||||||
|
use strict;
|
||||||
|
+use Config;
|
||||||
|
|
||||||
|
BEGIN {
|
||||||
|
unless (my $port = getservbyname('echo', 'tcp')) {
|
||||||
|
print "1..0 \# Skip: no echo port\n";
|
||||||
|
exit;
|
||||||
|
}
|
||||||
|
+ unless ($Config{d_getpbyname}) {
|
||||||
|
+ print "1..0 \# Skip: no getprotobyname\n";
|
||||||
|
+ exit;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
use Test::More qw(no_plan);
|
||||||
|
diff --git a/t/010_pingecho.t b/t/010_pingecho.t
|
||||||
|
index e26332b..0c3c815 100644
|
||||||
|
--- a/t/010_pingecho.t
|
||||||
|
+++ b/t/010_pingecho.t
|
||||||
|
@@ -1,11 +1,16 @@
|
||||||
|
use warnings;
|
||||||
|
use strict;
|
||||||
|
+use Config;
|
||||||
|
|
||||||
|
BEGIN {
|
||||||
|
unless (my $port = getservbyname('echo', 'tcp')) {
|
||||||
|
print "1..0 \# Skip: no echo port\n";
|
||||||
|
exit;
|
||||||
|
}
|
||||||
|
+ unless ($Config{d_getpbyname}) {
|
||||||
|
+ print "1..0 \# Skip: no getprotobyname\n";
|
||||||
|
+ exit;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
use Test::More tests => 2;
|
||||||
|
@@ -14,7 +19,6 @@ BEGIN {use_ok('Net::Ping')};
|
||||||
|
TODO: {
|
||||||
|
local $TODO = "Not working on os390 smoker; may be a permissions problem"
|
||||||
|
if $^O eq 'os390';
|
||||||
|
- $TODO = "Not working on freebsd" if $^O eq 'freebsd';
|
||||||
|
my $result = pingecho("127.0.0.1");
|
||||||
|
is($result, 1, "pingecho 127.0.0.1 works");
|
||||||
|
}
|
||||||
|
diff --git a/t/450_service.t b/t/450_service.t
|
||||||
|
index 203d86b..8bfd91e 100644
|
||||||
|
--- a/t/450_service.t
|
||||||
|
+++ b/t/450_service.t
|
||||||
|
@@ -78,7 +78,7 @@ is($p->ping("127.0.0.1"), 1, 'first port is reachable');
|
||||||
|
$p->{port_num} = $port2;
|
||||||
|
|
||||||
|
{
|
||||||
|
- local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:hpux|MSWin32|os390|freebsd)$/;
|
||||||
|
+ local $TODO = "Believed not to work on $^O" if $^O =~ /^(?:MSWin32|os390)$/;
|
||||||
|
is($p->ping("127.0.0.1"), 1, 'second port is reachable');
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -133,7 +133,7 @@ SKIP: {
|
||||||
|
|
||||||
|
{
|
||||||
|
local $TODO = "Believed not to work on $^O"
|
||||||
|
- if $^O =~ /^(?:hpux|MSWin32|os390|freebsd)$/;
|
||||||
|
+ if $^O =~ /^(?:MSWin32|os390)$/;
|
||||||
|
is($p->ack(), '127.0.0.1', 'IP should be reachable');
|
||||||
|
}
|
||||||
|
}
|
||||||
|
diff --git a/t/500_ping_icmp.t b/t/500_ping_icmp.t
|
||||||
|
index 7476f60..e355711 100644
|
||||||
|
--- a/t/500_ping_icmp.t
|
||||||
|
+++ b/t/500_ping_icmp.t
|
||||||
|
@@ -19,14 +19,13 @@ BEGIN {
|
||||||
|
}
|
||||||
|
|
||||||
|
my $is_devel = $ENV{PERL_CORE} || -d ".git" ? 1 : 0;
|
||||||
|
-$ENV{TEST_PING_HOST} = "127.0.0.1" if $ENV{NO_NETWORK_TESTING};
|
||||||
|
# Note this rawsocket test code is considered anti-social in p5p and was removed in
|
||||||
|
# their variant.
|
||||||
|
-# See See https://www.nntp.perl.org/group/perl.perl5.porters/2016/11/msg240707.html
|
||||||
|
+# See http://nntp.perl.org/group/perl.perl5.porters/240707
|
||||||
|
# Problem is that ping_icmp needs root perms, and previous bugs were
|
||||||
|
# never caught. So I rather execute it via sudo in the core test suite
|
||||||
|
# and on devel CPAN dirs, than not at all and risk further bitrot of this API.
|
||||||
|
-if (!Net::Ping::_isroot()) {
|
||||||
|
+if ( 0 && !Net::Ping::_isroot()) { # disable in blead via 7bfdd8260c
|
||||||
|
my $file = __FILE__;
|
||||||
|
my $lib = $ENV{PERL_CORE} ? '-I../../lib' : '-Mblib';
|
||||||
|
if ($is_devel and $Config{ccflags} =~ /fsanitize=address/ and $^O eq 'linux') {
|
||||||
|
diff --git a/t/501_ping_icmpv6.t b/t/501_ping_icmpv6.t
|
||||||
|
index 9b5b8b8..d59d4be 100644
|
||||||
|
--- a/t/501_ping_icmpv6.t
|
||||||
|
+++ b/t/501_ping_icmpv6.t
|
||||||
|
@@ -19,8 +19,7 @@ BEGIN {
|
||||||
|
}
|
||||||
|
|
||||||
|
my $is_devel = $ENV{PERL_CORE} || -d ".git" ? 1 : 0;
|
||||||
|
-$ENV{TEST_PING6_HOST} = "::1" if $ENV{NO_NETWORK_TESTING};
|
||||||
|
-if (!Net::Ping::_isroot()) {
|
||||||
|
+if (0 && !Net::Ping::_isroot()) {
|
||||||
|
my $file = __FILE__;
|
||||||
|
my $lib = $ENV{PERL_CORE} ? '-I../../lib' : '-Mblib';
|
||||||
|
# -n prevents from asking for a password. rather fail then
|
||||||
|
@@ -60,7 +59,7 @@ SKIP: {
|
||||||
|
my $rightip = "2001:4860:4860::8888"; # pingable ip of google's dnsserver
|
||||||
|
# for a firewalled ipv6 network try an optional local ipv6 host
|
||||||
|
$rightip = $ENV{TEST_PING6_HOST} if $ENV{TEST_PING6_HOST};
|
||||||
|
- my $wrongip = "2001:db8::"; # non existing ip
|
||||||
|
+ my $wrongip = "2001:4860:4860::1234"; # non existing ip
|
||||||
|
# diag "Pinging existing IPv6 ";
|
||||||
|
my $result = $p->ping($rightip);
|
||||||
|
if ($result == 1) {
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
@ -0,0 +1,180 @@
|
|||||||
|
%global base_version 2.75
|
||||||
|
# Perform optional tests
|
||||||
|
%bcond_without perl_Net_Ping_enables_optional_test
|
||||||
|
|
||||||
|
Name: perl-Net-Ping
|
||||||
|
Version: 2.76
|
||||||
|
Release: 510%{?dist}
|
||||||
|
Summary: Check a remote host for reachability
|
||||||
|
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
||||||
|
URL: https://metacpan.org/release/Net-Ping/
|
||||||
|
Source0: https://cpan.metacpan.org/authors/id/R/RU/RURBAN/Net-Ping-%{base_version}.tar.gz
|
||||||
|
# Unbundled from perl 5.37.11
|
||||||
|
Patch0: Net-Ping-2.75-Upgrade-to-2.76.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: coreutils
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl-interpreter
|
||||||
|
BuildRequires: perl(:VERSION) >= 5.2
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
# Run-time:
|
||||||
|
BuildRequires: perl(Carp)
|
||||||
|
BuildRequires: perl(constant)
|
||||||
|
BuildRequires: perl(Exporter)
|
||||||
|
BuildRequires: perl(Fcntl)
|
||||||
|
BuildRequires: perl(FileHandle)
|
||||||
|
BuildRequires: perl(IO::Socket::INET)
|
||||||
|
# Net::Ping::External not used at tests
|
||||||
|
BuildRequires: perl(POSIX)
|
||||||
|
BuildRequires: perl(Socket) >= 2.007
|
||||||
|
BuildRequires: perl(Time::HiRes)
|
||||||
|
BuildRequires: perl(vars)
|
||||||
|
# Win32 not used on Linux
|
||||||
|
# Tests:
|
||||||
|
BuildRequires: perl(Config)
|
||||||
|
BuildRequires: perl(Cwd)
|
||||||
|
BuildRequires: perl(File::Spec)
|
||||||
|
BuildRequires: perl(Test::More)
|
||||||
|
# sudo not used
|
||||||
|
%if %{with perl_Net_Ping_enables_optional_test}
|
||||||
|
# Optional tests:
|
||||||
|
BuildRequires: perl(:VERSION) >= 5.6
|
||||||
|
# Class::XSAccessor not used
|
||||||
|
BuildRequires: perl(IO::Socket)
|
||||||
|
# List::MoreUtils not used
|
||||||
|
# Module::CPANTS::Kwalitee::Uses not used
|
||||||
|
# Text::CSV_XS not used
|
||||||
|
# Test::CPAN::Meta not used
|
||||||
|
# Test::Kwalitee not used
|
||||||
|
BuildRequires: perl(Test::Pod) >= 1.22
|
||||||
|
# Test::Pod::Coverage not used
|
||||||
|
%endif
|
||||||
|
Requires: perl(IO::Socket::INET)
|
||||||
|
# Keep Net::Ping::External optional
|
||||||
|
Suggests: perl(Net::Ping::External)
|
||||||
|
Conflicts: perl < 4:5.22.0-350
|
||||||
|
|
||||||
|
%description
|
||||||
|
Net::Ping module contains methods to test the reachability of remote hosts on
|
||||||
|
a network.
|
||||||
|
|
||||||
|
%package tests
|
||||||
|
Summary: Tests for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
Requires: perl-Test-Harness
|
||||||
|
Requires: perl(Socket)
|
||||||
|
Requires: perl(IO::Socket)
|
||||||
|
Requires: perl(IO::Socket::INET)
|
||||||
|
|
||||||
|
%description tests
|
||||||
|
Tests from %{name}. Execute them
|
||||||
|
with "%{_libexecdir}/%{name}/test".
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Net-Ping-%{base_version}
|
||||||
|
%patch -P0 -p1
|
||||||
|
# Remove author tests
|
||||||
|
rm t/6*.t
|
||||||
|
# Remove appveyor script
|
||||||
|
rm t/appveyor-test.bat
|
||||||
|
# Remove removed files from MANIFEST file
|
||||||
|
perl -i -ne 'print $_ unless m{^(?:t/6.*\.t|appveyor-test\.bat)}' MANIFEST
|
||||||
|
# Help generators to recognize Perl scripts
|
||||||
|
for F in t/*.t; do
|
||||||
|
perl -i -MConfig -ple 'print $Config{startperl} if $. == 1 && !s{\A#!\s*perl}{$Config{startperl}}' "$F"
|
||||||
|
chmod +x "$F"
|
||||||
|
done
|
||||||
|
|
||||||
|
%build
|
||||||
|
unset PERL_CORE
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
|
||||||
|
%{make_build}
|
||||||
|
|
||||||
|
%install
|
||||||
|
%{make_install}
|
||||||
|
# Install tests
|
||||||
|
mkdir -p %{buildroot}%{_libexecdir}/%{name}
|
||||||
|
cp -a t %{buildroot}%{_libexecdir}/%{name}
|
||||||
|
cat > %{buildroot}%{_libexecdir}/%{name}/test << 'EOF'
|
||||||
|
#!/bin/sh
|
||||||
|
unset AUTHOR_TESTING IS_MAINTAINER NET_PING_FAIL_IP PERL_TEST_Net_Ping \
|
||||||
|
TEST_PING_HOST TEST_PING6_HOST
|
||||||
|
export NO_NETWORK_TESTING=1
|
||||||
|
cd %{_libexecdir}/%{name} && exec prove -I . -j "$(getconf _NPROCESSORS_ONLN)"
|
||||||
|
EOF
|
||||||
|
chmod +x %{buildroot}%{_libexecdir}/%{name}/test
|
||||||
|
%{_fixperms} %{buildroot}/*
|
||||||
|
|
||||||
|
%check
|
||||||
|
unset AUTHOR_TESTING IS_MAINTAINER NET_PING_FAIL_IP PERL_TEST_Net_Ping \
|
||||||
|
TEST_PING_HOST TEST_PING6_HOST
|
||||||
|
export NO_NETWORK_TESTING=1
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc Changes README TODO
|
||||||
|
%{perl_vendorlib}/*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%files tests
|
||||||
|
%{_libexecdir}/%{name}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jul 18 2024 Jitka Plesnikova <jplesnik@redhat.com> - 2.76-510
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.76-503
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.76-502
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.76-501
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.76-500
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 11 2023 Jitka Plesnikova <jplesnik@redhat.com> - 2.76-499
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Thu May 18 2023 Jitka Plesnikova <jplesnik@redhat.com> - 2.76-1
|
||||||
|
- Upgrade to 2.76 as provided in perl-5.37.11
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.75-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 02 2022 Michal Josef Špaček <mspacek@redhat.com> - 2.75-2
|
||||||
|
- Package tests
|
||||||
|
- Unify to use macros
|
||||||
|
- Update license to SPDX format
|
||||||
|
|
||||||
|
* Tue Sep 06 2022 Michal Josef Špaček <mspacek@redhat.com> - 2.75-1
|
||||||
|
- Bump 2.75
|
||||||
|
|
||||||
|
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.74-489
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 30 2022 Jitka Plesnikova <jplesnik@redhat.com> - 2.74-488
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.74-479
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.74-478
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 21 2021 Jitka Plesnikova <jplesnik@redhat.com> - 2.74-477
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.74-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 03 2020 Jitka Plesnikova <jplesnik@redhat.com> - 2.74-2
|
||||||
|
- Disable network tests in 200_tcp_ping
|
||||||
|
|
||||||
|
* Mon Nov 16 2020 Petr Pisar <ppisar@redhat.com> 2.74-1
|
||||||
|
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in new issue