Correct dependencies

If the script is installed by EU::MM, the sharp-bang is fixed
automatically.
epel9
Petr Písař 10 years ago
parent a43eed025a
commit 7461fb1f7d

@ -0,0 +1,26 @@
From c959e067ee5bb6c4ad5b139058b7e3bb29716c15 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 10 Feb 2015 11:48:32 +0100
Subject: [PATCH] Fix sharp-bang line
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
bin/mce_grep | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/bin/mce_grep b/bin/mce_grep
index 44cfc8a..028bb04 100755
--- a/bin/mce_grep
+++ b/bin/mce_grep
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!perl
###############################################################################
## ----------------------------------------------------------------------------
## A MCE-driven wrapper script for the following C binaries.
--
1.9.3

@ -0,0 +1,33 @@
From 9d9cce744e8cb9c6573578beb18cb25089cd6b86 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 10 Feb 2015 11:44:18 +0100
Subject: [PATCH] Install mce_grep
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
CPAN RT#102040
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/Makefile.PL b/Makefile.PL
index 9508423..6fdf236 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -33,7 +33,9 @@ WriteMakefile(
VERSION => '1.600',
- EXE_FILES => [],
+ EXE_FILES => [
+ 'bin/mce_grep'
+ ],
(($ExtUtils::MakeMaker::VERSION lt '6.25') ?
(PL_FILES => { }) : ()),
--
1.9.3

@ -1,10 +1,14 @@
Name: perl-MCE Name: perl-MCE
Version: 1.600 Version: 1.600
Release: 1%{?dist} Release: 2%{?dist}
Summary: Many-core Engine for Perl providing parallel processing capabilities Summary: Many-core Engine for Perl providing parallel processing capabilities
License: GPL+ or Artistic License: GPL+ or Artistic
URL: http://search.cpan.org/dist/MCE/ URL: http://search.cpan.org/dist/MCE/
Source0: http://www.cpan.org/authors/id/M/MA/MARIOROY/MCE-%{version}.tar.gz Source0: http://www.cpan.org/authors/id/M/MA/MARIOROY/MCE-%{version}.tar.gz
# Install mce_grep tool, CPAN RT#102040
Patch0: MCE-1.600-Install-mce_grep.patch
# Fix sharp-bang line
Patch1: MCE-1.600-Fix-sharp-bang-line.patch
BuildArch: noarch BuildArch: noarch
# Build # Build
BuildRequires: perl BuildRequires: perl
@ -31,9 +35,19 @@ Requires: perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
Requires: perl(Carp) Requires: perl(Carp)
Requires: perl(File::Path) Requires: perl(File::Path)
Requires: perl(IO::Handle) Requires: perl(IO::Handle)
Requires: perl(MCE::Util)
Requires: perl(MCE::Core::Input::Generator)
Requires: perl(MCE::Core::Input::Handle)
Requires: perl(MCE::Core::Input::Iterator)
Requires: perl(MCE::Core::Input::Request)
Requires: perl(MCE::Core::Input::Sequence)
Requires: perl(MCE::Core::Validation)
Requires: perl(MCE::Core::Manager)
Requires: perl(MCE::Core::Worker)
Requires: perl(Storable) >= 2.04 Requires: perl(Storable) >= 2.04
%global __requires_exclude %{?__requires_exclude|%__requires_exclude|}^perl\\(Storable\\)$ %{?perl_default_filter}
%global __requires_exclude %{?__requires_exclude|%__requires_exclude|}^perl\\((MCE|Storable)\\)$
%global __provides_exclude %{?__provides_exclude|%__provides_exclude|}^perl\\(MCE\\)$ %global __provides_exclude %{?__provides_exclude|%__provides_exclude|}^perl\\(MCE\\)$
%description %description
@ -46,6 +60,8 @@ the next n elements from the input stream to the next available worker.
%prep %prep
%setup -q -n MCE-%{version} %setup -q -n MCE-%{version}
%patch0 -p1
%patch1 -p1
chmod -c a-x examples/*pl chmod -c a-x examples/*pl
%build %build
@ -55,7 +71,6 @@ make %{?_smp_mflags}
%install %install
make pure_install DESTDIR=%{buildroot} make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} + find %{buildroot} -type f -name .packlist -exec rm -f {} +
install -m0755 -p bin/mce_grep -D %{buildroot}%{_bindir}/mce_grep
%{_fixperms} %{buildroot}/* %{_fixperms} %{buildroot}/*
%check %check
@ -68,6 +83,9 @@ make test
%{_mandir}/man3/* %{_mandir}/man3/*
%changelog %changelog
* Tue Feb 10 2015 Petr Pisar <ppisar@redhat.com> - 1.600-2
- Correct dependencies
* Wed Feb 04 2015 Petr Šabata <contyk@redhat.com> - 1.600-1 * Wed Feb 04 2015 Petr Šabata <contyk@redhat.com> - 1.600-1
- 1.600 bump - 1.600 bump

Loading…
Cancel
Save