c8-stream-5.24
imports/c8-stream-5.24/perl-ExtUtils-ParseXS-3.31-369.module+el8.1.0+2926+ce7246ad
commit
24f56761a4
@ -0,0 +1 @@
|
|||||||
|
SOURCES/ExtUtils-ParseXS-3.30.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
b44ef93e1357a47b6f3aee3684f1a63dc2abf207 SOURCES/ExtUtils-ParseXS-3.30.tar.gz
|
@ -0,0 +1,139 @@
|
|||||||
|
diff --git a/lib/ExtUtils/ParseXS.pm b/lib/ExtUtils/ParseXS.pm
|
||||||
|
index f67a82d..32d74e1 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS.pm
|
||||||
|
@@ -11,7 +11,7 @@ use Symbol;
|
||||||
|
|
||||||
|
our $VERSION;
|
||||||
|
BEGIN {
|
||||||
|
- $VERSION = '3.30';
|
||||||
|
+ $VERSION = '3.31';
|
||||||
|
}
|
||||||
|
use ExtUtils::ParseXS::Constants $VERSION;
|
||||||
|
use ExtUtils::ParseXS::CountLines $VERSION;
|
||||||
|
@@ -579,7 +579,7 @@ EOF
|
||||||
|
} );
|
||||||
|
}
|
||||||
|
else {
|
||||||
|
- print "\t$class *";
|
||||||
|
+ print "\t" . map_type($self, "$class *");
|
||||||
|
$self->{var_types}->{"THIS"} = "$class *";
|
||||||
|
$self->generate_init( {
|
||||||
|
type => "$class *",
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Constants.pm b/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
index 8856551..2319a24 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
@@ -3,7 +3,7 @@ use strict;
|
||||||
|
use warnings;
|
||||||
|
use Symbol;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/CountLines.pm b/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
index 2f45292..222a95c 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
package ExtUtils::ParseXS::CountLines;
|
||||||
|
use strict;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
our $SECTION_END_MARKER;
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Eval.pm b/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
index 8c075a3..7315332 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::ParseXS::Eval;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Utilities.pm b/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
index 4de9f4e..41a9f6d 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
@@ -5,7 +5,7 @@ use Exporter;
|
||||||
|
use File::Spec;
|
||||||
|
use ExtUtils::ParseXS::Constants ();
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
our (@ISA, @EXPORT_OK);
|
||||||
|
@ISA = qw(Exporter);
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps.pm b/lib/ExtUtils/Typemaps.pm
|
||||||
|
index a16ae06..48d623e 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
require ExtUtils::ParseXS;
|
||||||
|
require ExtUtils::ParseXS::Constants;
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/Cmd.pm b/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
index ccd5efe..ffed504 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::Cmd;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
use ExtUtils::Typemaps;
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/InputMap.pm b/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
index 67ea1c2..86c646d 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::InputMap;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/OutputMap.pm b/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
index 42cbe5c..32cf9f9 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::OutputMap;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/Type.pm b/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
index 7e0f4ba..abe93cb 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
@@ -4,7 +4,7 @@ use strict;
|
||||||
|
use warnings;
|
||||||
|
require ExtUtils::Typemaps;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
@ -0,0 +1,10 @@
|
|||||||
|
diff -up ExtUtils-ParseXS/lib/ExtUtils/xsubpp.cve ExtUtils-ParseXS/lib/ExtUtils/xsubpp
|
||||||
|
--- ExtUtils-ParseXS/lib/ExtUtils/xsubpp.cve 2016-02-05 16:26:05.000000000 +0100
|
||||||
|
+++ ExtUtils-ParseXS/lib/ExtUtils/xsubpp 2016-08-02 13:39:39.791316159 +0200
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
#!perl
|
||||||
|
use 5.006;
|
||||||
|
+BEGIN { pop @INC if $INC[-1] eq '.' }
|
||||||
|
use strict;
|
||||||
|
eval {
|
||||||
|
require ExtUtils::ParseXS;
|
@ -0,0 +1,149 @@
|
|||||||
|
%global base_version 3.30
|
||||||
|
Name: perl-ExtUtils-ParseXS
|
||||||
|
# Epoch to compete with perl.spec
|
||||||
|
Epoch: 1
|
||||||
|
Version: 3.31
|
||||||
|
Release: 369%{?dist}
|
||||||
|
Summary: Module and a script for converting Perl XS code into C code
|
||||||
|
License: GPL+ or Artistic
|
||||||
|
Group: Development/Libraries
|
||||||
|
URL: http://search.cpan.org/dist/ExtUtils-ParseXS/
|
||||||
|
Source0: http://www.cpan.org/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-%{base_version}.tar.gz
|
||||||
|
# Unbundled from perl 5.24.0
|
||||||
|
Patch0: ExtUtils-ParseXS-3.30-Upgrade-to-3.31.patch
|
||||||
|
# Avoid loading optional modules from default . (CVE-2016-1238)
|
||||||
|
Patch1: ExtUtils-ParseXS-3.31-CVE-2016-1238-avoid-loading-optional-modules-from.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: coreutils
|
||||||
|
BuildRequires: findutils
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: perl
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(Config)
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.46
|
||||||
|
BuildRequires: perl(File::Spec)
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
# Run-time:
|
||||||
|
BuildRequires: perl(Cwd)
|
||||||
|
BuildRequires: perl(Exporter) >= 5.57
|
||||||
|
# ExtUtils::XSSymSet not needed
|
||||||
|
BuildRequires: perl(File::Basename)
|
||||||
|
# Getopt::Long not tested
|
||||||
|
BuildRequires: perl(re)
|
||||||
|
BuildRequires: perl(Symbol)
|
||||||
|
# Tests:
|
||||||
|
BuildRequires: perl(attributes)
|
||||||
|
BuildRequires: perl(Carp)
|
||||||
|
BuildRequires: perl(DynaLoader)
|
||||||
|
BuildRequires: perl(ExtUtils::CBuilder)
|
||||||
|
BuildRequires: perl(File::Temp)
|
||||||
|
BuildRequires: perl(lib)
|
||||||
|
BuildRequires: perl(overload)
|
||||||
|
BuildRequires: perl(Test::More) >= 0.47
|
||||||
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||||
|
Requires: perl(Exporter) >= 5.57
|
||||||
|
|
||||||
|
# Remove under-specified dependencies
|
||||||
|
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Exporter\\)$
|
||||||
|
|
||||||
|
%description
|
||||||
|
ExtUtils::ParseXS will compile XS code into C code by embedding the
|
||||||
|
constructs necessary to let C functions manipulate Perl values and creates
|
||||||
|
the glue necessary to let Perl access those functions.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n ExtUtils-ParseXS-%{base_version}
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
find $RPM_BUILD_ROOT -type f -name .packlist -delete
|
||||||
|
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||||
|
# Do not install xsubpp twice, RT#117289
|
||||||
|
rm $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/xsubpp
|
||||||
|
ln -s ../../../../bin/xsubpp $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc Changes README
|
||||||
|
%{_bindir}/*
|
||||||
|
%{perl_vendorlib}/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 29 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.31-369
|
||||||
|
- Rebuild with enable hardening (bug #1636329)
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.31-368
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Sep 13 2016 Petr Pisar <ppisar@redhat.com> - 1:3.31-367
|
||||||
|
- Remove old obsoleting perl-ExtUtils-Typemaps
|
||||||
|
|
||||||
|
* Wed Aug 03 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.31-366
|
||||||
|
- Avoid loading optional modules from default . (CVE-2016-1238)
|
||||||
|
|
||||||
|
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.31-365
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Wed May 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.31-1
|
||||||
|
- 3.31 bump in order to dual-live with perl 5.24
|
||||||
|
|
||||||
|
* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 1:3.30-3
|
||||||
|
- Remove dependency on perl-devel (bug #1129443)
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.30-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 31 2015 Petr Pisar <ppisar@redhat.com> - 1:3.30-1
|
||||||
|
- 3.30 bump
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.28-346
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.28-345
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.28-2
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Wed May 06 2015 Petr Pisar <ppisar@redhat.com> - 1:3.28-1
|
||||||
|
- 3.28 bump in order to dual-live with perl 5.22
|
||||||
|
|
||||||
|
* Tue Aug 26 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.24-310
|
||||||
|
- Perl 5.20 rebuild
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.24-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 10 2014 Petr Pisar <ppisar@redhat.com> - 1:3.24-1
|
||||||
|
- 3.24 bump
|
||||||
|
|
||||||
|
* Mon Sep 02 2013 Petr Pisar <ppisar@redhat.com> - 1:3.22-1
|
||||||
|
- 3.22 bump
|
||||||
|
|
||||||
|
* Mon Aug 26 2013 Petr Pisar <ppisar@redhat.com> - 1:3.21-1
|
||||||
|
- 3.21 bump
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.18-291
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 15 2013 Petr Pisar <ppisar@redhat.com> - 1:3.18-290
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:3.18-2
|
||||||
|
- Perl 5.18 rebuild
|
||||||
|
|
||||||
|
* Fri Mar 22 2013 Petr Pisar <ppisar@redhat.com> 1:3.18-1
|
||||||
|
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in new issue