c8-stream-5.26
imports/c8-stream-5.26/perl-ExtUtils-CBuilder-0.280230-2.module_el8.1.0+225+978beb03
commit
b16d1bf727
@ -0,0 +1 @@
|
|||||||
|
SOURCES/ExtUtils-CBuilder-0.280230.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
c3198a6136649bda7da9a5599562d0627bfdee8e SOURCES/ExtUtils-CBuilder-0.280230.tar.gz
|
@ -0,0 +1,64 @@
|
|||||||
|
From f55b546a261651ad76a2a339768a599a4d84b4f5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
|
Date: Wed, 3 Jul 2013 11:01:02 +0200
|
||||||
|
Subject: [PATCH] Link XS modules to libperl.so with EU::CBuilder on Linux
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
<https://bugzilla.redhat.com/show_bug.cgi?id=960048>
|
||||||
|
<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=327585#50>
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
---
|
||||||
|
MANIFEST | 1 +
|
||||||
|
lib/ExtUtils/CBuilder/Platform/linux.pm | 25 +++++++++++++++++++++++++
|
||||||
|
2 files changed, 26 insertions(+)
|
||||||
|
create mode 100644 lib/ExtUtils/CBuilder/Platform/linux.pm
|
||||||
|
|
||||||
|
diff --git a/MANIFEST b/MANIFEST
|
||||||
|
index fdc8bd9..a7de63a 100644
|
||||||
|
--- a/MANIFEST
|
||||||
|
+++ b/MANIFEST
|
||||||
|
@@ -25,6 +25,7 @@ lib/ExtUtils/CBuilder/Platform/android.pm
|
||||||
|
lib/ExtUtils/CBuilder/Platform/cygwin.pm
|
||||||
|
lib/ExtUtils/CBuilder/Platform/darwin.pm
|
||||||
|
lib/ExtUtils/CBuilder/Platform/dec_osf.pm
|
||||||
|
+lib/ExtUtils/CBuilder/Platform/linux.pm
|
||||||
|
lib/ExtUtils/CBuilder/Platform/os2.pm
|
||||||
|
t/00-have-compiler.t
|
||||||
|
t/01-basic.t
|
||||||
|
diff --git a/lib/ExtUtils/CBuilder/Platform/linux.pm b/lib/ExtUtils/CBuilder/Platform/linux.pm
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..823f852
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/lib/ExtUtils/CBuilder/Platform/linux.pm
|
||||||
|
@@ -0,0 +1,25 @@
|
||||||
|
+package ExtUtils::CBuilder::Platform::linux;
|
||||||
|
+
|
||||||
|
+use strict;
|
||||||
|
+use ExtUtils::CBuilder::Platform::Unix;
|
||||||
|
+use File::Spec;
|
||||||
|
+
|
||||||
|
+our $VERSION = '0.280230';
|
||||||
|
+our @ISA = qw(ExtUtils::CBuilder::Platform::Unix);
|
||||||
|
+
|
||||||
|
+sub link {
|
||||||
|
+ my ($self, %args) = @_;
|
||||||
|
+ my $cf = $self->{config};
|
||||||
|
+
|
||||||
|
+ # Link XS modules to libperl.so explicitly because multiple
|
||||||
|
+ # dlopen(, RTLD_LOCAL) hides libperl symbols from XS module.
|
||||||
|
+ local $cf->{lddlflags} = $cf->{lddlflags};
|
||||||
|
+ if ($ENV{PERL_CORE}) {
|
||||||
|
+ $cf->{lddlflags} .= ' -L' . $self->perl_inc();
|
||||||
|
+ }
|
||||||
|
+ $cf->{lddlflags} .= ' -lperl';
|
||||||
|
+
|
||||||
|
+ return $self->SUPER::link(%args);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+1;
|
||||||
|
--
|
||||||
|
2.13.6
|
||||||
|
|
@ -0,0 +1,125 @@
|
|||||||
|
Name: perl-ExtUtils-CBuilder
|
||||||
|
# Compete with perl.spec
|
||||||
|
Epoch: 1
|
||||||
|
# Mimic perl.spec
|
||||||
|
Version: 0.280230
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: Compile and link C code for Perl modules
|
||||||
|
License: GPL+ or Artistic
|
||||||
|
URL: http://search.cpan.org/dist/ExtUtils-CBuilder/
|
||||||
|
Source0: http://www.cpan.org/authors/id/A/AM/AMBS/ExtUtils-CBuilder-%{version}.tar.gz
|
||||||
|
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
||||||
|
Patch0: ExtUtils-CBuilder-0.280230-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: perl-interpreter
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
# Run-time:
|
||||||
|
BuildRequires: perl(Config)
|
||||||
|
BuildRequires: perl(Cwd)
|
||||||
|
BuildRequires: perl(DynaLoader)
|
||||||
|
# ExtUtils::Mksymlists 6.30 not used at test time
|
||||||
|
BuildRequires: perl(File::Basename)
|
||||||
|
BuildRequires: perl(File::Path)
|
||||||
|
BuildRequires: perl(File::Spec) >= 3.13
|
||||||
|
# File::Spec::Functions not used at test time
|
||||||
|
BuildRequires: perl(File::Temp)
|
||||||
|
# IO::File not used at test time
|
||||||
|
BuildRequires: perl(IPC::Cmd)
|
||||||
|
BuildRequires: perl(Perl::OSType) >= 1
|
||||||
|
BuildRequires: perl(Text::ParseWords)
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
# Tests:
|
||||||
|
BuildRequires: perl(Test::More) >= 0.47
|
||||||
|
# vmsish not used
|
||||||
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||||
|
Requires: perl(DynaLoader)
|
||||||
|
Requires: perl(ExtUtils::Mksymlists) >= 6.30
|
||||||
|
Requires: perl(File::Spec) >= 3.13
|
||||||
|
Requires: perl(Perl::OSType) >= 1
|
||||||
|
Requires: perl-devel
|
||||||
|
|
||||||
|
%{?perl_default_filter}
|
||||||
|
# Remove under-specified dependencies
|
||||||
|
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\((File::Spec|Perl::OSType)\\)$
|
||||||
|
|
||||||
|
%description
|
||||||
|
This module can build the C portions of Perl modules by invoking the
|
||||||
|
appropriate compilers and linkers in a cross-platform manner. It was motivated
|
||||||
|
by the Module::Build project, but may be useful for other purposes as well.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n ExtUtils-CBuilder-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE
|
||||||
|
%doc Changes CONTRIBUTING README README.mkdn
|
||||||
|
%{perl_vendorlib}/*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:0.280230-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 23 2017 Petr Pisar <ppisar@redhat.com> - 1:0.280230-1
|
||||||
|
- 0.280230 bump
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:0.280226-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 17 2017 Petr Pisar <ppisar@redhat.com> - 1:0.280226-1
|
||||||
|
- 0.280226 bump
|
||||||
|
|
||||||
|
* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280225-393
|
||||||
|
- Perl 5.26 rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:0.280225-366
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280225-365
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Wed May 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280225-1
|
||||||
|
- 0.280225 bump in order to dual-live with perl 5.24
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:0.280224-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Oct 12 2015 Petr Pisar <ppisar@redhat.com> - 1:0.280224-1
|
||||||
|
- 0.280224 bump
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.280223-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280223-2
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Thu Jun 04 2015 Petr Pisar <ppisar@redhat.com> - 1:0.280223-1
|
||||||
|
- 0.280223 bump
|
||||||
|
|
||||||
|
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280221-2
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Wed May 06 2015 Petr Pisar <ppisar@redhat.com> - 1:0.280221-1
|
||||||
|
- 0.280221 bump in order to dual-live with perl 5.22
|
||||||
|
|
||||||
|
* Mon Nov 03 2014 Petr Pisar <ppisar@redhat.com> - 1:0.280220-1
|
||||||
|
- 0.280220 bump
|
||||||
|
|
||||||
|
* Thu Sep 18 2014 Petr Pisar <ppisar@redhat.com> - 1:0.280219-1
|
||||||
|
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in new issue