0.082841 bump

epel9
Jitka Plesnikova 7 years ago
parent db25aa5f78
commit 3a94703fbf

1
.gitignore vendored

@ -15,3 +15,4 @@ DBIx-Class-0.08120.tar.gz
/DBIx-Class-0.082820.tar.gz
/DBIx-Class-0.082821.tar.gz
/DBIx-Class-0.082840.tar.gz
/DBIx-Class-0.082841.tar.gz

@ -1,65 +0,0 @@
From c7eadcc1944540c7fdd8ab8da88b4ba97e64eb0d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Wed, 7 Jun 2017 09:15:58 +0200
Subject: [PATCH] Convert README to UTF-8
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
List of authors in README was a mix of UTF-8 and ISO-8859-1 encodings.
This patch normalizes it to UTF-8.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
README | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/README b/README
index 2371fde..f53068f 100644
--- a/README
+++ b/README
@@ -238,7 +238,7 @@ AUTHORS
ash: Ash Berlin <ash@cpan.org>
- bert: Norbert Csongrádi <bert@cpan.org>
+ bert: Norbert Csongrádi <bert@cpan.org>
bfwg: Colin Newell <colin.newell@gmail.com>
@@ -356,9 +356,9 @@ AUTHORS
idn: Ian Norton <i.norton@shadowcat.co.uk>
- ilmari: Dagfinn Ilmari Mannsåker <ilmari@ilmari.org>
+ ilmari: Dagfinn Ilmari Mannsåker <ilmari@ilmari.org>
- ingy: Ingy döt Net <ingy@ingy.net>
+ ingy: Ingy döt Net <ingy@ingy.net>
initself: Mike Baas <mike@initselftech.com>
@@ -478,7 +478,7 @@ AUTHORS
ovid: Curtis "Ovid" Poe <ovid@cpan.org>
- oyse: Øystein Torget <oystein.torget@dnv.com>
+ oyse: Øystein Torget <oystein.torget@dnv.com>
paulm: Paul Makepeace <paulm+pause@paulm.com>
@@ -486,9 +486,9 @@ AUTHORS
perigrin: Chris Prather <chris@prather.org>
- Peter Siklósi <einon@einon.hu>
+ Peter Siklósi <einon@einon.hu>
- Peter Valdemar Mørch <peter@morch.com>
+ Peter Valdemar Mørch <peter@morch.com>
peter: Peter Collingbourne <peter@pcc.me.uk>
--
2.9.4

@ -1,8 +0,0 @@
diff -up DBIx-Class-0.082840/Makefile.PL.orig DBIx-Class-0.082840/Makefile.PL
--- DBIx-Class-0.082840/Makefile.PL.orig 2017-05-26 10:29:28.090609173 +0200
+++ DBIx-Class-0.082840/Makefile.PL 2017-05-26 10:29:52.467466333 +0200
@@ -1,3 +1,4 @@
+BEGIN { push @INC, '.'; }
use strict;
use warnings;

@ -1,37 +0,0 @@
From adcc1df0049e0093cb94c867bd2be8c9fe242a61 Mon Sep 17 00:00:00 2001
From: Peter Rabbitson <ribasushi@cpan.org>
Date: Tue, 13 Sep 2016 17:15:48 +0200
Subject: [PATCH] Fix for upcoming (not yet available via DBD::SQLite)
libsqlite version
---
Changes | 2 ++
t/prefetch/grouped.t | 2 +-
2 files changed, 3 insertions(+), 1 deletion(-)
#diff --git a/Changes b/Changes
#index 72d7647..e402e5a 100644
#--- a/Changes
#+++ b/Changes
#@@ -73,6 +73,8 @@ Revision history for DBIx::Class
# working with copy() in t/icdt/engine_specific/sybase.t (GH#84)
# - Fix t/54taint.t failing on local::lib's with upgraded Carp on 5.8.*
# - Fix invalid variable names in ResultSource::View examples
#+ - Fix missing ORDER BY leading to failures of t/prefetch/grouped.t
#+ under upcoming libsqlite (RT#117271)
# - Skip tests in a way more intelligent and speedy manner when optional
# dependencies are missing
# - Make the Optional::Dependencies error messages cpanm-friendly
diff --git a/t/prefetch/grouped.t b/t/prefetch/grouped.t
index 4aad6b1..c0d2224 100644
--- a/t/prefetch/grouped.t
+++ b/t/prefetch/grouped.t
@@ -100,7 +100,7 @@ my @cdids = sort $cd_rs->get_column ('cdid')->all;
# add an extra track to one of the cds, and then make sure we can get it on top
# (check if limit works)
- my $top_cd = $cd_rs->slice (1,1)->next;
+ my $top_cd = $cd_rs->search({}, { order_by => 'cdid' })->slice (1,1)->next;
$top_cd->create_related ('tracks', {
title => 'over the top',
});

@ -1,48 +0,0 @@
Description: Drop test which expected SQLite behaviour from before 3.14
Cf. https://rt.cpan.org/Public/Bug/Display.html?id=118395#txn-1676851
.
Thanks to Peter Rabbitson for the help.
Origin: vendor
Bug-Debian: https://bugs.debian.org/841573
Forwarded: not-needed
Author: gregor herrmann <gregoa@debian.org>
Last-Update: 2016-10-21
--- a/t/resultset/update_delete.t
+++ b/t/resultset/update_delete.t
@@ -138,35 +138,6 @@
], 'Correct null-delete-SQL with multijoin without pruning' );
-# try the same sql with forced multicolumn in
-$schema->is_executed_sql_bind( sub {
- local $schema->storage->{_use_multicolumn_in} = 1;
-
- # this can't actually execute on sqlite
- eval { $fks_multi->update ({ read_count => \ 'read_count + 1' }) };
-}, [[
- 'UPDATE fourkeys
- SET read_count = read_count + 1
- WHERE (
- (foo, bar, hello, goodbye) IN (
- SELECT me.foo, me.bar, me.hello, me.goodbye
- FROM fourkeys me
- LEFT JOIN fourkeys_to_twokeys fourkeys_to_twokeys ON
- fourkeys_to_twokeys.f_bar = me.bar
- AND fourkeys_to_twokeys.f_foo = me.foo
- AND fourkeys_to_twokeys.f_goodbye = me.goodbye
- AND fourkeys_to_twokeys.f_hello = me.hello
- WHERE ( bar = ? OR bar = ? ) AND ( foo = ? OR foo = ? ) AND fourkeys_to_twokeys.pilot_sequence != ? AND ( goodbye = ? OR goodbye = ? ) AND ( hello = ? OR hello = ? ) AND sensors != ?
- ORDER BY foo, bar, hello, goodbye
- )
- )
- ',
- ( 1, 2) x 2,
- 666,
- ( 1, 2) x 2,
- 'c',
-]], 'Correct update-SQL with multicolumn in support' );
-
$schema->is_executed_sql_bind( sub {
$fks->search({ 'twokeys.artist' => { '!=' => 666 } })->update({ read_count => \ 'read_count + 1' });
}, [

@ -1,23 +1,14 @@
Name: perl-DBIx-Class
Summary: Extensible and flexible object <-> relational mapper
Version: 0.082840
Release: 9%{?dist}
Version: 0.082841
Release: 1%{?dist}
License: GPL+ or Artistic
Group: Development/Libraries
Source0: http://search.cpan.org/CPAN/authors/id/R/RI/RIBASUSHI/DBIx-Class-%{version}.tar.gz
URL: http://search.cpan.org/dist/DBIx-Class/
# Fix missing ORDER BY leading to failures of t/prefetch/grouped.t under
# upcoming libsqlite (RT#117271)
Patch0: DBIx-Class-0.082840-Fix-test-RT117271.patch
# Disable a test incompatible with sqlite >= 3.14, CPAN RT#119845
Patch1: DBIx-Class-0.082840-sqlite-3.14.patch
# Fix building on Perl without '.' in @INC
Patch2: DBIx-Class-0.082840-Fix-building-on-Perl-without-dot-in-INC.patch
# Fix README encoding, CPAN RT#122028
Patch3: DBIx-Class-0.082840-Convert-README-to-UTF-8.patch
# Do not use /usr/bin/env in shell bangs, upstream does not agree
# (see Changes)
Patch4: DBIx-Class-0.082840-Do-not-use-usr-bin-env-in-shell-bangs.patch
Patch0: DBIx-Class-0.082840-Do-not-use-usr-bin-env-in-shell-bangs.patch
BuildArch: noarch
# Build
BuildRequires: coreutils
@ -280,10 +271,6 @@ DISTINCT, GROUP BY and HAVING support.
%prep
%setup -q -n DBIx-Class-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
chmod -c +x script/*
# skip dbic_pretty.t when bootstrapping
%if 0%{?perl_bootstrap}
@ -314,6 +301,9 @@ make test
%{_mandir}/man[13]/*
%changelog
* Mon Jan 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.082841-1
- 0.082841 bump
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.082840-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

@ -1 +1 @@
549aac47388a616b126c8e27f9eb9f88 DBIx-Class-0.082840.tar.gz
SHA512 (DBIx-Class-0.082841.tar.gz) = a9c54c0cdb7a2dc93a4b3acb90974e6db80d5eaa95c723c0c3895c99b53be00ed182d4cdc6c5350ee7f120f29172c06494d5c647b8eb4643b91387c0ffee694b

Loading…
Cancel
Save