parent
db25aa5f78
commit
3a94703fbf
@ -1,8 +0,0 @@
|
|||||||
diff -up DBIx-Class-0.082840/Makefile.PL.orig DBIx-Class-0.082840/Makefile.PL
|
|
||||||
--- DBIx-Class-0.082840/Makefile.PL.orig 2017-05-26 10:29:28.090609173 +0200
|
|
||||||
+++ DBIx-Class-0.082840/Makefile.PL 2017-05-26 10:29:52.467466333 +0200
|
|
||||||
@@ -1,3 +1,4 @@
|
|
||||||
+BEGIN { push @INC, '.'; }
|
|
||||||
use strict;
|
|
||||||
use warnings;
|
|
||||||
|
|
@ -1,37 +0,0 @@
|
|||||||
From adcc1df0049e0093cb94c867bd2be8c9fe242a61 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Rabbitson <ribasushi@cpan.org>
|
|
||||||
Date: Tue, 13 Sep 2016 17:15:48 +0200
|
|
||||||
Subject: [PATCH] Fix for upcoming (not yet available via DBD::SQLite)
|
|
||||||
libsqlite version
|
|
||||||
|
|
||||||
---
|
|
||||||
Changes | 2 ++
|
|
||||||
t/prefetch/grouped.t | 2 +-
|
|
||||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
#diff --git a/Changes b/Changes
|
|
||||||
#index 72d7647..e402e5a 100644
|
|
||||||
#--- a/Changes
|
|
||||||
#+++ b/Changes
|
|
||||||
#@@ -73,6 +73,8 @@ Revision history for DBIx::Class
|
|
||||||
# working with copy() in t/icdt/engine_specific/sybase.t (GH#84)
|
|
||||||
# - Fix t/54taint.t failing on local::lib's with upgraded Carp on 5.8.*
|
|
||||||
# - Fix invalid variable names in ResultSource::View examples
|
|
||||||
#+ - Fix missing ORDER BY leading to failures of t/prefetch/grouped.t
|
|
||||||
#+ under upcoming libsqlite (RT#117271)
|
|
||||||
# - Skip tests in a way more intelligent and speedy manner when optional
|
|
||||||
# dependencies are missing
|
|
||||||
# - Make the Optional::Dependencies error messages cpanm-friendly
|
|
||||||
diff --git a/t/prefetch/grouped.t b/t/prefetch/grouped.t
|
|
||||||
index 4aad6b1..c0d2224 100644
|
|
||||||
--- a/t/prefetch/grouped.t
|
|
||||||
+++ b/t/prefetch/grouped.t
|
|
||||||
@@ -100,7 +100,7 @@ my @cdids = sort $cd_rs->get_column ('cdid')->all;
|
|
||||||
|
|
||||||
# add an extra track to one of the cds, and then make sure we can get it on top
|
|
||||||
# (check if limit works)
|
|
||||||
- my $top_cd = $cd_rs->slice (1,1)->next;
|
|
||||||
+ my $top_cd = $cd_rs->search({}, { order_by => 'cdid' })->slice (1,1)->next;
|
|
||||||
$top_cd->create_related ('tracks', {
|
|
||||||
title => 'over the top',
|
|
||||||
});
|
|
@ -1,48 +0,0 @@
|
|||||||
Description: Drop test which expected SQLite behaviour from before 3.14
|
|
||||||
Cf. https://rt.cpan.org/Public/Bug/Display.html?id=118395#txn-1676851
|
|
||||||
.
|
|
||||||
Thanks to Peter Rabbitson for the help.
|
|
||||||
Origin: vendor
|
|
||||||
Bug-Debian: https://bugs.debian.org/841573
|
|
||||||
Forwarded: not-needed
|
|
||||||
Author: gregor herrmann <gregoa@debian.org>
|
|
||||||
Last-Update: 2016-10-21
|
|
||||||
|
|
||||||
--- a/t/resultset/update_delete.t
|
|
||||||
+++ b/t/resultset/update_delete.t
|
|
||||||
@@ -138,35 +138,6 @@
|
|
||||||
], 'Correct null-delete-SQL with multijoin without pruning' );
|
|
||||||
|
|
||||||
|
|
||||||
-# try the same sql with forced multicolumn in
|
|
||||||
-$schema->is_executed_sql_bind( sub {
|
|
||||||
- local $schema->storage->{_use_multicolumn_in} = 1;
|
|
||||||
-
|
|
||||||
- # this can't actually execute on sqlite
|
|
||||||
- eval { $fks_multi->update ({ read_count => \ 'read_count + 1' }) };
|
|
||||||
-}, [[
|
|
||||||
- 'UPDATE fourkeys
|
|
||||||
- SET read_count = read_count + 1
|
|
||||||
- WHERE (
|
|
||||||
- (foo, bar, hello, goodbye) IN (
|
|
||||||
- SELECT me.foo, me.bar, me.hello, me.goodbye
|
|
||||||
- FROM fourkeys me
|
|
||||||
- LEFT JOIN fourkeys_to_twokeys fourkeys_to_twokeys ON
|
|
||||||
- fourkeys_to_twokeys.f_bar = me.bar
|
|
||||||
- AND fourkeys_to_twokeys.f_foo = me.foo
|
|
||||||
- AND fourkeys_to_twokeys.f_goodbye = me.goodbye
|
|
||||||
- AND fourkeys_to_twokeys.f_hello = me.hello
|
|
||||||
- WHERE ( bar = ? OR bar = ? ) AND ( foo = ? OR foo = ? ) AND fourkeys_to_twokeys.pilot_sequence != ? AND ( goodbye = ? OR goodbye = ? ) AND ( hello = ? OR hello = ? ) AND sensors != ?
|
|
||||||
- ORDER BY foo, bar, hello, goodbye
|
|
||||||
- )
|
|
||||||
- )
|
|
||||||
- ',
|
|
||||||
- ( 1, 2) x 2,
|
|
||||||
- 666,
|
|
||||||
- ( 1, 2) x 2,
|
|
||||||
- 'c',
|
|
||||||
-]], 'Correct update-SQL with multicolumn in support' );
|
|
||||||
-
|
|
||||||
$schema->is_executed_sql_bind( sub {
|
|
||||||
$fks->search({ 'twokeys.artist' => { '!=' => 666 } })->update({ read_count => \ 'read_count + 1' });
|
|
||||||
}, [
|
|
Loading…
Reference in new issue