parent
d088931814
commit
6153275e98
@ -1,25 +0,0 @@
|
||||
From 542d5568578c8a603833d135b2d5caf5f29781b0 Mon Sep 17 00:00:00 2001
|
||||
From: "Jason A. Donenfeld" <Jason@zx2c4.com>
|
||||
Date: Mon, 14 Apr 2014 15:03:56 +0200
|
||||
Subject: [PATCH 1/2] Install bash-completion file to the right place.
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ff9b450..df9d68a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -15,7 +15,7 @@ install-pass:
|
||||
@mkdir -p "$(DESTDIR)$(BINDIR)" "$(DESTDIR)$(LIBDIR)" "$(DESTDIR)$(MANDIR)/man1" "$(DESTDIR)$(PREFIX)/share/bash-completion/completions/"
|
||||
@install -m 0755 -v src/password-store.sh "$(DESTDIR)$(BINDIR)/pass"
|
||||
@install -m 0644 -v man/pass.1 "$(DESTDIR)$(MANDIR)/man1/pass.1"
|
||||
- @install -m 0644 -v src/completion/pass.bash-completion "$(DESTDIR)$(PREFIX)/share/bash-completion/completions/password-store"
|
||||
+ @install -m 0644 -v src/completion/pass.bash-completion "$(DESTDIR)$(PREFIX)/share/bash-completion/completions/pass"
|
||||
|
||||
# Uncomment to install the zsh completion file.
|
||||
# @install -m 0644 -v src/completion/pass.zsh-completion "$(DESTDIR)$(PREFIX)/share/zsh/site-functions/_pass"
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,22 +0,0 @@
|
||||
From 775c305331a674ceb42c7a2e931e459a6b44b719 Mon Sep 17 00:00:00 2001
|
||||
From: schalox <schalox@gmail.com>
|
||||
Date: Sat, 19 Apr 2014 08:20:21 +0300
|
||||
Subject: [PATCH 2/2] bash-completion: fix completion-file's name in uninstall
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index df9d68a..f82b9cf 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -33,4 +33,4 @@ install: install-pass
|
||||
endif
|
||||
|
||||
uninstall:
|
||||
- @rm -vf "$(DESTDIR)$(BINDIR)/pass" "$(DESTDIR)$(MANDIR)/man1/pass.1" "$(DESTDIR)$(PREFIX)/share/bash-completion/completions/password-store" "$(DESTDIR)$(LIBDIR)/password-store.platform.sh"
|
||||
+ @rm -vf "$(DESTDIR)$(BINDIR)/pass" "$(DESTDIR)$(MANDIR)/man1/pass.1" "$(DESTDIR)$(PREFIX)/share/bash-completion/completions/pass" "$(DESTDIR)$(LIBDIR)/password-store.platform.sh"
|
||||
--
|
||||
1.9.0
|
||||
|
Loading…
Reference in new issue