Update to 1.7.0

- Fixed openvswitch-configure-ovskmod-var-autoconfd.patch because
  openvswitch kernel module name changed in 1.7.0
- Removed Source8: ovsdbmonitor-move-to-its-own-data-directory.patch
- Patches merged:
  - ovsdbmonitor-move-to-its-own-data-directory-automaked.patch
  - openvswitch-rhel-initscripts-resync.patch
f38
Tomas Hozza 13 years ago
parent ed0284a339
commit df6fb525c8

1
.gitignore vendored

@ -1 +1,2 @@
/openvswitch-1.4.0.tar.gz
/openvswitch-1.7.0.tar.gz

@ -1,12 +1,7 @@
This is the autoconf'd result of applying
openvswitch-configure-ovskmod-var.patch.
It updates configure and .in files directly,
rather than their sources.
diff -aru openvswitch-1.4.0.orig/configure openvswitch-1.4.0/configure
--- openvswitch-1.4.0.orig/configure 2012-01-30 23:09:16.000000000 -0800
+++ openvswitch-1.4.0/configure 2012-02-29 21:23:09.397779430 -0800
@@ -599,6 +607,7 @@
diff -up openvswitch-1.7.0/configure.ovskmod openvswitch-1.7.0/configure
--- openvswitch-1.7.0/configure.ovskmod 2012-07-31 08:10:35.000000000 +0200
+++ openvswitch-1.7.0/configure 2012-08-17 10:35:33.251844453 +0200
@@ -607,6 +607,7 @@ am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
LIBOBJS
@ -14,7 +9,7 @@ diff -aru openvswitch-1.4.0.orig/configure openvswitch-1.4.0/configure
LINUX_ENABLED_FALSE
LINUX_ENABLED_TRUE
KBUILD
@@ -757,7 +766,8 @@
@@ -767,7 +768,8 @@ PKG_CONFIG_PATH
PKG_CONFIG_LIBDIR
SSL_CFLAGS
SSL_LIBS
@ -24,31 +19,31 @@ diff -aru openvswitch-1.4.0.orig/configure openvswitch-1.4.0/configure
# Initialize some variables set by options.
@@ -1417,6 +1427,7 @@
@@ -1427,6 +1429,7 @@ Some influential environment variables:
SSL_CFLAGS C compiler flags for SSL, overriding pkg-config
SSL_LIBS linker flags for SSL, overriding pkg-config
KARCH Kernel Architecture String
+ OVSKMOD Open vSwitch kernel module name (default openvswitch_mod)
+ OVSKMOD Open vSwitch kernel module name (default openvswitch)
Use these variables to override the choices made by `configure' or to help
it to find libraries and programs with nonstandard names/locations.
@@ -7882,6 +7893,12 @@
@@ -7921,6 +7924,12 @@ fi
+
+if test "X$OVSKMOD" = "X"; then
+ OVSKMOD=openvswitch_mod
+ OVSKMOD=openvswitch
+fi
+
+
ac_config_files="$ac_config_files Makefile datapath/Makefile datapath/linux/Kbuild datapath/linux/Makefile datapath/linux/Makefile.main tests/atlocal"
diff -aru openvswitch-1.4.0.orig/datapath/Makefile.in openvswitch-1.4.0/datapath/Makefile.in
--- openvswitch-1.4.0.orig/datapath/Makefile.in 2012-01-30 23:09:16.000000000 -0800
+++ openvswitch-1.4.0/datapath/Makefile.in 2012-02-29 21:23:26.744028440 -0800
@@ -128,6 +128,7 @@
diff -up openvswitch-1.7.0/datapath/Makefile.in.ovskmod openvswitch-1.7.0/datapath/Makefile.in
--- openvswitch-1.7.0/datapath/Makefile.in.ovskmod 2012-07-31 08:10:36.000000000 +0200
+++ openvswitch-1.7.0/datapath/Makefile.in 2012-08-17 10:08:15.300517434 +0200
@@ -127,6 +127,7 @@ LTLIBOBJS = @LTLIBOBJS@
MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
OBJEXT = @OBJEXT@
@ -56,10 +51,10 @@ diff -aru openvswitch-1.4.0.orig/datapath/Makefile.in openvswitch-1.4.0/datapath
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
diff -aru openvswitch-1.4.0.orig/Makefile.in openvswitch-1.4.0/Makefile.in
--- openvswitch-1.4.0.orig/Makefile.in 2012-01-30 23:09:16.000000000 -0800
+++ openvswitch-1.4.0/Makefile.in 2012-02-29 21:23:27.070033119 -0800
@@ -875,6 +875,7 @@
diff -up openvswitch-1.7.0/Makefile.in.ovskmod openvswitch-1.7.0/Makefile.in
--- openvswitch-1.7.0/Makefile.in.ovskmod 2012-07-31 08:12:05.000000000 +0200
+++ openvswitch-1.7.0/Makefile.in 2012-08-17 10:23:02.024495532 +0200
@@ -927,6 +927,7 @@ LTLIBOBJS = @LTLIBOBJS@
MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
OBJEXT = @OBJEXT@
@ -67,55 +62,56 @@ diff -aru openvswitch-1.4.0.orig/Makefile.in openvswitch-1.4.0/Makefile.in
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
@@ -3634,6 +3635,7 @@
@@ -3793,6 +3794,7 @@ uninstall-man: uninstall-man1 uninstall-
-e 's,[@]PYTHON[@],$(PYTHON),g' \
-e 's,[@]RUNDIR[@],$(RUNDIR),g' \
-e 's,[@]VERSION[@],$(VERSION),g' \
-e 's,[@]BUILDNR[@],$(BUILDNR),g' \
+ -e 's,[@]OVSKMOD[@],$(OVSKMOD),g' \
-e 's,[@]localstatedir[@],$(localstatedir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
-e 's,[@]sysconfdir[@],$(sysconfdir),g' \
diff -aru openvswitch-1.4.0.orig/utilities/ovs-ctl.in openvswitch-1.4.0/utilities/ovs-ctl.in
--- openvswitch-1.4.0.orig/utilities/ovs-ctl.in 2012-01-30 23:08:18.000000000 -0800
+++ openvswitch-1.4.0/utilities/ovs-ctl.in 2012-02-29 21:22:49.206489585 -0800
@@ -31,14 +31,14 @@
diff -up openvswitch-1.7.0/utilities/ovs-ctl.in.ovskmod openvswitch-1.7.0/utilities/ovs-ctl.in
--- openvswitch-1.7.0/utilities/ovs-ctl.in.ovskmod 2012-07-31 08:05:48.000000000 +0200
+++ openvswitch-1.7.0/utilities/ovs-ctl.in 2012-08-17 10:48:08.874535857 +0200
@@ -31,15 +31,15 @@ done
## ----- ##
insert_openvswitch_mod_if_required () {
- # If openvswitch_mod is already loaded then we're done.
- test -e /sys/module/openvswitch_mod && return 0
- # If openvswitch is already loaded then we're done.
- test -e /sys/module/openvswitch -o -e /sys/module/openvswitch_mod && \
+ # If @OVSKMOD@ is already loaded then we're done.
+ test -e /sys/module/@OVSKMOD@ && return 0
+ test -e /sys/module/@OVSKMOD@ -o -e /sys/module/openvswitch_mod && \
return 0
- # Load openvswitch_mod. If that's successful then we're done.
- action "Inserting openvswitch module" modprobe openvswitch_mod && return 0
- # Load openvswitch. If that's successful then we're done.
- action "Inserting openvswitch module" modprobe openvswitch && return 0
+ # Load @OVSKMOD@. If that's successful then we're done.
+ action "Inserting openvswitch module" modprobe @OVSKMOD@ && return 0
# If the bridge module is loaded, then that might be blocking
- # openvswitch_mod. Try to unload it, if there are no bridges.
- # openvswitch. Try to unload it, if there are no bridges.
+ # @OVSKMOD@. Try to unload it, if there are no bridges.
test -e /sys/module/bridge || return 1
bridges=`echo /sys/class/net/*/bridge | sed 's,/sys/class/net/,,g;s,/bridge,,g'`
if test "$bridges" != "*"; then
@@ -47,8 +47,8 @@
@@ -48,8 +48,8 @@ insert_openvswitch_mod_if_required () {
fi
action "removing bridge module" rmmod bridge || return 1
- # Try loading openvswitch_mod again.
- action "Inserting openvswitch module" modprobe openvswitch_mod
- # Try loading openvswitch again.
- action "Inserting openvswitch module" modprobe openvswitch
+ # Try loading @OVSKMOD@ again.
+ action "Inserting openvswitch module" modprobe @OVSKMOD@
}
insert_brcompat_mod_if_required () {
@@ -285,8 +285,8 @@
if test -e /sys/module/brcompat_mod; then
action "Removing brcompat module" rmmod brcompat_mod
@@ -300,8 +300,8 @@ force_reload_kmod () {
fi
- if test -e /sys/module/openvswitch_mod; then
- action "Removing openvswitch module" rmmod openvswitch_mod
+ if test -e /sys/module/@OVSKMOD@; then
if test -e /sys/module/openvswitch_mod; then
action "Removing openvswitch module" rmmod openvswitch_mod
- elif test -e /sys/module/openvswitch; then
- action "Removing openvswitch module" rmmod openvswitch
+ elif test -e /sys/module/@OVSKMOD@; then
+ action "Removing openvswitch module" rmmod @OVSKMOD@
fi

@ -1,210 +0,0 @@
From 26fbdf773f546f653d67f1bf022ff9021cefc062 Mon Sep 17 00:00:00 2001
From: Gurucharan Shetty <gshetty@nicira.com>
Date: Fri, 20 Jan 2012 15:07:50 -0800
Subject: [PATCH] rhel: Correct an example in README.RHEL
Change the value of OVS_BRIDGE in an example to point
to the correct bridge name.
Signed-off-by: Gurucharan Shetty <gshetty@nicira.com>
---
rhel/README.RHEL | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/rhel/README.RHEL b/rhel/README.RHEL
index e6617ab..3e682b3 100644
--- a/rhel/README.RHEL
+++ b/rhel/README.RHEL
@@ -70,7 +70,7 @@ DEVICE=eth0
ONBOOT=yes
DEVICETYPE=ovs
TYPE=OVSPort
-OVS_BRIDGE=internet
+OVS_BRIDGE=ovsbridge0
BOOTPROTO=none
HOTPLUG=no
--
1.7.7.6
From 5442edb9e0afb6fdc4cd81e5d1ebd3e0d4e6accf Mon Sep 17 00:00:00 2001
From: Gurucharan Shetty <gshetty@nicira.com>
Date: Mon, 30 Jan 2012 20:17:53 -0800
Subject: [PATCH] rhel: Enable DHCP in redhat network scripts.
The current network-script, ifup-ovs does not work well if you
enable DHCP on the OVS. It will work if we name the bridge
alphabetically greater than the underlying physical interfaces.
Even then, it will do multiple DHCP attempts slowing down the boot
up process.
This patch allows DHCP on an OVS bridge.
Signed-off-by: Gurucharan Shetty <gshetty@nicira.com>
---
rhel/README.RHEL | 12 ++++++++++++
rhel/etc_sysconfig_network-scripts_ifup-ovs | 16 +++++++++++++++-
2 files changed, 27 insertions(+), 1 deletions(-)
diff --git a/rhel/README.RHEL b/rhel/README.RHEL
index 3e682b3..b97fb6c 100644
--- a/rhel/README.RHEL
+++ b/rhel/README.RHEL
@@ -62,6 +62,18 @@ IPADDR=A.B.C.D
NETMASK=X.Y.Z.0
HOTPLUG=no
+Enable DHCP on the bridge:
+* Needs OVSBOOTPROTO instead of BOOTPROTO.
+* All the interfaces that can reach the DHCP server
+as a comma separated list in OVSDHCPINTERFACES.
+
+DEVICE=ovsbridge0
+ONBOOT=yes
+DEVICETYPE=ovs
+TYPE=OVSBridge
+OVSBOOTPROTO="dhcp"
+OVSDHCPINTERFACES="eth0"
+HOTPLUG=no
Adding physical eth0 to ovsbridge0 described above:
diff --git a/rhel/etc_sysconfig_network-scripts_ifup-ovs b/rhel/etc_sysconfig_network-scripts_ifup-ovs
index 7074c07..18cebc4 100755
--- a/rhel/etc_sysconfig_network-scripts_ifup-ovs
+++ b/rhel/etc_sysconfig_network-scripts_ifup-ovs
@@ -36,12 +36,25 @@ fi
case "$TYPE" in
OVSBridge)
ovs-vsctl -- --may-exist add-br "$DEVICE" $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
- ${OTHERSCRIPT} ${CONFIG} ${2}
+ if [ "${OVSBOOTPROTO}" = "dhcp" ] && [ -n "${OVSINTF}" ]; then
+ case ${OVSDHCPINTERFACES} in
+ ${OVSINTF#ifcfg-} | \
+ "${OVSINTF#ifcfg-},"* | \
+ *",${OVSINTF#ifcfg-}" | \
+ *",${OVSINTF#ifcfg-},"*)
+ BOOTPROTO=dhcp ${OTHERSCRIPT} ${CONFIG}
+ ;;
+ esac
+ fi
+ if [ "${OVSBOOTPROTO}" != "dhcp" ] && [ -z "${OVSINTF}" ]; then
+ ${OTHERSCRIPT} ${CONFIG}
+ fi
;;
OVSPort)
/sbin/ifup "$OVS_BRIDGE"
${OTHERSCRIPT} ${CONFIG} ${2}
ovs-vsctl -- --may-exist add-port "$OVS_BRIDGE" "$DEVICE" $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
+ OVSINTF=${CONFIG} /sbin/ifup "$OVS_BRIDGE"
;;
OVSIntPort)
/sbin/ifup "$OVS_BRIDGE"
@@ -55,6 +68,7 @@ case "$TYPE" in
done
ovs-vsctl -- --fake-iface add-bond "$OVS_BRIDGE" "$DEVICE" ${BOND_IFACES} $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
${OTHERSCRIPT} ${CONFIG} ${2}
+ OVSINTF=${CONFIG} /sbin/ifup "$OVS_BRIDGE"
;;
*)
echo $"Invalid OVS interface type $TYPE"
--
1.7.7.6
From e31f6c5d1c26e9b86adb6449226b4f08f2c8d7a5 Mon Sep 17 00:00:00 2001
From: Ben Pfaff <blp@nicira.com>
Date: Fri, 3 Feb 2012 09:33:47 -0800
Subject: [PATCH] rhel: Simplify ifup-ovs script use of "case".
Suggested-by: "Alexey I. Froloff" <raorn@altlinux.org>
Signed-off-by: Ben Pfaff <blp@nicira.com>
---
rhel/etc_sysconfig_network-scripts_ifup-ovs | 7 ++-----
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/rhel/etc_sysconfig_network-scripts_ifup-ovs b/rhel/etc_sysconfig_network-scripts_ifup-ovs
index 18cebc4..4773ee4 100755
--- a/rhel/etc_sysconfig_network-scripts_ifup-ovs
+++ b/rhel/etc_sysconfig_network-scripts_ifup-ovs
@@ -37,11 +37,8 @@ case "$TYPE" in
OVSBridge)
ovs-vsctl -- --may-exist add-br "$DEVICE" $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
if [ "${OVSBOOTPROTO}" = "dhcp" ] && [ -n "${OVSINTF}" ]; then
- case ${OVSDHCPINTERFACES} in
- ${OVSINTF#ifcfg-} | \
- "${OVSINTF#ifcfg-},"* | \
- *",${OVSINTF#ifcfg-}" | \
- *",${OVSINTF#ifcfg-},"*)
+ case ,${OVSDHCPINTERFACES}, in
+ *,${OVSINTF#ifcfg-},*)
BOOTPROTO=dhcp ${OTHERSCRIPT} ${CONFIG}
;;
esac
--
1.7.7.6
From b4b6a39ae688b88b2d17c0b47b105fed86f6c29d Mon Sep 17 00:00:00 2001
From: Gurucharan Shetty <gshetty@nicira.com>
Date: Fri, 3 Feb 2012 12:21:30 -0800
Subject: [PATCH] rhel: Space separated list of DHCP interfaces in network
scripts.
Use space separated list of DHCP interfaces for OVSDHCPINTERFACES
instead of comma separated list. This is done to maintain
consistency with BOND_IFACES.
Signed-off-by: Gurucharan Shetty <gshetty@nicira.com>
---
rhel/README.RHEL | 2 +-
rhel/etc_sysconfig_network-scripts_ifup-ovs | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/rhel/README.RHEL b/rhel/README.RHEL
index b97fb6c..d9b68e4 100644
--- a/rhel/README.RHEL
+++ b/rhel/README.RHEL
@@ -65,7 +65,7 @@ HOTPLUG=no
Enable DHCP on the bridge:
* Needs OVSBOOTPROTO instead of BOOTPROTO.
* All the interfaces that can reach the DHCP server
-as a comma separated list in OVSDHCPINTERFACES.
+as a space separated list in OVSDHCPINTERFACES.
DEVICE=ovsbridge0
ONBOOT=yes
diff --git a/rhel/etc_sysconfig_network-scripts_ifup-ovs b/rhel/etc_sysconfig_network-scripts_ifup-ovs
index 4773ee4..b800ce0 100755
--- a/rhel/etc_sysconfig_network-scripts_ifup-ovs
+++ b/rhel/etc_sysconfig_network-scripts_ifup-ovs
@@ -37,8 +37,8 @@ case "$TYPE" in
OVSBridge)
ovs-vsctl -- --may-exist add-br "$DEVICE" $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
if [ "${OVSBOOTPROTO}" = "dhcp" ] && [ -n "${OVSINTF}" ]; then
- case ,${OVSDHCPINTERFACES}, in
- *,${OVSINTF#ifcfg-},*)
+ case " ${OVSDHCPINTERFACES} " in
+ *" ${OVSINTF} "*)
BOOTPROTO=dhcp ${OTHERSCRIPT} ${CONFIG}
;;
esac
@@ -51,7 +51,7 @@ case "$TYPE" in
/sbin/ifup "$OVS_BRIDGE"
${OTHERSCRIPT} ${CONFIG} ${2}
ovs-vsctl -- --may-exist add-port "$OVS_BRIDGE" "$DEVICE" $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
- OVSINTF=${CONFIG} /sbin/ifup "$OVS_BRIDGE"
+ OVSINTF=${DEVICE} /sbin/ifup "$OVS_BRIDGE"
;;
OVSIntPort)
/sbin/ifup "$OVS_BRIDGE"
@@ -65,7 +65,7 @@ case "$TYPE" in
done
ovs-vsctl -- --fake-iface add-bond "$OVS_BRIDGE" "$DEVICE" ${BOND_IFACES} $OVS_OPTIONS ${OVS_EXTRA+-- $OVS_EXTRA}
${OTHERSCRIPT} ${CONFIG} ${2}
- OVSINTF=${CONFIG} /sbin/ifup "$OVS_BRIDGE"
+ OVSINTF=${DEVICE} /sbin/ifup "$OVS_BRIDGE"
;;
*)
echo $"Invalid OVS interface type $TYPE"
--
1.7.7.6

@ -1,6 +1,6 @@
Name: openvswitch
Version: 1.4.0
Release: 6%{?dist}
Version: 1.7.0
Release: 1%{?dist}
Summary: Open vSwitch daemon/database/utilities
# Nearly all of openvswitch is ASL 2.0. The bugtool is LGPLv2+, and the
@ -17,13 +17,9 @@ Source4: ifup-ovs
Source5: ifdown-ovs
Source6: ovsdbmonitor.desktop
Source7: openvswitch-configure-ovskmod-var.patch
Source8: ovsdbmonitor-move-to-its-own-data-directory.patch
# make the kmod name configurable since Fedora kernel ships openvswitch module
# Source7 is not applied, it's used to generate patch0
Patch0: openvswitch-configure-ovskmod-var-autoconfd.patch
# mv ovsdbmonitordir. Source8 (accepted upstream) is source for patch1
Patch1: ovsdbmonitor-move-to-its-own-data-directory-automaked.patch
Patch2: openvswitch-rhel-initscripts-resync.patch
BuildRequires: systemd-units openssl openssl-devel
BuildRequires: python python-twisted-core python-twisted-conch python-zope-interface PyQt4
@ -77,8 +73,6 @@ issues in Open vSwitch setup.
%prep
%setup -q
%patch0 -p1 -b .ovskmod
%patch1 -p1 -b .ovsdbmonitordir
%patch2 -p1 -b .initscripts
%build
@ -206,6 +200,15 @@ fi
%changelog
* Fri Aug 17 2012 Tomas Hozza <thozza@redhat.com> - 1.7.0-1
- Update to 1.7.0
- Fixed openvswitch-configure-ovskmod-var-autoconfd.patch because
openvswitch kernel module name changed in 1.7.0
- Removed Source8: ovsdbmonitor-move-to-its-own-data-directory.patch
- Patches merged:
- ovsdbmonitor-move-to-its-own-data-directory-automaked.patch
- openvswitch-rhel-initscripts-resync.patch
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

@ -1,23 +0,0 @@
This is the automake'd version of the patch
ovsdbmonitor-move-to-its-own-data-directory.patch. It only updates
Makefile.in rather than ovsdb/ovsdbmonitor/automake.mk.
diff -aur openvswitch-1.4.0.orig/debian/ovsdbmonitor.install openvswitch-1.4.0/debian/ovsdbmonitor.install
--- openvswitch-1.4.0.orig/debian/ovsdbmonitor.install 2012-01-30 19:44:54.000000000 -0800
+++ openvswitch-1.4.0/debian/ovsdbmonitor.install 2012-03-01 15:29:30.661090604 -0800
@@ -1,2 +1,2 @@
usr/bin/ovsdbmonitor
-usr/share/openvswitch/ovsdbmonitor
+usr/share/ovsdbmonitor
diff -aur openvswitch-1.4.0.orig/Makefile.in openvswitch-1.4.0/Makefile.in
--- openvswitch-1.4.0.orig/Makefile.in 2012-01-30 23:09:16.000000000 -0800
+++ openvswitch-1.4.0/Makefile.in 2012-03-01 15:29:35.927167987 -0800
@@ -1589,7 +1589,7 @@
ovsdb/ovsdbmonitor/Ui_MainWindow.py \
ovsdb/ovsdbmonitor/qt4reactor.py
-ovsdbmonitordir = ${pkgdatadir}/ovsdbmonitor
+ovsdbmonitordir = ${datadir}/ovsdbmonitor
@BUILD_OVSDBMONITOR_TRUE@ovsdbmonitor_DATA = $(ovsdbmonitor_pyfiles)
update_spec = \
($(ro_shell) && sed -e 's,[@]VERSION[@],$(VERSION),g') \

@ -1,39 +0,0 @@
From 748dca871d1f8a06d33a1002e1dfabb74b16c9b6 Mon Sep 17 00:00:00 2001
From: Chris Wright <chrisw@sous-sol.org>
Date: Thu, 1 Mar 2012 15:25:14 -0800
Subject: [PATCH] ovsdbmonitor: move to its own data directory
It doesn't have dependencies on any packages that would install into
pkgdatadir, and for Fedora it makes directory ownership work better.
So move ovsdbmonitor python internals to its own data directory.
Signed-off-by: Chris Wright <chrisw@sous-sol.org>
Signed-off-by: Ben Pfaff <blp@nicira.com>
---
debian/ovsdbmonitor.install | 2 +-
ovsdb/ovsdbmonitor/automake.mk | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/debian/ovsdbmonitor.install b/debian/ovsdbmonitor.install
index 4f19ecb..0572be4 100644
--- a/debian/ovsdbmonitor.install
+++ b/debian/ovsdbmonitor.install
@@ -1,2 +1,2 @@
usr/bin/ovsdbmonitor
-usr/share/openvswitch/ovsdbmonitor
+usr/share/ovsdbmonitor
diff --git a/ovsdb/ovsdbmonitor/automake.mk b/ovsdb/ovsdbmonitor/automake.mk
index 59d2e2c..ec63cc7 100644
--- a/ovsdb/ovsdbmonitor/automake.mk
+++ b/ovsdb/ovsdbmonitor/automake.mk
@@ -28,7 +28,7 @@ EXTRA_DIST += \
ovsdb/ovsdbmonitor/ovsdbmonitor.in
MAN_ROOTS += ovsdb/ovsdbmonitor/ovsdbmonitor.1
-ovsdbmonitordir = ${pkgdatadir}/ovsdbmonitor
+ovsdbmonitordir = ${datadir}/ovsdbmonitor
if BUILD_OVSDBMONITOR
noinst_SCRIPTS += ovsdb/ovsdbmonitor/ovsdbmonitor
ovsdbmonitor_DATA = $(ovsdbmonitor_pyfiles)
--
1.7.7.4

@ -1 +1 @@
3847c60af329bfe81ff7220b9f489fa5 openvswitch-1.4.0.tar.gz
68fab83678e5a69073aabef9f502bd82 openvswitch-1.7.0.tar.gz

Loading…
Cancel
Save