Backport "Add ovs.compat module to python package" (#1619712)
Backport a variant of "dhparams: Fix .c file generation with OpenSSL >= 1.1.1-pre9"f38
parent
bca9d9121b
commit
460da50b8c
@ -0,0 +1,31 @@
|
|||||||
|
From f18adea51cac4f40c50d59d7c001264a8ce83cb3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Terry Wilson <twilson@redhat.com>
|
||||||
|
Date: Fri, 31 Aug 2018 13:40:54 -0500
|
||||||
|
Subject: [PATCH] Add ovs.compat module to python package
|
||||||
|
|
||||||
|
Signed-off-by: Terry Wilson <twilson@redhat.com>
|
||||||
|
Signed-off-by: Ben Pfaff <blp@ovn.org>
|
||||||
|
Acked-by: Timothy Redaelli <tredaelli@redhat.com>
|
||||||
|
(cherry picked from commit 2360464d629de3acacabd960ffc02fbb5081028d)
|
||||||
|
Signed-off-by: Ben Pfaff <blp@ovn.org>
|
||||||
|
---
|
||||||
|
python/setup.py | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/python/setup.py b/python/setup.py
|
||||||
|
index 0e86834ea..b52657df3 100644
|
||||||
|
--- a/python/setup.py
|
||||||
|
+++ b/python/setup.py
|
||||||
|
@@ -63,7 +63,8 @@ setup_args = dict(
|
||||||
|
url='http://www.openvswitch.org/',
|
||||||
|
author='Open vSwitch',
|
||||||
|
author_email='dev@openvswitch.org',
|
||||||
|
- packages=['ovs', 'ovs.db', 'ovs.unixctl'],
|
||||||
|
+ packages=['ovs', 'ovs.compat', 'ovs.compat.sortedcontainers',
|
||||||
|
+ 'ovs.db', 'ovs.unixctl'],
|
||||||
|
keywords=['openvswitch', 'ovs', 'OVSDB'],
|
||||||
|
license='Apache 2.0',
|
||||||
|
classifiers=[
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
@ -0,0 +1,38 @@
|
|||||||
|
From 44343cb1ca4232f23dba24cab98d3605686f5700 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Timothy Redaelli <tredaelli@redhat.com>
|
||||||
|
Date: Fri, 7 Sep 2018 15:14:53 +0200
|
||||||
|
Subject: [PATCH] dhparams: Fix .c file generation with OpenSSL >= 1.1.1-pre9
|
||||||
|
|
||||||
|
Since OpenSSL upstream commit 201b305a2409
|
||||||
|
("apps/dsaparam.c generates code that is intended to be pasted or included into
|
||||||
|
an existing source file: the function is static, and the code doesn't include
|
||||||
|
dsa.h. Match the generated C source style of dsaparam.") "openssl dhparam -C"
|
||||||
|
generates the get_dh functions as static, but the functions are used inside
|
||||||
|
stream-ssl.c and so the static keyword cannot be used.
|
||||||
|
|
||||||
|
This commit removes the static keyword from the get_dh functions during
|
||||||
|
dhparams.c file generation by restoring the current behaviour.
|
||||||
|
|
||||||
|
Signed-off-by: Timothy Redaelli <tredaelli@redhat.com>
|
||||||
|
Signed-off-by: Ben Pfaff <blp@ovn.org>
|
||||||
|
(cherry picked from commit dc041eae5019a936618c398a2a1d106f65604ccc)
|
||||||
|
---
|
||||||
|
lib/automake.mk | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lib/automake.mk b/lib/automake.mk
|
||||||
|
index 8ecad1241..70461ec8c 100644
|
||||||
|
--- a/lib/automake.mk
|
||||||
|
+++ b/lib/automake.mk
|
||||||
|
@@ -438,7 +438,7 @@ lib/dhparams.c: lib/dh1024.pem lib/dh2048.pem lib/dh4096.pem
|
||||||
|
openssl dhparam -C -in $(srcdir)/lib/dh1024.pem -noout && \
|
||||||
|
openssl dhparam -C -in $(srcdir)/lib/dh2048.pem -noout && \
|
||||||
|
openssl dhparam -C -in $(srcdir)/lib/dh4096.pem -noout) \
|
||||||
|
- | sed 's/\(get_dh[0-9]*\)()/\1(void)/' > lib/dhparams.c.tmp && \
|
||||||
|
+ | sed 's/^static DH/DH/; s/\(get_dh[0-9]*\)()/\1(void)/' > lib/dhparams.c.tmp && \
|
||||||
|
mv lib/dhparams.c.tmp lib/dhparams.c
|
||||||
|
else
|
||||||
|
lib_libopenvswitch_la_SOURCES += lib/stream-nossl.c
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
Loading…
Reference in new issue