Update to 3.0.1

i9cf changed/i9c/openssl-gost-engine-3.0.1-1.el9
Arkady L. Shane 1 year ago
parent c0a2af15e4
commit d8042e524b
Signed by: tigro
GPG Key ID: 9C7900103E1C4F8B

2
.gitignore vendored

@ -1 +1 @@
SOURCES/openssl-gost-engine-3.0.0.tar.gz SOURCES/openssl-gost-engine-3.0.1.tar.gz

@ -1 +1 @@
d1f8fb88110803804ea5ceb1e1259933c0b167ca SOURCES/openssl-gost-engine-3.0.0.tar.gz df784c17971f04765176eb45c512c916d37bdc5b SOURCES/openssl-gost-engine-3.0.1.tar.gz

@ -0,0 +1,18 @@
diff -up engine-3.0.1/CMakeLists.txt.silent engine-3.0.1/CMakeLists.txt
--- engine-3.0.1/CMakeLists.txt.silent 2023-01-29 12:09:13.187905422 +0100
+++ engine-3.0.1/CMakeLists.txt 2023-01-29 12:09:34.270083655 +0100
@@ -29,12 +29,12 @@ if (CMAKE_C_COMPILER_ID MATCHES "Clang")
set(CMAKE_C_FLAGS_RELEASE -O2)
set(CMAKE_C_FLAGS_DEBUG "-O0 -ggdb")
set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -ggdb")
- add_compile_options(-Werror -Wall -Wno-unused-parameter -Wno-unused-function -Wno-missing-braces -Qunused-arguments -Wno-deprecated-declarations)
+ add_compile_options(-Wall -Wno-unused-parameter -Wno-unused-function -Wno-missing-braces -Qunused-arguments -Wno-deprecated-declarations)
elseif(CMAKE_C_COMPILER_ID MATCHES "GNU")
set(CMAKE_C_FLAGS_RELEASE -O2)
set(CMAKE_C_FLAGS_DEBUG "-O0 -ggdb")
set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -ggdb")
- add_compile_options(-Werror -Wall -Wno-unused-parameter -Wno-unused-function -Wno-missing-braces -Wno-error=unknown-pragmas -Wno-error=pragmas -Wno-deprecated-declarations)
+ add_compile_options(-Wall -Wno-unused-parameter -Wno-unused-function -Wno-missing-braces -Wno-error=unknown-pragmas -Wno-error=pragmas -Wno-deprecated-declarations)
elseif(CMAKE_C_COMPILER_ID MATCHES "MSVC")
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
add_definitions(-D_CRT_DEPRECATED_NO_WARNINGS)

@ -1,13 +1,13 @@
Name: openssl-gost-engine Name: openssl-gost-engine
Version: 3.0.0 Version: 3.0.1
Release: 3%{?dist} Release: 1%{?dist}
URL: https://github.com/gost-engine/engine URL: https://github.com/gost-engine/engine
License: OpenSSL License: OpenSSL
Summary: A reference implementation of the Russian GOST crypto algorithms for OpenSSL Summary: A reference implementation of the Russian GOST crypto algorithms for OpenSSL
Source: https://github.com/gost-engine/engine/archive/v%{version}/%{name}-%{version}.tar.gz Source: https://github.com/gost-engine/engine/archive/v%{version}/%{name}-%{version}.tar.gz
Patch1: 01-engine-nowerror.patch
BuildRequires: make BuildRequires: make
BuildRequires: cmake-rpm-macros gcc perl-Test-Simple BuildRequires: cmake-rpm-macros gcc perl-Test-Simple
@ -26,8 +26,9 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
GOST file digesting utilities. GOST file digesting utilities.
%global _enginesdir %(pkg-config --variable=enginesdir libcrypto) %global _enginesdir %(pkg-config --variable=enginesdir libcrypto)
%global _providersdir %(pkg-config --variable=modulesdir libcrypto)
%prep %prep
%setup -n engine-%version -q %autosetup -n engine-%version
%build %build
%cmake -B "%{_vpath_builddir}" %cmake -B "%{_vpath_builddir}"
@ -38,7 +39,9 @@ GOST file digesting utilities.
mkdir -p %buildroot%_bindir mkdir -p %buildroot%_bindir
mkdir -p %buildroot%_mandir/man1 mkdir -p %buildroot%_mandir/man1
mkdir -p %buildroot%_enginesdir mkdir -p %buildroot%_enginesdir
mkdir -p %buildroot%_providersdir
cp "%{_vpath_builddir}"/bin/gost.so README.gost %buildroot%_enginesdir/ cp "%{_vpath_builddir}"/bin/gost.so README.gost %buildroot%_enginesdir/
cp "%{_vpath_builddir}"/bin/gostprov.so %buildroot%_providersdir/
cp "%{_vpath_builddir}"/bin/gost*sum %buildroot%_bindir/ cp "%{_vpath_builddir}"/bin/gost*sum %buildroot%_bindir/
cp gost*sum.1 %buildroot%_mandir/man1/ cp gost*sum.1 %buildroot%_mandir/man1/
@ -54,6 +57,7 @@ OPENSSL_ENGINES="$PWD/%{_vpath_builddir}/bin" \
%files %files
%_enginesdir/gost.so %_enginesdir/gost.so
%_providersdir/gostprov.so
%doc %_enginesdir/README.gost %doc %_enginesdir/README.gost
%files -n gostsum %files -n gostsum
@ -61,9 +65,15 @@ OPENSSL_ENGINES="$PWD/%{_vpath_builddir}/bin" \
%_mandir/man1/gost*sum* %_mandir/man1/gost*sum*
%changelog %changelog
* Sun Jan 29 2023 Dmitry Belyavskiy <dbelyavs@redhat.com> - 3.0.1-1
- Update to version 3.0.1
* Tue Jun 13 2023 Sergey Cherevko <s.cherevko@msvsphere.ru> - 3.0.0-3 * Tue Jun 13 2023 Sergey Cherevko <s.cherevko@msvsphere.ru> - 3.0.0-3
- Rebuilt for MSVSphere 9.2 - Rebuilt for MSVSphere 9.2
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-3 * Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

Loading…
Cancel
Save