Suppressed the dependency on SCons (as autotools are used instead)

Fixed the generated version minor number (from 127 to 122)
Fixed the target include directory
epel8
Denis Arnaud 5 years ago
commit 300630d4a2

@ -0,0 +1,11 @@
--- openpgm-release-5-2-122/openpgm/pgm/Makefile.am 2012-12-04 03:56:54.000000000 +0100
+++ openpgm-release-5-2-122/openpgm/pgm/Makefile2.am 2019-10-30 22:09:31.457801206 +0100
@@ -54,7 +54,7 @@
histogram.c \
version.c
-share_includedir = $(includedir)/pgm-@RELEASE_INFO@/pgm
+share_includedir = $(includedir)/pgm
share_include_HEADERS = \
include/pgm/atomic.h \
include/pgm/engine.h \

@ -7,5 +7,5 @@ index 1e56d944..9e30a6da 100644
# versions of pkg-config that support static linking.
Libs: -L${libdir} -lpgm @LIBS@
-Cflags: -I${includedir}/pgm-@VERSION_MAJOR@.@VERSION_MINOR@ -I${libdir}/pgm-@VERSION_MAJOR@.@VERSION_MINOR@/include
+Cflags: -I${includedir}/pgm-@VERSION_MAJOR@.@VERSION_MINOR@
+Cflags: -I${includedir}

@ -38,13 +38,12 @@ index e489aef..581eabe 100755
const unsigned pgm_major_version = 5;
const unsigned pgm_minor_version = 2;
-const unsigned pgm_micro_version = 122;
const unsigned pgm_micro_version = 122;
-const char* pgm_build_date = "%s";
-const char* pgm_build_time = "%s";
-const char* pgm_build_system = "%s";
-const char* pgm_build_machine = "%s";
-const char* pgm_build_revision = "%s";
+const unsigned pgm_micro_version = 127;
+const char* pgm_build_date = "{0}";
+const char* pgm_build_time = "{1}";
+const char* pgm_build_system = "{2}";

@ -1,7 +1,7 @@
Name: openpgm
Version: 5.2.122
%global version_dash 5-2-122
Release: 19%{?dist}
Release: 20%{?dist}
Summary: An implementation of the PGM reliable multicast protocol
# The license is LGPLv2.1
@ -13,6 +13,7 @@ Source0: https://github.com/steve-o/%{name}/archive/release-%{version_dash
# All the following patches have been submitted upstream
# as a merge request: https://github.com/steve-o/openpgm/pull/64
Patch1: openpgm-01-makefile-am.patch
Patch2: openpgm-02-c-func.patch
Patch3: openpgm-03-pkgconfig.patch
Patch4: openpgm-04-py-version-gen.patch
@ -47,14 +48,14 @@ aclocal
autoheader
automake --copy --add-missing
autoconf
./configure --libdir=%{_libdir}
%configure
%build
make %{_smp_mflags}
%install
rm -rf %{buildroot}
make prefix=/usr libdir=%{_libdir} DESTDIR=%{buildroot} install
make DESTDIR=%{buildroot} install
rm -f %{buildroot}%{_libdir}/libpgm.{a,la}
@ -72,6 +73,11 @@ rm -f %{buildroot}%{_libdir}/libpgm.{a,la}
%changelog
* Wed Oct 30 2019 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 5.2.122-20
- Suppressed the dependency on SCons (as autotools are used instead)
- Fixed the generated version minor number (from 127 to 122)
- Fixed the target include directory
* Wed Oct 30 2019 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 5.2.122-19
- Merged with the EPEL 8 version, i.e., with modernized way of packaging

Loading…
Cancel
Save