parent
e7dd52dc74
commit
932db9e55c
File diff suppressed because it is too large
Load Diff
@ -1,36 +0,0 @@
|
|||||||
--- opencv-1.0.0.orig/configure.in 2006-11-03 16:54:33.000000000 +0100
|
|
||||||
+++ opencv-1.0.0/configure.in 2006-12-11 11:43:06.000000000 +0100
|
|
||||||
@@ -202,28 +202,28 @@
|
|
||||||
i686-*-*)
|
|
||||||
if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
|
||||||
# default to i686/pentiumpro -- people can override this
|
|
||||||
- CXXFLAGS="-g -march=i686 -ffast-math -fomit-frame-pointer $CXXFLAGS"
|
|
||||||
+: CXXFLAGS="-g -march=i686 -ffast-math -fomit-frame-pointer $CXXFLAGS"
|
|
||||||
fi
|
|
||||||
;;
|
|
||||||
powerpc-*-*)
|
|
||||||
if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
|
||||||
# default to G3 processors -- people can override this
|
|
||||||
- CXXFLAGS="-g -mcpu=G3 -mtune=G5 -fomit-frame-pointer $CXXFLAGS"
|
|
||||||
+: CXXFLAGS="-g -mcpu=G3 -mtune=G5 -fomit-frame-pointer $CXXFLAGS"
|
|
||||||
fi
|
|
||||||
;;
|
|
||||||
*-*-*)
|
|
||||||
if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
|
||||||
- CXXFLAGS="-fomit-frame-pointer $CXXFLAGS"
|
|
||||||
+: CXXFLAGS="-fomit-frame-pointer $CXXFLAGS"
|
|
||||||
fi
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
|
||||||
- CXXFLAGS="-O3 $CXXFLAGS"
|
|
||||||
+: CXXFLAGS="-O3 $CXXFLAGS"
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
|
||||||
- CXXFLAGS="-Wall -fno-rtti -pipe $CXXFLAGS"
|
|
||||||
+: CXXFLAGS="-Wall -fno-rtti -pipe $CXXFLAGS"
|
|
||||||
fi
|
|
||||||
|
|
||||||
# add libm because it is used by several libraries and OpenCV itself
|
|
@ -1,9 +0,0 @@
|
|||||||
--- opencv-1.0.0.orig/opencv.pc.in 2006-08-02 19:13:34.000000000 +0200
|
|
||||||
+++ opencv-1.0.0/opencv.pc.in 2008-05-11 06:27:54.000000000 +0200
|
|
||||||
@@ -8,5 +8,5 @@
|
|
||||||
Name: OpenCV
|
|
||||||
Description: Intel(R) Open Source Computer Vision Library
|
|
||||||
Version: @VERSION@
|
|
||||||
-Libs: -L${libdir} -lcxcore -lcv -lhighgui -lcvaux -lml
|
|
||||||
+Libs: -L${libdir} -lhighgui -lcvaux -lcv -lml -lcxcore
|
|
||||||
Cflags: -I${includedir}
|
|
@ -1,14 +0,0 @@
|
|||||||
--- opencv-1.0.0.orig/interfaces/swig/python/Makefile.am 2006-08-10 15:29:20.000000000 +0200
|
|
||||||
+++ opencv-1.0.0/interfaces/swig/python/Makefile.am 2007-03-22 04:04:45.000000000 +0100
|
|
||||||
@@ -92,9 +92,9 @@
|
|
||||||
|
|
||||||
if BUILD_PYTHON_WRAPPERS
|
|
||||||
|
|
||||||
-pkgpython_LTLIBRARIES = _cv.la _highgui.la
|
|
||||||
+pkgpyexec_LTLIBRARIES = _cv.la _highgui.la
|
|
||||||
|
|
||||||
-pkgpython_PYTHON = \
|
|
||||||
+pkgpyexec_PYTHON = \
|
|
||||||
__init__.py \
|
|
||||||
cv.py \
|
|
||||||
adaptors.py \
|
|
Loading…
Reference in new issue