update to 3.5.0

epel9
Miroslav Lichvar 14 years ago
parent d88b8255a7
commit e7d187599a

4
.gitignore vendored

@ -1,2 +1,2 @@
setlayout.c
openbox-3.4.11.2.tar.gz
/setlayout.c
/openbox-3.5.0.tar.gz

@ -2,10 +2,10 @@
<openbox_menu xmlns="http://openbox.org/3.4/menu">
<menu id="applications-menu" label="Applications" execute="_DATADIR_/xdg-menu applications"/>
<menu id="preferences-menu" label="Preferences" execute="_DATADIR_/xdg-menu preferences"/>
<menu id="administration-menu" label="Administration" execute="_DATADIR_/xdg-menu system-settings"/>
<menu id="terminals-menu" label="Terminals" execute="_DATADIR_/xdg-menu _DATADIR_/terminals"/>
<menu id="applications-menu" label="Applications" execute="_LIBEXECDIR_/openbox-xdg-menu applications"/>
<menu id="preferences-menu" label="Preferences" execute="_LIBEXECDIR_/openbox-xdg-menu preferences"/>
<menu id="administration-menu" label="Administration" execute="_LIBEXECDIR_/openbox-xdg-menu system-settings"/>
<menu id="terminals-menu" label="Terminals" execute="_LIBEXECDIR_/openbox-xdg-menu /etc/xdg/openbox/terminals"/>
<menu id="root-menu" label="Openbox 3">
<separator label="Openbox"/>

@ -1,19 +0,0 @@
diff -up openbox-3.4.11/Makefile.in.xau openbox-3.4.11/Makefile.in
--- openbox-3.4.11/Makefile.in.xau 2010-02-09 15:10:36.000000000 +0100
+++ openbox-3.4.11/Makefile.in 2010-02-09 15:15:01.000000000 +0100
@@ -763,6 +763,7 @@ tools_gnome_panel_control_gnome_panel_co
$(X_CFLAGS)
tools_gnome_panel_control_gnome_panel_control_LDADD = \
+ -lXau \
$(X_LIBS)
tools_gnome_panel_control_gnome_panel_control_SOURCES = \
@@ -784,6 +785,7 @@ tools_gdm_control_gdm_control_CPPFLAGS =
$(GLIB_CFLAGS)
tools_gdm_control_gdm_control_LDADD = \
+ -lXau \
$(X_LIBS) \
$(GLIB_LIBS)

@ -1,48 +0,0 @@
commit 263833450d3fb1ca0bfffef302c4b204a3133766
Author: Mikael Magnusson <mikachu@gmail.com>
Date: Sat Jun 6 11:12:06 2009 +0200
Add support for 24bit
diff --git a/render/color.c b/render/color.c
index 41fcc71..5e3f216 100644
--- a/render/color.c
+++ b/render/color.c
@@ -143,6 +143,28 @@ void RrReduceDepth(const RrInstance *inst, RrPixel32 *data, XImage *im)
}
} else im->data = (gchar*) data;
break;
+ case 24:
+ {
+ /* reverse the ordering, shifting left 16bit should be the first byte
+ out of three, etc */
+ const guint roff = (16 - RrRedOffset(inst)) / 8;
+ const guint goff = (16 - RrGreenOffset(inst)) / 8;
+ const guint boff = (16 - RrBlueOffset(inst)) / 8;
+ gint outx;
+ for (y = 0; y < im->height; y++) {
+ for (x = 0, outx = 0; x < im->width; x++, outx += 3) {
+ r = (data[x] >> RrDefaultRedOffset) & 0xFF;
+ g = (data[x] >> RrDefaultGreenOffset) & 0xFF;
+ b = (data[x] >> RrDefaultBlueOffset) & 0xFF;
+ p8[outx+roff] = r;
+ p8[outx+goff] = g;
+ p8[outx+boff] = b;
+ }
+ data += im->width;
+ p8 += im->bytes_per_line;
+ }
+ break;
+ }
case 16:
for (y = 0; y < im->height; y++) {
for (x = 0; x < im->width; x++) {
@@ -191,7 +213,7 @@ void RrReduceDepth(const RrInstance *inst, RrPixel32 *data, XImage *im)
}
break;
default:
- g_error("Your bit depth is currently unhandled\n");
+ g_error("This image bit depth (%i) is currently unhandled", im->bits_per_pixel);
}
}

@ -1,12 +0,0 @@
diff -up openbox-3.4.9/Makefile.in.autostartdir openbox-3.4.9/Makefile.in
--- openbox-3.4.9/Makefile.in.autostartdir 2009-12-18 17:09:20.000000000 +0100
+++ openbox-3.4.9/Makefile.in 2009-12-19 11:09:25.000000000 +0100
@@ -502,7 +502,7 @@ pkgconfigdir = $(libdir)/pkgconfig
pubincludedir = $(includedir)/openbox/@OB_VERSION@/openbox
pixmapdir = $(datadir)/pixmaps
xsddir = $(datadir)/openbox
-secretbindir = $(libdir)/openbox
+secretbindir = $(datadir)/openbox
appsdir = $(datadir)/applications
theme = Clearlooks
AUTOMAKE_OPTIONS = subdir-objects foreign

@ -1,6 +1,6 @@
Name: openbox
Version: 3.4.11.2
Release: 8%{?dist}
Version: 3.5.0
Release: 1%{?dist}
Summary: A highly configurable and standards-compliant X11 window manager
Group: User Interface/Desktops
@ -14,10 +14,7 @@ Source4: openbox.desktop
Source5: terminals.menu
Source6: openbox.gnome-session
Patch0: openbox-3.4.9-autostartdir.patch
Patch1: openbox-3.4.11-Xau.patch
Patch2: openbox-3.4.11.2-gnomesession.patch
Patch4: openbox-3.4.7.2-24bit.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -97,10 +94,7 @@ KDE session.
%prep
%setup -q
%patch0 -p1 -b .autostartdir
%patch1 -p1 -b .Xau
%patch2 -p1 -b .gnome
%patch4 -p1 -b .24bit
%build
@ -118,15 +112,15 @@ rm -rf %{buildroot}
make install DESTDIR=%{buildroot}
install setlayout %{buildroot}%{_bindir}
install -p %{SOURCE2} %{buildroot}%{_datadir}/%{name}/xdg-menu
sed 's|_DATADIR_|%{_datadir}/%{name}|g' < %{SOURCE3} \
install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
> %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
desktop-file-install --vendor="" \
--dir=%{buildroot}%{_datadir}/applications \
%{SOURCE4}
install -m644 -p %{SOURCE5} %{buildroot}%{_datadir}/%{name}/terminals.menu
install -m644 -p %{SOURCE5} %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
install -m644 -D %{SOURCE6} \
%{buildroot}%{_datadir}/gnome-session/sessions/gnome-openbox.session
@ -149,8 +143,8 @@ rm -rf %{buildroot}
%{_bindir}/%{name}-session
%{_bindir}/obxprop
%{_bindir}/setlayout
%{_libexecdir}/openbox-*
%{_datadir}/applications/*%{name}.desktop
%{_datadir}/%{name}
%{_datadir}/themes/*/
%{_datadir}/pixmaps/%{name}.png
%{_datadir}/xsessions/%{name}.desktop
@ -162,13 +156,13 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc COPYING
%{_libdir}/libobrender.so.*
%{_libdir}/libobparser.so.*
%{_libdir}/libobt.so.*
%files devel
%defattr(-,root,root,-)
%{_includedir}/%{name}/
%{_libdir}/libobrender.so
%{_libdir}/libobparser.so
%{_libdir}/libobt.so
%{_libdir}/pkgconfig/*.pc
%files gnome

@ -1,2 +1,2 @@
16ca0d290cae2f4c16a35e9cdfb6f503 setlayout.c
30e669134fa81df810fe7d1dc59cd931 openbox-3.4.11.2.tar.gz
00441b53cf14c03566c8e82643544ff9 openbox-3.5.0.tar.gz

Loading…
Cancel
Save