parent
d88b8255a7
commit
e7d187599a
@ -1,2 +1,2 @@
|
|||||||
setlayout.c
|
/setlayout.c
|
||||||
openbox-3.4.11.2.tar.gz
|
/openbox-3.5.0.tar.gz
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
diff -up openbox-3.4.11/Makefile.in.xau openbox-3.4.11/Makefile.in
|
|
||||||
--- openbox-3.4.11/Makefile.in.xau 2010-02-09 15:10:36.000000000 +0100
|
|
||||||
+++ openbox-3.4.11/Makefile.in 2010-02-09 15:15:01.000000000 +0100
|
|
||||||
@@ -763,6 +763,7 @@ tools_gnome_panel_control_gnome_panel_co
|
|
||||||
$(X_CFLAGS)
|
|
||||||
|
|
||||||
tools_gnome_panel_control_gnome_panel_control_LDADD = \
|
|
||||||
+ -lXau \
|
|
||||||
$(X_LIBS)
|
|
||||||
|
|
||||||
tools_gnome_panel_control_gnome_panel_control_SOURCES = \
|
|
||||||
@@ -784,6 +785,7 @@ tools_gdm_control_gdm_control_CPPFLAGS =
|
|
||||||
$(GLIB_CFLAGS)
|
|
||||||
|
|
||||||
tools_gdm_control_gdm_control_LDADD = \
|
|
||||||
+ -lXau \
|
|
||||||
$(X_LIBS) \
|
|
||||||
$(GLIB_LIBS)
|
|
||||||
|
|
@ -1,48 +0,0 @@
|
|||||||
commit 263833450d3fb1ca0bfffef302c4b204a3133766
|
|
||||||
Author: Mikael Magnusson <mikachu@gmail.com>
|
|
||||||
Date: Sat Jun 6 11:12:06 2009 +0200
|
|
||||||
|
|
||||||
Add support for 24bit
|
|
||||||
|
|
||||||
diff --git a/render/color.c b/render/color.c
|
|
||||||
index 41fcc71..5e3f216 100644
|
|
||||||
--- a/render/color.c
|
|
||||||
+++ b/render/color.c
|
|
||||||
@@ -143,6 +143,28 @@ void RrReduceDepth(const RrInstance *inst, RrPixel32 *data, XImage *im)
|
|
||||||
}
|
|
||||||
} else im->data = (gchar*) data;
|
|
||||||
break;
|
|
||||||
+ case 24:
|
|
||||||
+ {
|
|
||||||
+ /* reverse the ordering, shifting left 16bit should be the first byte
|
|
||||||
+ out of three, etc */
|
|
||||||
+ const guint roff = (16 - RrRedOffset(inst)) / 8;
|
|
||||||
+ const guint goff = (16 - RrGreenOffset(inst)) / 8;
|
|
||||||
+ const guint boff = (16 - RrBlueOffset(inst)) / 8;
|
|
||||||
+ gint outx;
|
|
||||||
+ for (y = 0; y < im->height; y++) {
|
|
||||||
+ for (x = 0, outx = 0; x < im->width; x++, outx += 3) {
|
|
||||||
+ r = (data[x] >> RrDefaultRedOffset) & 0xFF;
|
|
||||||
+ g = (data[x] >> RrDefaultGreenOffset) & 0xFF;
|
|
||||||
+ b = (data[x] >> RrDefaultBlueOffset) & 0xFF;
|
|
||||||
+ p8[outx+roff] = r;
|
|
||||||
+ p8[outx+goff] = g;
|
|
||||||
+ p8[outx+boff] = b;
|
|
||||||
+ }
|
|
||||||
+ data += im->width;
|
|
||||||
+ p8 += im->bytes_per_line;
|
|
||||||
+ }
|
|
||||||
+ break;
|
|
||||||
+ }
|
|
||||||
case 16:
|
|
||||||
for (y = 0; y < im->height; y++) {
|
|
||||||
for (x = 0; x < im->width; x++) {
|
|
||||||
@@ -191,7 +213,7 @@ void RrReduceDepth(const RrInstance *inst, RrPixel32 *data, XImage *im)
|
|
||||||
}
|
|
||||||
break;
|
|
||||||
default:
|
|
||||||
- g_error("Your bit depth is currently unhandled\n");
|
|
||||||
+ g_error("This image bit depth (%i) is currently unhandled", im->bits_per_pixel);
|
|
||||||
|
|
||||||
}
|
|
||||||
}
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up openbox-3.4.9/Makefile.in.autostartdir openbox-3.4.9/Makefile.in
|
|
||||||
--- openbox-3.4.9/Makefile.in.autostartdir 2009-12-18 17:09:20.000000000 +0100
|
|
||||||
+++ openbox-3.4.9/Makefile.in 2009-12-19 11:09:25.000000000 +0100
|
|
||||||
@@ -502,7 +502,7 @@ pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
pubincludedir = $(includedir)/openbox/@OB_VERSION@/openbox
|
|
||||||
pixmapdir = $(datadir)/pixmaps
|
|
||||||
xsddir = $(datadir)/openbox
|
|
||||||
-secretbindir = $(libdir)/openbox
|
|
||||||
+secretbindir = $(datadir)/openbox
|
|
||||||
appsdir = $(datadir)/applications
|
|
||||||
theme = Clearlooks
|
|
||||||
AUTOMAKE_OPTIONS = subdir-objects foreign
|
|
Loading…
Reference in new issue