enough. If ever picked up again, old version could be resurrected or fresh package imported from scratch.epel9
parent
d9c7735242
commit
bb687984e0
@ -1 +0,0 @@
|
|||||||
openbox-2.3.1.tar.gz
|
|
@ -1,21 +0,0 @@
|
|||||||
# Makefile for source rpm: openbox
|
|
||||||
# $Id$
|
|
||||||
NAME := openbox
|
|
||||||
SPECFILE = $(firstword $(wildcard *.spec))
|
|
||||||
|
|
||||||
define find-makefile-common
|
|
||||||
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKEFILE_COMMON := $(shell $(find-makefile-common))
|
|
||||||
|
|
||||||
ifeq ($(MAKEFILE_COMMON),)
|
|
||||||
# attept a checkout
|
|
||||||
define checkout-makefile-common
|
|
||||||
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
|
|
||||||
endif
|
|
||||||
|
|
||||||
include $(MAKEFILE_COMMON)
|
|
@ -1,10 +0,0 @@
|
|||||||
--- openbox-2.3.1/util/epist/keytree.cc.orig 2003-06-29 08:08:59.000000000 -0600
|
|
||||||
+++ openbox-2.3.1/util/epist/keytree.cc 2003-06-29 08:09:21.000000000 -0600
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
|
|
||||||
#include <string>
|
|
||||||
#include <iostream>
|
|
||||||
+#include <assert.h>
|
|
||||||
|
|
||||||
using std::string;
|
|
||||||
|
|
@ -1,20 +0,0 @@
|
|||||||
--- openbox-2.3.1/Makefile.am.orig 2003-03-21 17:56:02.000000000 -0700
|
|
||||||
+++ openbox-2.3.1/Makefile.am 2003-07-06 08:52:25.000000000 -0600
|
|
||||||
@@ -1,5 +1,6 @@
|
|
||||||
# Makefile.am for Openbox
|
|
||||||
|
|
||||||
+AUTOMAKE_OPTIONS = foreign
|
|
||||||
SUBDIRS = data doc nls src util
|
|
||||||
MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in stamp-h.in
|
|
||||||
|
|
||||||
--- openbox-2.3.1/nls/convert.awk.orig 2003-07-06 09:11:38.000000000 -0600
|
|
||||||
+++ openbox-2.3.1/nls/convert.awk 2003-07-06 09:12:39.000000000 -0600
|
|
||||||
@@ -4,6 +4,8 @@
|
|
||||||
|
|
||||||
if (major > 1)
|
|
||||||
printf "\n" > output
|
|
||||||
+ else
|
|
||||||
+ printf "$ codeset=utf-8\n" > output
|
|
||||||
printf "$set %d %s\n", major, $3 > output
|
|
||||||
|
|
||||||
if (header) {
|
|
@ -1,3 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
|
|
||||||
exec /etc/X11/xdm/Xsession openbox
|
|
@ -1,3 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
|
|
||||||
exec /usr/bin/openbox
|
|
@ -1,95 +0,0 @@
|
|||||||
Summary: Openbox window manager
|
|
||||||
Name: openbox
|
|
||||||
Version: 2.3.1
|
|
||||||
Release: 1
|
|
||||||
URL: http://www.icculus.org/openbox/
|
|
||||||
Source0: http://www.icculus.org/openbox/releases/%{name}-%{version}.tar.gz
|
|
||||||
Source1: openbox-switchdesk.Xclients
|
|
||||||
Source2: openbox-dm.sessions
|
|
||||||
Patch1: openbox-2.3.1-gcc33.patch
|
|
||||||
Patch2: openbox-2.3.1-nls.patch
|
|
||||||
License: GPL
|
|
||||||
Group: User Interface/X
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
BuildRequires: XFree86-devel, fontconfig-devel, bison
|
|
||||||
Conflicts: fluxbox <= 0.1.14
|
|
||||||
|
|
||||||
%description
|
|
||||||
Openbox is a window manager for the X11 windowing system. It currently
|
|
||||||
runs on a large list of platforms. It was originally based on Blackbox
|
|
||||||
and currently remains very similar, even using Blackbox styles (with
|
|
||||||
available extensions) for its themes.
|
|
||||||
|
|
||||||
%prep
|
|
||||||
echo "
|
|
||||||
--------------------------------------------------------------
|
|
||||||
Fatal C++ errors in the code. Some easy to fix, others not.
|
|
||||||
Package and software version are ancient. Maintenance needed.
|
|
||||||
--------------------------------------------------------------" > /dev/null
|
|
||||||
exit 1
|
|
||||||
|
|
||||||
%setup -q
|
|
||||||
%patch1 -p1 -b .gcc33
|
|
||||||
%patch2 -p1 -b .nls
|
|
||||||
|
|
||||||
%build
|
|
||||||
%configure --enable-xinerama
|
|
||||||
%{__make} %{?_smp_mflags}
|
|
||||||
|
|
||||||
%install
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
%makeinstall
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/apps/switchdesk
|
|
||||||
cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/apps/switchdesk/Xclients.openbox
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/gdm/Sessions
|
|
||||||
cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/gdm/Sessions/Openbox
|
|
||||||
|
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc AUTHORS CHANGELOG* LICENSE README* TODO util/epist/ChangeLog
|
|
||||||
%{_bindir}/*
|
|
||||||
%{_mandir}/man?/*
|
|
||||||
%dir %{_datadir}/openbox
|
|
||||||
%{_datadir}/openbox/epistrc
|
|
||||||
%{_datadir}/openbox/menu
|
|
||||||
%dir %{_datadir}/openbox/buttons
|
|
||||||
%{_datadir}/openbox/buttons/*
|
|
||||||
%{_datadir}/openbox/nls/*
|
|
||||||
%dir %{_datadir}/openbox/styles
|
|
||||||
%{_datadir}/openbox/styles/*
|
|
||||||
%dir %{_sysconfdir}/X11/gdm/Sessions
|
|
||||||
%dir %{_sysconfdir}/X11/gdm
|
|
||||||
%attr(0755,root,root) %config %{_sysconfdir}/X11/gdm/Sessions/Openbox
|
|
||||||
%dir %{_datadir}/apps/switchdesk
|
|
||||||
%attr(0755,root,root) %{_datadir}/apps/switchdesk/Xclients.openbox
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
|
|
||||||
- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
|
|
||||||
- Need to conflict with fluxbox (#422 / #440)
|
|
||||||
|
|
||||||
* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
|
|
||||||
- Need to own /usr/share/apps/switchdesk (#422)
|
|
||||||
|
|
||||||
* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
|
|
||||||
- More spec revisions (#422); change make and preserve timestamps
|
|
||||||
|
|
||||||
* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
|
|
||||||
- Minor spec revisions (#422); add epoch and versions to changelogs
|
|
||||||
|
|
||||||
* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
|
|
||||||
- Add switchdesk support
|
|
||||||
- Add display manager support
|
|
||||||
- Fix NLS build on Cambridge
|
|
||||||
- Fedora'ize the spec
|
|
||||||
|
|
||||||
* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
|
|
||||||
- Rev to 2.3.1 release
|
|
||||||
- Make go with GCC 3.3
|
|
||||||
|
|
||||||
* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
|
|
||||||
- Package of 2.3.0 release
|
|
Loading…
Reference in new issue