parent
074d639f69
commit
4ebd3dd7a7
@ -1,2 +1,2 @@
|
|||||||
setlayout.c
|
setlayout.c
|
||||||
openbox-3.4.10.tar.gz
|
openbox-3.4.11.tar.gz
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,31 +0,0 @@
|
|||||||
commit 62e36ad0410ce888e7097e7bce5cbbf67b5b6290
|
|
||||||
Author: Dana Jansens <danakj@orodu.net>
|
|
||||||
Date: Tue Jan 12 13:59:25 2010 -0500
|
|
||||||
|
|
||||||
Fixes bug #4492 (mis-using the return value of grep -q in openbox-gnome-session script
|
|
||||||
|
|
||||||
diff --git a/data/xsession/openbox-gnome-session.in b/data/xsession/openbox-gnome-session.in
|
|
||||||
index 6765ae8..1f17edb 100644
|
|
||||||
--- a/data/xsession/openbox-gnome-session.in
|
|
||||||
+++ b/data/xsession/openbox-gnome-session.in
|
|
||||||
@@ -37,7 +37,7 @@ else
|
|
||||||
if test -z "$SESSION"; then
|
|
||||||
# if its empty then just run openbox
|
|
||||||
SESSION="[openbox]"
|
|
||||||
- elif test -z $(echo "$SESSION" | grep -q openbox); then
|
|
||||||
+ elif echo "$SESSION" | grep -q openbox; then
|
|
||||||
# if openbox isn't in the session then append it
|
|
||||||
SESSION="${SESSION%]},openbox]"
|
|
||||||
fi
|
|
||||||
diff -up openbox-3.4.10/data/xsession/openbox-gnome-session.in.gnomesession2 openbox-3.4.10/data/xsession/openbox-gnome-session.in
|
|
||||||
--- openbox-3.4.10/data/xsession/openbox-gnome-session.in.gnomesession2 2010-01-21 14:30:07.000000000 +0100
|
|
||||||
+++ openbox-3.4.10/data/xsession/openbox-gnome-session.in 2010-01-21 14:30:47.000000000 +0100
|
|
||||||
@@ -37,7 +37,7 @@ else
|
|
||||||
if test -z "$SESSION"; then
|
|
||||||
# if its empty then just run openbox
|
|
||||||
SESSION="[openbox]"
|
|
||||||
- elif echo "$SESSION" | grep -q openbox; then
|
|
||||||
+ elif ! echo "$SESSION" | grep -q openbox; then
|
|
||||||
# if openbox isn't in the session then append it
|
|
||||||
SESSION="${SESSION%]},openbox]"
|
|
||||||
fi
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -up openbox-3.4.10/Makefile.in.obxpropman openbox-3.4.10/Makefile.in
|
|
||||||
--- openbox-3.4.10/Makefile.in.obxpropman 2010-01-08 10:34:53.000000000 +0100
|
|
||||||
+++ openbox-3.4.10/Makefile.in 2010-01-08 11:55:04.000000000 +0100
|
|
||||||
@@ -976,6 +976,7 @@ dist_doc_DATA = \
|
|
||||||
|
|
||||||
nodist_man_MANS = \
|
|
||||||
doc/openbox.1 \
|
|
||||||
+ doc/obxprop.1 \
|
|
||||||
doc/openbox-session.1 \
|
|
||||||
doc/openbox-gnome-session.1 \
|
|
||||||
doc/openbox-kde-session.1
|
|
@ -0,0 +1,19 @@
|
|||||||
|
diff -up openbox-3.4.11/Makefile.in.xau openbox-3.4.11/Makefile.in
|
||||||
|
--- openbox-3.4.11/Makefile.in.xau 2010-02-09 15:10:36.000000000 +0100
|
||||||
|
+++ openbox-3.4.11/Makefile.in 2010-02-09 15:15:01.000000000 +0100
|
||||||
|
@@ -763,6 +763,7 @@ tools_gnome_panel_control_gnome_panel_co
|
||||||
|
$(X_CFLAGS)
|
||||||
|
|
||||||
|
tools_gnome_panel_control_gnome_panel_control_LDADD = \
|
||||||
|
+ -lXau \
|
||||||
|
$(X_LIBS)
|
||||||
|
|
||||||
|
tools_gnome_panel_control_gnome_panel_control_SOURCES = \
|
||||||
|
@@ -784,6 +785,7 @@ tools_gdm_control_gdm_control_CPPFLAGS =
|
||||||
|
$(GLIB_CFLAGS)
|
||||||
|
|
||||||
|
tools_gdm_control_gdm_control_LDADD = \
|
||||||
|
+ -lXau \
|
||||||
|
$(X_LIBS) \
|
||||||
|
$(GLIB_LIBS)
|
||||||
|
|
Loading…
Reference in new issue