parent
d9745cc2a4
commit
453756ac2b
@ -1,2 +1,2 @@
|
|||||||
setlayout.c
|
setlayout.c
|
||||||
openbox-3.4.8.tar.gz
|
openbox-3.4.9.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up openbox-3.4.7.1/Makefile.in.autostartdir openbox-3.4.7.1/Makefile.in
|
|
||||||
--- openbox-3.4.7.1/Makefile.in.autostartdir 2008-04-16 17:37:46.000000000 +0200
|
|
||||||
+++ openbox-3.4.7.1/Makefile.in 2008-04-16 18:24:22.000000000 +0200
|
|
||||||
@@ -479,7 +479,7 @@ pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
pubincludedir = $(includedir)/openbox/@OB_VERSION@/openbox
|
|
||||||
pixmapdir = $(datadir)/pixmaps
|
|
||||||
xsddir = $(datadir)/openbox
|
|
||||||
-secretbindir = $(libdir)/openbox
|
|
||||||
+secretbindir = $(datadir)/openbox
|
|
||||||
theme = Clearlooks
|
|
||||||
AUTOMAKE_OPTIONS = subdir-objects foreign
|
|
||||||
ACLOCAL_AMFLAGS = -I m4
|
|
@ -1,20 +0,0 @@
|
|||||||
diff -up openbox-3.4.7.2/openbox/session.c.autostartid openbox-3.4.7.2/openbox/session.c
|
|
||||||
--- openbox-3.4.7.2/openbox/session.c.autostartid 2008-04-14 01:22:12.000000000 +0200
|
|
||||||
+++ openbox-3.4.7.2/openbox/session.c 2008-12-09 18:04:50.000000000 +0100
|
|
||||||
@@ -174,6 +174,16 @@ static gboolean session_connect(void)
|
|
||||||
|
|
||||||
/* connect to the server */
|
|
||||||
oldid = ob_sm_id;
|
|
||||||
+
|
|
||||||
+ if (!oldid) {
|
|
||||||
+ const gchar *autostart_id = g_getenv("DESKTOP_AUTOSTART_ID");
|
|
||||||
+
|
|
||||||
+ if (autostart_id) {
|
|
||||||
+ oldid = g_strdup(autostart_id);
|
|
||||||
+ g_unsetenv("DESKTOP_AUTOSTART_ID");
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
ob_debug_type(OB_DEBUG_SM, "Connecting to SM with id: %s\n",
|
|
||||||
oldid ? oldid : "(null)");
|
|
||||||
sm_conn = SmcOpenConnection(NULL, NULL, 1, 0,
|
|
@ -1,39 +0,0 @@
|
|||||||
diff -up openbox-3.4.8/data/xsession/openbox-gnome-session.in.gdm openbox-3.4.8/data/xsession/openbox-gnome-session.in
|
|
||||||
--- openbox-3.4.8/data/xsession/openbox-gnome-session.in.gdm 2009-12-08 21:57:11.000000000 +0100
|
|
||||||
+++ openbox-3.4.8/data/xsession/openbox-gnome-session.in 2009-12-10 14:06:27.000000000 +0100
|
|
||||||
@@ -7,6 +7,9 @@ if test -n "$1"; then
|
|
||||||
exit
|
|
||||||
fi
|
|
||||||
|
|
||||||
+# Clean up after GDM
|
|
||||||
+xprop -root -remove _NET_NUMBER_OF_DESKTOPS -remove _NET_DESKTOP_NAMES -remove _NET_CURRENT_DESKTOP 2> /dev/null
|
|
||||||
+
|
|
||||||
VER=$(gnome-session --version 2>/dev/null | \
|
|
||||||
sed -e 's/[^0-9.]*\([0-9.]\+\)/\1/')
|
|
||||||
|
|
||||||
diff -up openbox-3.4.8/data/xsession/openbox-kde-session.in.gdm openbox-3.4.8/data/xsession/openbox-kde-session.in
|
|
||||||
--- openbox-3.4.8/data/xsession/openbox-kde-session.in.gdm 2009-12-08 15:32:06.000000000 +0100
|
|
||||||
+++ openbox-3.4.8/data/xsession/openbox-kde-session.in 2009-12-10 14:06:04.000000000 +0100
|
|
||||||
@@ -7,6 +7,9 @@ if test -n "$1"; then
|
|
||||||
exit
|
|
||||||
fi
|
|
||||||
|
|
||||||
+# Clean up after GDM
|
|
||||||
+xprop -root -remove _NET_NUMBER_OF_DESKTOPS -remove _NET_DESKTOP_NAMES -remove _NET_CURRENT_DESKTOP 2> /dev/null
|
|
||||||
+
|
|
||||||
# Run KDE with Openbox as its window manager
|
|
||||||
export KDEWM="@bindir@/openbox"
|
|
||||||
exec startkde "$@"
|
|
||||||
diff -up openbox-3.4.8/data/xsession/openbox-session.in.gdm openbox-3.4.8/data/xsession/openbox-session.in
|
|
||||||
--- openbox-3.4.8/data/xsession/openbox-session.in.gdm 2009-12-08 15:37:34.000000000 +0100
|
|
||||||
+++ openbox-3.4.8/data/xsession/openbox-session.in 2009-12-10 14:06:49.000000000 +0100
|
|
||||||
@@ -7,6 +7,9 @@ if test -n "$1"; then
|
|
||||||
exit
|
|
||||||
fi
|
|
||||||
|
|
||||||
+# Clean up after GDM
|
|
||||||
+xprop -root -remove _NET_NUMBER_OF_DESKTOPS -remove _NET_DESKTOP_NAMES -remove _NET_CURRENT_DESKTOP 2> /dev/null
|
|
||||||
+
|
|
||||||
AUTOSTART="${XDG_CONFIG_HOME:-"$HOME/.config"}/openbox/autostart.sh"
|
|
||||||
GLOBALAUTOSTART="@configdir@/openbox/autostart.sh"
|
|
||||||
|
|
@ -1,39 +0,0 @@
|
|||||||
diff -up openbox-3.4.8/data/xsession/openbox-gnome-session.in.gnomesession openbox-3.4.8/data/xsession/openbox-gnome-session.in
|
|
||||||
--- openbox-3.4.8/data/xsession/openbox-gnome-session.in.gnomesession 2009-12-10 14:14:13.000000000 +0100
|
|
||||||
+++ openbox-3.4.8/data/xsession/openbox-gnome-session.in 2009-12-10 14:15:29.000000000 +0100
|
|
||||||
@@ -10,27 +10,13 @@ fi
|
|
||||||
# Clean up after GDM
|
|
||||||
xprop -root -remove _NET_NUMBER_OF_DESKTOPS -remove _NET_DESKTOP_NAMES -remove _NET_CURRENT_DESKTOP 2> /dev/null
|
|
||||||
|
|
||||||
-VER=$(gnome-session --version 2>/dev/null | \
|
|
||||||
- sed -e 's/[^0-9.]*\([0-9.]\+\)/\1/')
|
|
||||||
-
|
|
||||||
-MAJOR=$(echo $VER | cut -d . -f 1)
|
|
||||||
-MINOR=$(echo $VER | cut -d . -f 2)
|
|
||||||
-
|
|
||||||
# Run GNOME with Openbox as its window manager
|
|
||||||
-export WINDOW_MANAGER="@bindir@/openbox"
|
|
||||||
-
|
|
||||||
-if test $MAJOR -lt 2 || (test $MAJOR = 2 && test $MINOR -le 22); then
|
|
||||||
- # old gnome-session allows multiple sessions to be saved
|
|
||||||
- exec gnome-session --choose-session=openbox-session "$@"
|
|
||||||
-else
|
|
||||||
- # make sure the gnome-wm script is being used
|
|
||||||
- gconftool-2 -t string \
|
|
||||||
- -s /desktop/gnome/session/required_components/windowmanager "gnome-wm" \
|
|
||||||
- 2> /dev/null
|
|
||||||
-
|
|
||||||
- # new gnome-session does not allow multiple sessions
|
|
||||||
- exec gnome-session "$@"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-
|
|
||||||
+SESSION=$(gconftool-2 -g /desktop/gnome/session/default_session 2> /dev/null)
|
|
||||||
+test -z "$SESSION" && SESSION="[openbox]"
|
|
||||||
+echo "$SESSION" | grep -q openbox || SESSION="${SESSION%]},openbox]"
|
|
||||||
+
|
|
||||||
+OPENBOX_SESSION=$(gconftool-2 -g /desktop/gnome/session/openbox_session 2> /dev/null)
|
|
||||||
+[ "$SESSION" != "$OPENBOX_SESSION" ] && gconftool-2 -t list --list-type=strings -s \
|
|
||||||
+ /desktop/gnome/session/openbox_session "$SESSION" 2> /dev/null
|
|
||||||
|
|
||||||
+exec gnome-session --default-session-key /desktop/gnome/session/openbox_session "$@"
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up openbox-3.4.8/tools/xdg-autostart/xdg-autostart.xdgautostart openbox-3.4.8/tools/xdg-autostart/xdg-autostart
|
|
||||||
--- openbox-3.4.8/tools/xdg-autostart/xdg-autostart.xdgautostart 2009-12-08 15:32:06.000000000 +0100
|
|
||||||
+++ openbox-3.4.8/tools/xdg-autostart/xdg-autostart 2009-12-10 15:04:45.000000000 +0100
|
|
||||||
@@ -80,7 +80,7 @@ class AutostartFile:
|
|
||||||
def __str__(self):
|
|
||||||
return self.path + " : " + self.de.getName()
|
|
||||||
|
|
||||||
- def _isexecfile(path):
|
|
||||||
+ def _isexecfile(self, path):
|
|
||||||
return os.access(path, os.X_OK)
|
|
||||||
|
|
||||||
def _findFile(self, path, search, match_func):
|
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -up openbox-3.4.9/Makefile.in.autostartdir openbox-3.4.9/Makefile.in
|
||||||
|
--- openbox-3.4.9/Makefile.in.autostartdir 2009-12-18 17:09:20.000000000 +0100
|
||||||
|
+++ openbox-3.4.9/Makefile.in 2009-12-19 11:09:25.000000000 +0100
|
||||||
|
@@ -502,7 +502,7 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
pubincludedir = $(includedir)/openbox/@OB_VERSION@/openbox
|
||||||
|
pixmapdir = $(datadir)/pixmaps
|
||||||
|
xsddir = $(datadir)/openbox
|
||||||
|
-secretbindir = $(libdir)/openbox
|
||||||
|
+secretbindir = $(datadir)/openbox
|
||||||
|
appsdir = $(datadir)/applications
|
||||||
|
theme = Clearlooks
|
||||||
|
AUTOMAKE_OPTIONS = subdir-objects foreign
|
Loading…
Reference in new issue