parent
879bf61006
commit
8dd4d29faf
@ -1,13 +1,11 @@
|
|||||||
Index: openal-soft-1.16.0/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
===================================================================
|
+++ b/CMakeLists.txt
|
||||||
--- openal-soft-1.16.0.orig/CMakeLists.txt
|
@@ -411,7 +411,7 @@ endif()
|
||||||
+++ openal-soft-1.16.0/CMakeLists.txt
|
|
||||||
@@ -679,7 +679,7 @@ ENDIF()
|
|
||||||
# Check for ARM Neon support
|
# Check for ARM Neon support
|
||||||
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
|
option(ALSOFT_REQUIRE_NEON "Require ARM NEON support" OFF)
|
||||||
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H ${FPU_NEON_SWITCH})
|
-if(HAVE_ARM_NEON_H)
|
||||||
-IF(HAVE_ARM_NEON_H)
|
+if(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
||||||
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
option(ALSOFT_CPUEXT_NEON "Enable ARM NEON support" ON)
|
||||||
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
|
if(ALSOFT_CPUEXT_NEON)
|
||||||
IF(ALSOFT_CPUEXT_NEON)
|
check_c_source_compiles("#include <arm_neon.h>
|
||||||
SET(HAVE_NEON 1)
|
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
diff -up openal-soft-1.19.1/Alc/bformatdec.h~ openal-soft-1.19.1/Alc/bformatdec.h
|
|
||||||
--- openal-soft-1.19.1/Alc/bformatdec.h~ 2018-10-12 00:05:31.000000000 +0200
|
|
||||||
+++ openal-soft-1.19.1/Alc/bformatdec.h 2020-02-16 16:11:57.105035079 +0100
|
|
||||||
@@ -24,9 +24,9 @@
|
|
||||||
/* NOTE: These are scale factors as applied to Ambisonics content. Decoder
|
|
||||||
* coefficients should be divided by these values to get proper N3D scalings.
|
|
||||||
*/
|
|
||||||
-const ALfloat N3D2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
-const ALfloat SN3D2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
-const ALfloat FuMa2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
+extern const ALfloat N3D2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
+extern const ALfloat SN3D2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
+extern const ALfloat FuMa2N3DScale[MAX_AMBI_COEFFS];
|
|
||||||
|
|
||||||
|
|
||||||
struct AmbDecConf;
|
|
@ -0,0 +1,21 @@
|
|||||||
|
From 302e88dbf0f10224a5b87be4ce43b3fdd9d20184 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chris Robinson <chris.kcat@gmail.com>
|
||||||
|
Date: Tue, 16 Feb 2021 05:42:14 -0800
|
||||||
|
Subject: [PATCH] Add missing include
|
||||||
|
|
||||||
|
---
|
||||||
|
utils/makemhr/loadsofa.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/utils/makemhr/loadsofa.cpp b/utils/makemhr/loadsofa.cpp
|
||||||
|
index ec000d723..7d091be88 100644
|
||||||
|
--- a/utils/makemhr/loadsofa.cpp
|
||||||
|
+++ b/utils/makemhr/loadsofa.cpp
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
#include <memory>
|
||||||
|
#include <numeric>
|
||||||
|
#include <string>
|
||||||
|
+#include <thread>
|
||||||
|
#include <vector>
|
||||||
|
|
||||||
|
#include "makemhr.h"
|
@ -1 +1 @@
|
|||||||
SHA512 (openal-soft-1.19.1.tar.bz2) = 356a3f12bbe284bfac71f4f2a9f83d084083a832012222e73743042ac27812cf051c12b0ddcf53c010ff77e44ae2e9033cea9b9324d316a22a59a154307a64a4
|
SHA512 (openal-soft-1.21.1.tar.bz2) = 420eec18149a9b784daaabe8a2865de3b87d5550cf2e8e06569464d0b5ba6e51d904c18f1461af08676bf8c8b76ef270e860008d79545a5f85131299e89bffd4
|
||||||
|
Loading…
Reference in new issue