Updated to version 1.21.1.

epel10
Vitaly Zaitsev 3 years ago
parent 879bf61006
commit 8dd4d29faf
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A

1
.gitignore vendored

@ -8,3 +8,4 @@ openal-soft-1.12.854.tar.bz2
/openal-soft-1.18.2.tar.bz2
/openal-soft-1.19.0.tar.bz2
/openal-soft-1.19.1.tar.bz2
/openal-soft-1.21.1.tar.bz2

@ -1,13 +1,11 @@
Index: openal-soft-1.16.0/CMakeLists.txt
===================================================================
--- openal-soft-1.16.0.orig/CMakeLists.txt
+++ openal-soft-1.16.0/CMakeLists.txt
@@ -679,7 +679,7 @@ ENDIF()
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -411,7 +411,7 @@ endif()
# Check for ARM Neon support
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H ${FPU_NEON_SWITCH})
-IF(HAVE_ARM_NEON_H)
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
IF(ALSOFT_CPUEXT_NEON)
SET(HAVE_NEON 1)
option(ALSOFT_REQUIRE_NEON "Require ARM NEON support" OFF)
-if(HAVE_ARM_NEON_H)
+if(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
option(ALSOFT_CPUEXT_NEON "Enable ARM NEON support" ON)
if(ALSOFT_CPUEXT_NEON)
check_c_source_compiles("#include <arm_neon.h>

@ -1,16 +0,0 @@
diff -up openal-soft-1.19.1/Alc/bformatdec.h~ openal-soft-1.19.1/Alc/bformatdec.h
--- openal-soft-1.19.1/Alc/bformatdec.h~ 2018-10-12 00:05:31.000000000 +0200
+++ openal-soft-1.19.1/Alc/bformatdec.h 2020-02-16 16:11:57.105035079 +0100
@@ -24,9 +24,9 @@
/* NOTE: These are scale factors as applied to Ambisonics content. Decoder
* coefficients should be divided by these values to get proper N3D scalings.
*/
-const ALfloat N3D2N3DScale[MAX_AMBI_COEFFS];
-const ALfloat SN3D2N3DScale[MAX_AMBI_COEFFS];
-const ALfloat FuMa2N3DScale[MAX_AMBI_COEFFS];
+extern const ALfloat N3D2N3DScale[MAX_AMBI_COEFFS];
+extern const ALfloat SN3D2N3DScale[MAX_AMBI_COEFFS];
+extern const ALfloat FuMa2N3DScale[MAX_AMBI_COEFFS];
struct AmbDecConf;

@ -0,0 +1,21 @@
From 302e88dbf0f10224a5b87be4ce43b3fdd9d20184 Mon Sep 17 00:00:00 2001
From: Chris Robinson <chris.kcat@gmail.com>
Date: Tue, 16 Feb 2021 05:42:14 -0800
Subject: [PATCH] Add missing include
---
utils/makemhr/loadsofa.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/utils/makemhr/loadsofa.cpp b/utils/makemhr/loadsofa.cpp
index ec000d723..7d091be88 100644
--- a/utils/makemhr/loadsofa.cpp
+++ b/utils/makemhr/loadsofa.cpp
@@ -34,6 +34,7 @@
#include <memory>
#include <numeric>
#include <string>
+#include <thread>
#include <vector>
#include "makemhr.h"

@ -1,21 +1,21 @@
%define __cmake_in_source_build 1
%undefine __cmake_in_source_build
Name: openal-soft
Version: 1.19.1
Release: 15%{?dist}
Version: 1.21.1
Release: 1%{?dist}
Summary: Open Audio Library
License: LGPLv2+
URL: http://openal-soft.org/
Source0: http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
Patch0: openal-soft-arm_neon-only-for-32bit.patch
Patch1: openal-soft-fcommon-fix.patch
Patch1: openal-soft-libmysofa-include-fix.patch
BuildRequires: make
BuildRequires: alsa-lib-devel
BuildRequires: cmake
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: ninja-build
%if 0%{?fedora}
BuildRequires: fluidsynth-devel
BuildRequires: portaudio-devel
@ -23,6 +23,8 @@ BuildRequires: portaudio-devel
%if 0%{?fedora} || 0%{?rhel} < 9
BuildRequires: SDL_sound-devel
%endif
BuildRequires: libmysofa-devel
BuildRequires: libsndfile-devel
BuildRequires: pulseaudio-libs-devel
BuildRequires: qt5-qtbase-devel
BuildRequires: SDL2-devel
@ -69,20 +71,25 @@ for configuring OpenAL features.
%autosetup -p1
%build
%cmake -DALSOFT_CPUEXT_NEON:BOOL=OFF .
%make_build
%cmake -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DALSOFT_CPUEXT_NEON:BOOL=OFF \
-DALSOFT_EXAMPLES:BOOL=ON \
-DALSOFT_UTILS:BOOL=ON \
-DALSOFT_INSTALL_CONFIG:BOOL=ON \
-DALSOFT_INSTALL_EXAMPLES:BOOL=ON \
-DALSOFT_INSTALL_HRTF_DATA:BOOL=ON \
-DALSOFT_INSTALL_UTILS:BOOL=ON
%cmake_build
%install
%make_install
%cmake_install
find %{buildroot} -name '*.la' -exec rm -f {} ';'
install -Dpm644 alsoftrc.sample %{buildroot}%{_sysconfdir}/openal/alsoft.conf
# Don't pin the pulseaudio stream to a specific output device
sed -i 's/#allow-moves = false/allow-moves = true/' \
%{buildroot}%{_sysconfdir}/openal/alsoft.conf
%ldconfig_scriptlets
%files
%doc COPYING
%{_bindir}/openal-info
@ -94,7 +101,7 @@ sed -i 's/#allow-moves = false/allow-moves = true/' \
%exclude %{_datadir}/openal/presets/presets.txt
%files devel
%{_bindir}/makehrtf
%{_bindir}/makemhr
%{_includedir}/*
%{_libdir}/libopenal.so
%{_libdir}/pkgconfig/openal.pc
@ -117,6 +124,9 @@ sed -i 's/#allow-moves = false/allow-moves = true/' \
%{_bindir}/alsoft-config
%changelog
* Mon Sep 06 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 1.21.1-1
- Updated to version 1.21.1.
* Wed Aug 04 2021 Wim Taymans <wtaymans@redhat.com> - 1.19.1-15
- Don't package some examples when SDL_sound is disabled

@ -1 +1 @@
SHA512 (openal-soft-1.19.1.tar.bz2) = 356a3f12bbe284bfac71f4f2a9f83d084083a832012222e73743042ac27812cf051c12b0ddcf53c010ff77e44ae2e9033cea9b9324d316a22a59a154307a64a4
SHA512 (openal-soft-1.21.1.tar.bz2) = 420eec18149a9b784daaabe8a2865de3b87d5550cf2e8e06569464d0b5ba6e51d904c18f1461af08676bf8c8b76ef270e860008d79545a5f85131299e89bffd4

Loading…
Cancel
Save