All NEON checks will be disabled by `-DALSOFT_CPUEXT_NEON:BOOL=OFF`.epel10
parent
41f0e1d95b
commit
7aab51dea9
@ -1,11 +0,0 @@
|
|||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -411,7 +411,7 @@ endif()
|
|
||||||
|
|
||||||
# Check for ARM Neon support
|
|
||||||
option(ALSOFT_REQUIRE_NEON "Require ARM NEON support" OFF)
|
|
||||||
-if(HAVE_ARM_NEON_H)
|
|
||||||
+if(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
|
||||||
option(ALSOFT_CPUEXT_NEON "Enable ARM NEON support" ON)
|
|
||||||
if(ALSOFT_CPUEXT_NEON)
|
|
||||||
check_c_source_compiles("#include <arm_neon.h>
|
|
Loading…
Reference in new issue