ignore -s option

epel9
Tom Callaway 10 years ago
parent 164ad01445
commit ad0fdcf156

@ -0,0 +1,24 @@
diff -up ntfs-3g_ntfsprogs-2014.2.15/src/ntfs-3g_common.c.ref ntfs-3g_ntfsprogs-2014.2.15/src/ntfs-3g_common.c
--- ntfs-3g_ntfsprogs-2014.2.15/src/ntfs-3g_common.c.ref 2015-01-13 14:31:55.648115825 -0500
+++ ntfs-3g_ntfsprogs-2014.2.15/src/ntfs-3g_common.c 2015-01-13 14:32:47.514838649 -0500
@@ -553,7 +553,7 @@ int ntfs_parse_options(struct ntfs_optio
{
int c;
- static const char *sopt = "-o:hnvV";
+ static const char *sopt = "-o:hnsvV";
static const struct option lopt[] = {
{ "options", required_argument, NULL, 'o' },
{ "help", no_argument, NULL, 'h' },
@@ -613,6 +613,11 @@ int ntfs_parse_options(struct ntfs_optio
* we don't use it because mount(8) passes it.
*/
break;
+ case 's':
+ /*
+ * no effect - automount passes it, meaning sloppy
+ */
+ break;
case 'V':
ntfs_log_info("%s %s %s %d\n", EXEC_NAME, VERSION,
FUSE_TYPE, fuse_version());

@ -8,7 +8,7 @@
Name: ntfs-3g Name: ntfs-3g
Summary: Linux NTFS userspace driver Summary: Linux NTFS userspace driver
Version: 2014.2.15 Version: 2014.2.15
Release: 6%{?dist} Release: 7%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Base Group: System Environment/Base
Source0: http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}%{?subver}.tgz Source0: http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}%{?subver}.tgz
@ -33,6 +33,9 @@ Patch1: 0001-Upgraded-fuse-lite-to-support-ioctls.patch
Patch2: 0002-Implemented-fstrim-8.patch Patch2: 0002-Implemented-fstrim-8.patch
# c26a519da1ed182e7cfd67e7a353932dda53d811 # c26a519da1ed182e7cfd67e7a353932dda53d811
Patch3: 0001-Fixed-fstrim-8-applied-to-partitions.patch Patch3: 0001-Fixed-fstrim-8-applied-to-partitions.patch
# Upstream offered this patch in bugzilla
Patch4: ntfs-3g-ignore-s-option.patch
# Patch2 requires that libntfs-3g/Makefile is regenerated. This can # Patch2 requires that libntfs-3g/Makefile is regenerated. This can
# be removed, as well as the call to autoreconf below, when we move to # be removed, as well as the call to autoreconf below, when we move to
# a released version of ntfs-3g that includes the new feature. # a released version of ntfs-3g that includes the new feature.
@ -85,6 +88,7 @@ included utilities see man 8 ntfsprogs after installation).
%patch1 -p1 -b .ioctl %patch1 -p1 -b .ioctl
%patch2 -p1 -b .fstrim %patch2 -p1 -b .fstrim
%patch3 -p1 -b .parts %patch3 -p1 -b .parts
%patch4 -p1 -b .sopt
autoreconf -i autoreconf -i
%build %build
@ -184,6 +188,9 @@ rm -rf %{buildroot}%{_defaultdocdir}/%{name}/README
%exclude %{_mandir}/man8/ntfs-3g* %exclude %{_mandir}/man8/ntfs-3g*
%changelog %changelog
* Tue Jan 13 2015 Tom Callaway <spot@fedoraproject.org> - 2:2014.2.15-7
- add patch to ignore -s option
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:2014.2.15-6 * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:2014.2.15-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

Loading…
Cancel
Save