i10ce
changed/i10ce/noopenh264-0.1.0%7eopenh264_2.4.1-2.el10
commit
e2913d7844
@ -0,0 +1 @@
|
|||||||
|
SOURCES/noopenh264-v2.4.1.tar.bz2
|
@ -0,0 +1 @@
|
|||||||
|
80d6e951012135ed6c8c9c8c3eaa24fbfe18909f SOURCES/noopenh264-v2.4.1.tar.bz2
|
@ -0,0 +1,27 @@
|
|||||||
|
From 1b4ace18e696d7f191941dbfd5ab4251e7b94b16 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kalev Lember <klember@redhat.com>
|
||||||
|
Date: Thu, 8 Feb 2024 20:30:06 +0100
|
||||||
|
Subject: [PATCH] Fix the build
|
||||||
|
|
||||||
|
Update meson.build to match the directory layout changes from commit
|
||||||
|
7a1ee6907e4ae8f3cdd2a4c87df3e5a98b48a7ea.
|
||||||
|
---
|
||||||
|
meson.build | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index bc4b7c9..306c99a 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -20,7 +20,7 @@ includedir = join_paths(prefix, get_option('includedir'))
|
||||||
|
cpp = meson.get_compiler('cpp')
|
||||||
|
|
||||||
|
inc = include_directories([
|
||||||
|
- join_paths('codec', 'api', 'svc'),
|
||||||
|
+ join_paths('codec', 'api', 'wels'),
|
||||||
|
])
|
||||||
|
|
||||||
|
api_headers = []
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -0,0 +1,3 @@
|
|||||||
|
# noopenh264
|
||||||
|
|
||||||
|
The noopenh264 package
|
@ -0,0 +1,115 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
%global openh264_version 2.4.1
|
||||||
|
%global openh264_soversion 7
|
||||||
|
|
||||||
|
Name: noopenh264
|
||||||
|
# 0.1.0 is the project version from meson.build.
|
||||||
|
# Additionally, we also include the openh264 version as part of the
|
||||||
|
# version tag. As "openh264" ends with a digit, _ is used as a separator
|
||||||
|
# between "openh264" and the openh264 version number.
|
||||||
|
Version: 0.1.0~openh264_%{openh264_version}
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Fake implementation of the OpenH264 library
|
||||||
|
|
||||||
|
License: BSD-2-Clause and LGPL-2.1-or-later
|
||||||
|
URL: https://gitlab.com/freedesktop-sdk/noopenh264
|
||||||
|
%global tag v%{openh264_version}
|
||||||
|
Source: %{url}/-/archive/%{tag}/noopenh264-%{tag}.tar.bz2
|
||||||
|
|
||||||
|
# https://gitlab.com/freedesktop-sdk/noopenh264/-/merge_requests/6
|
||||||
|
Patch: 0001-Fix-the-build.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: meson
|
||||||
|
|
||||||
|
# Explicitly conflict with openh264 that ships the actual
|
||||||
|
# non-dummy version of the library.
|
||||||
|
Conflicts: openh264
|
||||||
|
|
||||||
|
%description
|
||||||
|
Fake implementation of the OpenH264 library we can link from
|
||||||
|
regardless of the actual library being available.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
# Explicitly conflict with openh264-devel that ships the actual
|
||||||
|
# non-dummy version of the library.
|
||||||
|
Conflicts: openh264-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n noopenh264-%{tag}
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%meson
|
||||||
|
%meson_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%meson_install
|
||||||
|
|
||||||
|
# Remove static library
|
||||||
|
rm $RPM_BUILD_ROOT%{_libdir}/*.a
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING*
|
||||||
|
%doc README
|
||||||
|
%{_libdir}/libopenh264.so.%{openh264_soversion}
|
||||||
|
%{_libdir}/libopenh264.so.%{openh264_version}
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/wels/
|
||||||
|
%{_libdir}/libopenh264.so
|
||||||
|
%{_libdir}/pkgconfig/openh264.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Dec 23 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.0~openh264_2.4.1-2
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0~openh264_2.4.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 24 2024 Kalev Lember <klember@redhat.com> - 0.1.0~openh264_2.4.1-1
|
||||||
|
- Update for openh264 2.4.1
|
||||||
|
|
||||||
|
* Thu Feb 08 2024 Kalev Lember <klember@redhat.com> - 0.1.0~openh264_2.4.0-1
|
||||||
|
- Update for openh264 2.4.0
|
||||||
|
|
||||||
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0~openh264_2.3.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0~openh264_2.3.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 06 2023 Kalev Lember <klember@redhat.com> - 0.1.0~openh264_2.3.1-1
|
||||||
|
- Switch to using upstream openh264-2.3.1 tag
|
||||||
|
- Make sure the matching openh264 version is listed as part of the rpm
|
||||||
|
version tag
|
||||||
|
- Stop using forge macros to get better control over the version and
|
||||||
|
release tags
|
||||||
|
|
||||||
|
* Mon Nov 06 2023 Kalev Lember <klember@redhat.com> - 0.1-2
|
||||||
|
- Move pkg-config file to correct subpackage
|
||||||
|
|
||||||
|
* Mon Nov 06 2023 Kalev Lember <klember@redhat.com> - 0.1-1
|
||||||
|
- Initial Fedora packaging (rhbz#2247274)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue