Update to 3.4.1

Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>
f40
Michel Alexandre Salim 3 years ago
parent 3f0b10f60d
commit a15bf6c9be

41
.gitignore vendored

@ -1,40 +1 @@
/v2.2.4.tar.gz /desktop-3.4.1.tar.gz
/nextcloud-client-2.2.4.tar.bz2
/owncloudclient-2.2.4.tar.xz
/v2.3.1.tar.gz
/client-2.3.2.tar.gz
/owncloudclient-2.3.2.tar.xz
/owncloudclient-2.3.3.tar.xz
/v2.3.2.tar.gz
/owncloudclient-2.4.0.tar.xz
/client_theming-2.3.3.tar.gz
/v2.3.3.tar.gz
/desktop-2.5.0.tar.gz
/desktop-2.5.1.tar.gz
/desktop-2.5.2.tar.gz
/desktop-2.5.3.tar.gz
/desktop-2.6.0-rc1.tar.gz
/desktop-2.6.0.tar.gz
/desktop-2.6.1.tar.gz
/desktop-2.6.2.tar.gz
/desktop-2.6.3.tar.gz
/desktop-2.6.4.tar.gz
/desktop-2.6.5.tar.gz
/desktop-3.0.1.tar.gz
/desktop-3.0.2.tar.gz
/desktop-3.0.3.tar.gz
/desktop-3.1.0.tar.gz
/desktop-3.1.1.tar.gz
/desktop-3.1.3.tar.gz
/desktop-3.2.0.tar.gz
/desktop-3.2.1.tar.gz
/desktop-3.2.2.tar.gz
/desktop-3.2.3.tar.gz
/desktop-3.2.4.tar.gz
/desktop-3.3.0.tar.gz
/desktop-3.3.1.tar.gz
/desktop-3.3.2.tar.gz
/desktop-3.3.3.tar.gz
/desktop-3.3.4.tar.gz
/desktop-3.3.5.tar.gz
/desktop-3.3.6.tar.gz

@ -1,8 +1,10 @@
%if 0%{?el8}
%undefine __cmake_in_source_build %undefine __cmake_in_source_build
%undefine _cmake_skip_rpath %undefine _cmake_skip_rpath
%endif
Name: nextcloud-client Name: nextcloud-client
Version: 3.3.6 Version: 3.4.1
Release: %autorelease Release: %autorelease
Summary: The Nextcloud Client Summary: The Nextcloud Client
@ -11,17 +13,9 @@ License: LGPLv2+ and GPLv2
Url: https://nextcloud.com/install/#install-clients Url: https://nextcloud.com/install/#install-clients
Source0: https://github.com/nextcloud/desktop/archive/v%{version}/desktop-%{version}.tar.gz Source0: https://github.com/nextcloud/desktop/archive/v%{version}/desktop-%{version}.tar.gz
Source1: nextcloud.appdata.xml Source1: nextcloud.appdata.xml
# The patch does 3 things:
# - Depends on system lib for QtSingleApplication and QtLockedFile
# - Remove the extraneous namespace when calling QtSingleApplication
# - Fix a mismatch in the QtSingleApplication::messageReceived signal and the
# Application::slotParseMessage slot
# These fix are needed because the system wide QtSingleApplication is slightly
# different from the bundled one.
#Patch0: %%{name}-%%{version}-syslibs.patch
# Patch0: fixes GNOME quirks on Wayland sessions. Read # Patch0: fixes GNOME quirks on Wayland sessions. Read
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/3BVLBS4B3XHJEXFVGD7RK2ZMXZG6JQZT/ # https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/3BVLBS4B3XHJEXFVGD7RK2ZMXZG6JQZT/
Patch2: xcb_%{version}.patch Patch0: xcb_%{version}.patch
BuildRequires: check BuildRequires: check
BuildRequires: chrpath BuildRequires: chrpath
@ -149,8 +143,7 @@ The nextcloud desktop client dolphin extension.
%endif %endif
%prep %prep
%setup -q -n desktop-%{version} %autosetup -p1 -n desktop-%{version}
%patch2 -p1
# change compiler flag # change compiler flag
sed -i 's/-fPIE/-fPIC/g' src/gui/CMakeLists.txt sed -i 's/-fPIE/-fPIC/g' src/gui/CMakeLists.txt

@ -1 +1 @@
SHA512 (desktop-3.3.6.tar.gz) = d6c16ebd8af0d97f412102cfa9f7b7d4ca502ff5d025618f3a98a33a068dce9d0b71ee71e7b3c3a02219929584559a1237d57b1a7aa27ad8234653b56530c9f0 SHA512 (desktop-3.4.1.tar.gz) = e4ee5a2601fe7e4a9c8e34ab84bbf3961c5c55e87d7c489190ac03a7d55e27235f68205095d85030ac2c3aed0fd1672e50217ad5f821db5fae346de57c29867b

@ -1,6 +1,7 @@
--- desktop-3.3.6-orig/src/gui/main.cpp 2021-10-31 10:39:15.179363699 -0400 diff -ruN desktop-3.4.1-orig/src/gui/main.cpp desktop-3.4.1/src/gui/main.cpp
+++ desktop-3.3.6/src/gui/main.cpp 2021-10-31 10:40:48.443965726 -0400 --- desktop-3.4.1-orig/src/gui/main.cpp 2021-12-17 07:52:51.000000000 -0800
@@ -49,8 +49,26 @@ +++ desktop-3.4.1/src/gui/main.cpp 2022-01-15 14:02:39.460156432 -0800
@@ -56,8 +56,24 @@
.arg(Theme::instance()->appNameGUI())); .arg(Theme::instance()->appNameGUI()));
} }
@ -19,11 +20,9 @@
+ +
int main(int argc, char **argv) int main(int argc, char **argv)
{ {
+ +#ifdef Q_OS_LIUX
+#ifdef Q_OS_LINUX
+ wayland_hacks(); + wayland_hacks();
+#endif +#endif
+
#ifdef Q_OS_WIN #ifdef Q_OS_WIN
SetDllDirectory(L""); SetDllDirectory(L"");
#endif #endif
Loading…
Cancel
Save