- Add patch to cleanup nc-config --fflags

epel9
Orion Poplawski 15 years ago
parent dc922e4aa0
commit fda5c162a3

@ -1,11 +0,0 @@
--- netcdf-4.1-snapshot2009111008/libsrc4/Makefile.in.hdf5 2009-11-10 08:38:09.000000000 -0700
+++ netcdf-4.1-snapshot2009111008/libsrc4/Makefile.in 2009-11-11 16:58:44.846340629 -0700
@@ -791,7 +791,7 @@
# Our output library will also include contents of the netcdf3
# convenience library.
libnetcdf_la_LIBADD = ../libsrc/libnetcdf3.la $(am__append_11) \
- $(am__append_12) $(am__append_13)
+ $(am__append_12) $(am__append_13) -lhdf5_hl -lhdf5
@BUILD_V2_TRUE@TST_V2 = tst_v2
# Netcdf-4 source.

@ -1,34 +0,0 @@
diff -up netcdf-4.1-snapshot2010020100/nc-config.in.pkgconfig netcdf-4.1-snapshot2010020100/nc-config.in
--- netcdf-4.1-snapshot2010020100/nc-config.in.pkgconfig 2010-01-11 12:27:12.000000000 -0700
+++ netcdf-4.1-snapshot2010020100/nc-config.in 2010-02-01 16:04:22.429448744 -0700
@@ -8,7 +8,6 @@
prefix=@prefix@
exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
includedir=${prefix}/include
cc="@CC@"
@@ -16,8 +15,6 @@ cxx="@CXX@"
fc="@FC@"
cflags=" -I${includedir}"
fflags="@FFLAGS@ @MOD_FLAG@${includedir}"
-libs="-L${libdir} @NC_LIBS@"
-flibs="-L${libdir} @NC_FLIBS@"
has_dap="@HAS_DAP@"
has_nc2="@HAS_NC2@"
has_nc4="@HAS_NC4@"
@@ -138,11 +135,11 @@ while test $# -gt 0; do
;;
--libs)
- echo $libs
+ pkg-config netcdf --libs
;;
--flibs)
- echo $flibs
+ pkg-config netcdf --flibs
;;
--has-dap)

@ -0,0 +1,13 @@
--- netcdf-4.1.1/nc-config.in.fflags 2010-04-08 14:05:40.063132547 -0600
+++ netcdf-4.1.1/nc-config.in 2010-04-09 13:53:26.923928260 -0600
@@ -13,8 +13,8 @@
cc="@CC@"
cxx="@CXX@"
fc="@FC@"
-cflags=" -I${includedir}"
-fflags="@FFLAGS@ @MOD_FLAG@${includedir}"
+cflags="-I${includedir}"
+fflags="@MOD_FLAG@${includedir}"
has_dap="@HAS_DAP@"
has_nc2="@HAS_NC2@"
has_nc4="@HAS_NC4@"

@ -1,6 +1,6 @@
Name: netcdf Name: netcdf
Version: 4.1.1 Version: 4.1.1
Release: 1%{?dist} Release: 2%{?dist}
Summary: Libraries for the Unidata network Common Data Form Summary: Libraries for the Unidata network Common Data Form
Group: Applications/Engineering Group: Applications/Engineering
@ -9,6 +9,7 @@ URL: http://www.unidata.ucar.edu/software/netcdf/
Source0: http://www.unidata.ucar.edu/downloads/netcdf/ftp/netcdf-4.1.1.tar.gz Source0: http://www.unidata.ucar.edu/downloads/netcdf/ftp/netcdf-4.1.1.tar.gz
#Use pkgconfig in nc-config to avoid multi-lib issues #Use pkgconfig in nc-config to avoid multi-lib issues
Patch0: netcdf-4.1-beta2-pkgconfig.patch Patch0: netcdf-4.1-beta2-pkgconfig.patch
Patch1: netcdf-4.1.1-fflags.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gcc-gfortran, gawk BuildRequires: gcc-gfortran, gawk
@ -74,6 +75,7 @@ This package contains the netCDF static libs.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .pkgconfig %patch0 -p1 -b .pkgconfig
%patch1 -p1 -b .fflags
%build %build
@ -156,6 +158,9 @@ fi
%changelog %changelog
* Fri Apr 9 2010 Orion Poplawski <orion@cora.nwra.com> - 4.1.1-2
- Add patch to cleanup nc-config --fflags
* Thu Apr 8 2010 Orion Poplawski <orion@cora.nwra.com> - 4.1.1-1 * Thu Apr 8 2010 Orion Poplawski <orion@cora.nwra.com> - 4.1.1-1
- Update to 4.1.1 - Update to 4.1.1

Loading…
Cancel
Save