commit
65db7f8ac5
@ -0,0 +1 @@
|
|||||||
|
SOURCES/mutter-47.0.tar.xz
|
@ -0,0 +1 @@
|
|||||||
|
c4f2828ee59165d74d0da8da6f38ac686dbdbf2c SOURCES/mutter-47.0.tar.xz
|
@ -0,0 +1,63 @@
|
|||||||
|
From 9ae5ee2ce58f6dcbadeac05ba05be0c329184c16 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||||
|
Date: Mon, 9 Sep 2024 19:59:56 +0200
|
||||||
|
Subject: [PATCH] Revert "Replace deprecated g_qsort_with_data with
|
||||||
|
g_sort_array"
|
||||||
|
|
||||||
|
This reverts commit 7610973a948bce0b2aea8e1a8e2fb01e00d3526f.
|
||||||
|
---
|
||||||
|
clutter/clutter/clutter-box-layout.c | 6 +++---
|
||||||
|
clutter/clutter/clutter-grid-layout.c | 6 +++---
|
||||||
|
meson.build | 2 +-
|
||||||
|
3 files changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/clutter/clutter/clutter-box-layout.c b/clutter/clutter/clutter-box-layout.c
|
||||||
|
index af814f17dd..12aaa2091b 100644
|
||||||
|
--- a/clutter/clutter/clutter-box-layout.c
|
||||||
|
+++ b/clutter/clutter/clutter-box-layout.c
|
||||||
|
@@ -588,9 +588,9 @@ distribute_natural_allocation (float extra_space,
|
||||||
|
*/
|
||||||
|
|
||||||
|
/* Sort descending by gap and position. */
|
||||||
|
- g_sort_array (spreading,
|
||||||
|
- n_requested_sizes, sizeof (unsigned int),
|
||||||
|
- compare_gap, sizes);
|
||||||
|
+ g_qsort_with_data (spreading,
|
||||||
|
+ n_requested_sizes, sizeof (unsigned int),
|
||||||
|
+ compare_gap, sizes);
|
||||||
|
|
||||||
|
/* Distribute available space.
|
||||||
|
* This master piece of a loop was conceived by Behdad Esfahbod.
|
||||||
|
diff --git a/clutter/clutter/clutter-grid-layout.c b/clutter/clutter/clutter-grid-layout.c
|
||||||
|
index 22f9cf7ec7..8a2c485c23 100644
|
||||||
|
--- a/clutter/clutter/clutter-grid-layout.c
|
||||||
|
+++ b/clutter/clutter/clutter-grid-layout.c
|
||||||
|
@@ -971,9 +971,9 @@ distribute_natural_allocation (gint extra_space,
|
||||||
|
*/
|
||||||
|
|
||||||
|
/* Sort descending by gap and position. */
|
||||||
|
- g_sort_array (spreading,
|
||||||
|
- n_requested_sizes, sizeof (guint),
|
||||||
|
- compare_gap, sizes);
|
||||||
|
+ g_qsort_with_data (spreading,
|
||||||
|
+ n_requested_sizes, sizeof (guint),
|
||||||
|
+ compare_gap, sizes);
|
||||||
|
|
||||||
|
/* Distribute available space.
|
||||||
|
* This master piece of a loop was conceived by Behdad Esfahbod.
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 565e3729fa..68c909b408 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -16,7 +16,7 @@ mutter_builddir = meson.current_build_dir()
|
||||||
|
lcms2_req = '>= 2.6'
|
||||||
|
colord_req = '>= 1.4.5'
|
||||||
|
fribidi_req = '>= 1.0.0'
|
||||||
|
-glib_req = '>= 2.81.1'
|
||||||
|
+glib_req = '>= 2.75.1'
|
||||||
|
gi_req = '>= 0.9.5'
|
||||||
|
graphene_req = '>= 1.10.2'
|
||||||
|
gtk3_req = '>= 3.19.8'
|
||||||
|
--
|
||||||
|
2.46.0
|
||||||
|
|
@ -0,0 +1,66 @@
|
|||||||
|
From beff8f13ed0cf16fa0b22f69de75f83e0378fdf1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||||
|
Date: Mon, 22 Jul 2024 12:37:01 +0200
|
||||||
|
Subject: [PATCH 1/3] Revert "x11/window: Compare input shape to client rect
|
||||||
|
when undecorating"
|
||||||
|
|
||||||
|
This reverts commit 1f1538be764ec5018b29d31c4486c0649a4e5068.
|
||||||
|
---
|
||||||
|
src/x11/window-x11.c | 16 +++++++++-------
|
||||||
|
1 file changed, 9 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/x11/window-x11.c b/src/x11/window-x11.c
|
||||||
|
index adf5075a9b..e7c76dd674 100644
|
||||||
|
--- a/src/x11/window-x11.c
|
||||||
|
+++ b/src/x11/window-x11.c
|
||||||
|
@@ -2415,7 +2415,6 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
g_autoptr (MtkRegion) region = NULL;
|
||||||
|
MetaWindowX11 *window_x11 = META_WINDOW_X11 (window);
|
||||||
|
MetaWindowX11Private *priv = meta_window_x11_get_instance_private (window_x11);
|
||||||
|
- MtkRectangle bounding_rect = { 0 };
|
||||||
|
Window xwindow;
|
||||||
|
|
||||||
|
if (window->decorated)
|
||||||
|
@@ -2427,14 +2426,10 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
xwindow = priv->frame->xwindow;
|
||||||
|
- bounding_rect.width = window->buffer_rect.width;
|
||||||
|
- bounding_rect.height = window->buffer_rect.height;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
xwindow = priv->xwindow;
|
||||||
|
- bounding_rect.width = priv->client_rect.width;
|
||||||
|
- bounding_rect.height = priv->client_rect.height;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (META_X11_DISPLAY_HAS_SHAPE (x11_display))
|
||||||
|
@@ -2478,8 +2473,8 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
else if (n_rects == 1 &&
|
||||||
|
(rects[0].x == 0 &&
|
||||||
|
rects[0].y == 0 &&
|
||||||
|
- rects[0].width == bounding_rect.width &&
|
||||||
|
- rects[0].height == bounding_rect.height))
|
||||||
|
+ rects[0].width == window->buffer_rect.width &&
|
||||||
|
+ rects[0].height == window->buffer_rect.height))
|
||||||
|
{
|
||||||
|
/* This is the bounding region case. Keep the
|
||||||
|
* region as NULL. */
|
||||||
|
@@ -2496,6 +2491,13 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
|
||||||
|
if (region != NULL)
|
||||||
|
{
|
||||||
|
+ MtkRectangle bounding_rect;
|
||||||
|
+
|
||||||
|
+ bounding_rect.x = 0;
|
||||||
|
+ bounding_rect.y = 0;
|
||||||
|
+ bounding_rect.width = window->buffer_rect.width;
|
||||||
|
+ bounding_rect.height = window->buffer_rect.height;
|
||||||
|
+
|
||||||
|
/* The shape we get back from the client may have coordinates
|
||||||
|
* outside of the frame. The X SHAPE Extension requires that
|
||||||
|
* the overall shape the client provides never exceeds the
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
@ -0,0 +1,35 @@
|
|||||||
|
From c0fda823b3f0c6802afe549379135719f86c6bfc Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Williamson <awilliam@redhat.com>
|
||||||
|
Date: Tue, 9 Mar 2021 17:21:59 -0800
|
||||||
|
Subject: [PATCH] Test: deny atomic KMS for "tegra" (RHBZ #1936991)
|
||||||
|
|
||||||
|
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||||
|
---
|
||||||
|
data/61-mutter.rules | 1 +
|
||||||
|
src/backends/native/meta-kms-impl-device-atomic.c | 1 +
|
||||||
|
2 files changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/data/61-mutter.rules b/data/61-mutter.rules
|
||||||
|
index 9262b152b9..24f9655b69 100644
|
||||||
|
--- a/data/61-mutter.rules
|
||||||
|
+++ b/data/61-mutter.rules
|
||||||
|
@@ -114,3 +114,4 @@ DRIVERS=="i915", SUBSYSTEM=="drm", ATTRS{vendor}=="0x8086", ATTRS{device}=="0x9b
|
||||||
|
DRIVERS=="i915", SUBSYSTEM=="drm", ATTRS{vendor}=="0x8086", ATTRS{device}=="0x9be6", TAG+="mutter-device-disable-kms-modifiers"
|
||||||
|
DRIVERS=="i915", SUBSYSTEM=="drm", ATTRS{vendor}=="0x8086", ATTRS{device}=="0x9bf6", TAG+="mutter-device-disable-kms-modifiers"
|
||||||
|
ENV{ID_PATH}=="platform-vkms", TAG+="mutter-device-ignore"
|
||||||
|
+DRIVER=="tegra", SUBSYSTEM=="platform", TAG+="mutter-device-disable-atomic-kms"
|
||||||
|
diff --git a/src/backends/native/meta-kms-impl-device-atomic.c b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
index a4ffd70b6a..9fac299e14 100644
|
||||||
|
--- a/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
+++ b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
@@ -1306,6 +1306,7 @@ requires_hotspots (const char *driver_name)
|
||||||
|
"vboxvideo",
|
||||||
|
"virtio_gpu",
|
||||||
|
"vmwgfx",
|
||||||
|
+ "tegra",
|
||||||
|
NULL,
|
||||||
|
};
|
||||||
|
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
@ -0,0 +1,28 @@
|
|||||||
|
From cbe6fb86ce1e71c7360974a960db6bf79eb1ebde Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||||
|
Date: Fri, 2 Dec 2022 22:49:41 +0100
|
||||||
|
Subject: [PATCH] place: Always center initial-setup/fedora-welcome
|
||||||
|
|
||||||
|
---
|
||||||
|
src/core/place.c | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/core/place.c b/src/core/place.c
|
||||||
|
index 8a06ccb667..f34ae7f43d 100644
|
||||||
|
--- a/src/core/place.c
|
||||||
|
+++ b/src/core/place.c
|
||||||
|
@@ -377,6 +377,11 @@ window_place_centered (MetaWindow *window)
|
||||||
|
|
||||||
|
type = window->type;
|
||||||
|
|
||||||
|
+ if (g_strcmp0 (meta_window_get_wm_class (window), "org.gnome.InitialSetup") == 0 ||
|
||||||
|
+ g_strcmp0 (meta_window_get_wm_class (window), "org.fedoraproject.welcome-screen") == 0 ||
|
||||||
|
+ g_strcmp0 (meta_window_get_wm_class (window), "fedora-welcome") == 0)
|
||||||
|
+ return TRUE;
|
||||||
|
+
|
||||||
|
return (type == META_WINDOW_DIALOG ||
|
||||||
|
type == META_WINDOW_MODAL_DIALOG ||
|
||||||
|
type == META_WINDOW_SPLASHSCREEN ||
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
@ -0,0 +1,35 @@
|
|||||||
|
From 51e378c8f28b96b94c8da338b1b0f26cbc32c7f0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||||
|
Date: Fri, 12 May 2017 13:40:31 +0200
|
||||||
|
Subject: [PATCH] window-actor: Special-case shaped Java windows
|
||||||
|
|
||||||
|
OpenJDK wrongly assumes that shaping a window implies no shadows.
|
||||||
|
They got lucky until commit b975676c changed the fallback case,
|
||||||
|
but now their compliance tests are broken. Make them happy again
|
||||||
|
by special-casing shaped Java windows.
|
||||||
|
---
|
||||||
|
src/compositor/meta-window-actor-x11.c | 8 ++++++++
|
||||||
|
1 file changed, 8 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/compositor/meta-window-actor-x11.c b/src/compositor/meta-window-actor-x11.c
|
||||||
|
index 2781df09cc..8748f3aa3a 100644
|
||||||
|
--- a/src/compositor/meta-window-actor-x11.c
|
||||||
|
+++ b/src/compositor/meta-window-actor-x11.c
|
||||||
|
@@ -431,6 +431,14 @@ has_shadow (MetaWindowActorX11 *actor_x11)
|
||||||
|
if (priv->has_custom_frame_extents)
|
||||||
|
return FALSE;
|
||||||
|
|
||||||
|
+ /*
|
||||||
|
+ * OpenJDK wrongly assumes that shaping a window implies no compositor
|
||||||
|
+ * shadows; make its compliance tests happy to give it what it wants ...
|
||||||
|
+ */
|
||||||
|
+ if (g_strcmp0 (window->res_name, "sun-awt-X11-XWindowPeer") == 0 &&
|
||||||
|
+ priv->shape_region != NULL)
|
||||||
|
+ return FALSE;
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Generate shadows for all other windows.
|
||||||
|
*/
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
@ -0,0 +1,47 @@
|
|||||||
|
From 3a73958f7eab973189441ec9b4a4c96ee6bb8ec7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||||
|
Date: Mon, 22 Jul 2024 12:55:30 +0200
|
||||||
|
Subject: [PATCH 2/3] Revert "x11/window: Update comment and variable name to
|
||||||
|
reflect current behavior"
|
||||||
|
|
||||||
|
This reverts commit e4763d00e8512aeb408ae118597d753f12217487.
|
||||||
|
---
|
||||||
|
src/x11/window-x11.c | 15 ++++++++-------
|
||||||
|
1 file changed, 8 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/x11/window-x11.c b/src/x11/window-x11.c
|
||||||
|
index e7c76dd674..b358b64bf2 100644
|
||||||
|
--- a/src/x11/window-x11.c
|
||||||
|
+++ b/src/x11/window-x11.c
|
||||||
|
@@ -2491,20 +2491,21 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
|
||||||
|
if (region != NULL)
|
||||||
|
{
|
||||||
|
- MtkRectangle bounding_rect;
|
||||||
|
+ MtkRectangle client_area;
|
||||||
|
|
||||||
|
- bounding_rect.x = 0;
|
||||||
|
- bounding_rect.y = 0;
|
||||||
|
- bounding_rect.width = window->buffer_rect.width;
|
||||||
|
- bounding_rect.height = window->buffer_rect.height;
|
||||||
|
+ client_area.x = 0;
|
||||||
|
+ client_area.y = 0;
|
||||||
|
+ client_area.width = window->buffer_rect.width;
|
||||||
|
+ client_area.height = window->buffer_rect.height;
|
||||||
|
|
||||||
|
/* The shape we get back from the client may have coordinates
|
||||||
|
* outside of the frame. The X SHAPE Extension requires that
|
||||||
|
* the overall shape the client provides never exceeds the
|
||||||
|
* "bounding rectangle" of the window -- the shape that the
|
||||||
|
- * window would have gotten if it was unshaped.
|
||||||
|
+ * window would have gotten if it was unshaped. In our case,
|
||||||
|
+ * this is simply the client area.
|
||||||
|
*/
|
||||||
|
- mtk_region_intersect_rectangle (region, &bounding_rect);
|
||||||
|
+ mtk_region_intersect_rectangle (region, &client_area);
|
||||||
|
}
|
||||||
|
|
||||||
|
meta_window_set_input_region (window, region);
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
@ -0,0 +1,29 @@
|
|||||||
|
From 3e6ba58c875055037e45f651bbcf866d2d47d82f Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||||
|
Date: Mon, 22 Jul 2024 12:55:44 +0200
|
||||||
|
Subject: [PATCH 3/3] Revert "x11/window: Use correct bounding rect to
|
||||||
|
determine NULL input region"
|
||||||
|
|
||||||
|
This reverts commit 6bd920b355d12395dbf00b99374fc1f23783caaf.
|
||||||
|
---
|
||||||
|
src/x11/window-x11.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/x11/window-x11.c b/src/x11/window-x11.c
|
||||||
|
index b358b64bf2..16dc57eec2 100644
|
||||||
|
--- a/src/x11/window-x11.c
|
||||||
|
+++ b/src/x11/window-x11.c
|
||||||
|
@@ -2473,8 +2473,8 @@ meta_window_x11_update_input_region (MetaWindow *window)
|
||||||
|
else if (n_rects == 1 &&
|
||||||
|
(rects[0].x == 0 &&
|
||||||
|
rects[0].y == 0 &&
|
||||||
|
- rects[0].width == window->buffer_rect.width &&
|
||||||
|
- rects[0].height == window->buffer_rect.height))
|
||||||
|
+ rects[0].width == priv->client_rect.width &&
|
||||||
|
+ rects[0].height == priv->client_rect.height))
|
||||||
|
{
|
||||||
|
/* This is the bounding region case. Keep the
|
||||||
|
* region as NULL. */
|
||||||
|
--
|
||||||
|
2.44.0.501.g19981daefd.dirty
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue