Update to new release (#691171)
parent
8fe1c51e03
commit
96917942b1
@ -1 +1,2 @@
|
|||||||
/mupdf-0.7.tar.gz
|
/mupdf-0.7.tar.gz
|
||||||
|
/mupdf-0.8.15-source.tar.gz
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
--- a/Makefile 2011-01-13 23:10:08.911556954 +0300
|
|
||||||
+++ b/Makefile 2011-01-13 23:12:43.329510332 +0300
|
|
||||||
@@ -36,6 +36,7 @@
|
|
||||||
include Makerules
|
|
||||||
include Makethird
|
|
||||||
|
|
||||||
+CFLAGS ?=
|
|
||||||
CFLAGS += $(THIRD_INCS) $(SYS_FREETYPE_INC)
|
|
||||||
|
|
||||||
#
|
|
||||||
|
|
||||||
--- a/Makerules 2010-08-25 18:12:08.000000000 +0400
|
|
||||||
+++ b/Makerules 2011-01-13 23:31:10.535045464 +0300
|
|
||||||
@@ -4,7 +4,8 @@
|
|
||||||
OS := $(OS:MINGW%=MINGW)
|
|
||||||
|
|
||||||
CC ?= cc
|
|
||||||
-CFLAGS := -Ifitz -Imupdf -Wall
|
|
||||||
+CFLAGS ?=
|
|
||||||
+CFLAGS += -Ifitz -Imupdf -Wall
|
|
||||||
LDFLAGS :=
|
|
||||||
|
|
||||||
ifeq "$(build)" "debug"
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/Makefile 2011-02-06 00:31:40.957428001 +0300
|
|
||||||
+++ b/Makefile 2011-02-06 00:32:37.597428002 +0300
|
|
||||||
@@ -7,6 +7,7 @@
|
|
||||||
|
|
||||||
build ?= debug
|
|
||||||
prefix ?= /usr/local
|
|
||||||
+LIBDIR ?= $(prefix)/lib
|
|
||||||
|
|
||||||
OBJDIR := build/$(build)
|
|
||||||
GENDIR := build/generated
|
|
||||||
@@ -378,7 +379,7 @@
|
|
||||||
rm -rf build
|
|
||||||
|
|
||||||
install: $(OBJDIR) $(GENDIR) $(MUPDF_LIB) $(APPS)
|
|
||||||
- install -d $(prefix)/bin $(prefix)/lib $(prefix)/include
|
|
||||||
+ install -d $(prefix)/bin $(LIBDIR) $(prefix)/include
|
|
||||||
install $(APPS) $(prefix)/bin
|
|
||||||
- install $(MUPDF_LIB) $(prefix)/lib
|
|
||||||
+ install $(MUPDF_LIB) $(MUPDF_SO_LIB) $(LIBDIR)
|
|
||||||
install $(MUPDF_HDR) $(prefix)/include
|
|
Loading…
Reference in new issue