Update to 0.5.8-1

epel9
Daiki Ueno 11 years ago
parent dc473d9197
commit 9087936902

1
.gitignore vendored

@ -1 +1,2 @@
/msgpack-0.5.7.tar.gz /msgpack-0.5.7.tar.gz
/msgpack-0.5.8.tar.gz

@ -1,55 +0,0 @@
From b8aa93ce30d11d091b339bff0e10ddf3a8d08daf Mon Sep 17 00:00:00 2001
From: Hideyuki Tanaka <tanaka.hideyuki@gmail.com>
Date: Thu, 26 Jan 2012 16:38:27 +0900
Subject: [PATCH] fix decode on bigendian systems
---
msgpack/sysdep.h | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/src/msgpack/sysdep.h b/src/msgpack/sysdep.h
index 0a99de9..4fedbd8 100644
--- a/src/msgpack/sysdep.h
+++ b/src/msgpack/sysdep.h
@@ -153,24 +153,24 @@ typedef unsigned int _msgpack_atomic_counter_t;
#define _msgpack_be64(x) (x)
#define _msgpack_load16(cast, from) ((cast)( \
- (((uint16_t)((uint8_t*)from)[1]) << 8) | \
- (((uint16_t)((uint8_t*)from)[0]) ) ))
+ (((uint16_t)((uint8_t*)from)[0]) << 8) | \
+ (((uint16_t)((uint8_t*)from)[1]) ) ))
#define _msgpack_load32(cast, from) ((cast)( \
- (((uint32_t)((uint8_t*)from)[3]) << 24) | \
- (((uint32_t)((uint8_t*)from)[2]) << 16) | \
- (((uint32_t)((uint8_t*)from)[1]) << 8) | \
- (((uint32_t)((uint8_t*)from)[0]) ) ))
+ (((uint32_t)((uint8_t*)from)[0]) << 24) | \
+ (((uint32_t)((uint8_t*)from)[1]) << 16) | \
+ (((uint32_t)((uint8_t*)from)[2]) << 8) | \
+ (((uint32_t)((uint8_t*)from)[3]) ) ))
#define _msgpack_load64(cast, from) ((cast)( \
- (((uint64_t)((uint8_t*)from)[7]) << 56) | \
- (((uint64_t)((uint8_t*)from)[6]) << 48) | \
- (((uint64_t)((uint8_t*)from)[5]) << 40) | \
- (((uint64_t)((uint8_t*)from)[4]) << 32) | \
- (((uint64_t)((uint8_t*)from)[3]) << 24) | \
- (((uint64_t)((uint8_t*)from)[2]) << 16) | \
- (((uint64_t)((uint8_t*)from)[1]) << 8) | \
- (((uint64_t)((uint8_t*)from)[0]) ) ))
+ (((uint64_t)((uint8_t*)from)[0]) << 56) | \
+ (((uint64_t)((uint8_t*)from)[1]) << 48) | \
+ (((uint64_t)((uint8_t*)from)[2]) << 40) | \
+ (((uint64_t)((uint8_t*)from)[3]) << 32) | \
+ (((uint64_t)((uint8_t*)from)[4]) << 24) | \
+ (((uint64_t)((uint8_t*)from)[5]) << 16) | \
+ (((uint64_t)((uint8_t*)from)[6]) << 8) | \
+ (((uint64_t)((uint8_t*)from)[7]) ) ))
#endif
--
1.8.1.4

@ -1,12 +0,0 @@
diff -ru msgpack-0.5.7.orig/test/Makefile.am msgpack-0.5.7/test/Makefile.am
--- msgpack-0.5.7.orig/test/Makefile.am 2011-06-12 14:37:51.000000000 +0900
+++ msgpack-0.5.7/test/Makefile.am 2012-02-15 15:21:10.241665810 +0900
@@ -1,7 +1,7 @@
AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src
AM_C_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src
-AM_LDFLAGS = $(top_builddir)/src/libmsgpack.la -lgtest_main -pthread
+AM_LDFLAGS = $(top_builddir)/src/libmsgpack.la -lgtest_main -lgtest -pthread
check_PROGRAMS = \
zone \

@ -1,14 +1,12 @@
Name: msgpack Name: msgpack
Version: 0.5.7 Version: 0.5.8
Release: 5%{?dist} Release: 1%{?dist}
Summary: Binary-based efficient object serialization library Summary: Binary-based efficient object serialization library
Group: System Environment/Libraries Group: System Environment/Libraries
License: ASL 2.0 License: ASL 2.0
URL: http://msgpack.org URL: http://msgpack.org
Source0: http://msgpack.org/releases/cpp/%{name}-%{version}.tar.gz Source0: https://github.com/msgpack/msgpack-c/releases/download/cpp-%{version}/%{name}-%{version}.tar.gz
Patch0: msgpack-gtest-implicit-dso.patch
Patch1: msgpack-fix-decode-on-bigendian-systems.patch
# for regenerating configure # for regenerating configure
BuildRequires: libtool BuildRequires: libtool
@ -33,8 +31,6 @@ Libraries and header files for %{name}
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .gtest-implicit-dso
%patch1 -p1 -b .big-endian
%build %build
@ -64,9 +60,14 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' ';'
%files devel %files devel
%{_includedir}/* %{_includedir}/*
%{_libdir}/*.so %{_libdir}/*.so
%{_libdir}/pkgconfig/msgpack.pc
%changelog %changelog
* Thu Jan 9 2014 Daiki Ueno <dueno@redhat.com> - 0.5.8-1
- new upstream release
- remove patches that are no longer needed
* Tue Aug 27 2013 Dan Horák <dan[at]danny.cz> - 0.5.7-5 * Tue Aug 27 2013 Dan Horák <dan[at]danny.cz> - 0.5.7-5
- apply upstream fix for big endians - apply upstream fix for big endians

@ -1 +1 @@
705106a9378c792fe22d285dba5c142c msgpack-0.5.7.tar.gz ea0bee0939d2980c0df91f0e4843ccc4 msgpack-0.5.8.tar.gz

Loading…
Cancel
Save