* Thu Mar 28 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-6.20130329svn

- 20130329 snapshot
- Updated the nodvdcss patch
- Updated the ffmpeg patch
- Dropped em8300-devel BR since the package was retired in Fedora
el8
Julian Sikorski 12 years ago
parent 9ca6f9a3d2
commit f25f910960

2
.gitignore vendored

@ -1,2 +1,2 @@
Blue-1.8.tar.bz2
mplayer-export-2013-01-23.tar.bz2
mplayer-export-2013-03-29.tar.bz2

@ -1,7 +1,7 @@
diff -up mplayer-export-2013-01-23/configure.ffmpeg mplayer-export-2013-01-23/configure
--- mplayer-export-2013-01-23/configure.ffmpeg 2013-02-03 16:31:05.861615031 +0100
+++ mplayer-export-2013-01-23/configure 2013-02-03 16:31:05.871615111 +0100
@@ -6935,7 +6935,7 @@ elif test "$ffmpeg_so" = auto ; then
diff -up mplayer-export-2013-03-24/configure.ffmpeg mplayer-export-2013-03-24/configure
--- mplayer-export-2013-03-24/configure.ffmpeg 2013-03-23 08:28:55.993725707 +0100
+++ mplayer-export-2013-03-24/configure 2013-03-23 08:28:56.003725776 +0100
@@ -6973,7 +6973,7 @@ elif test "$ffmpeg_so" = auto ; then
inc_ffmpeg=$($_pkg_config --cflags libswscale libavformat libavcodec libavutil)
ld_tmp=$($_pkg_config --libs libswscale libavformat libavcodec libavutil)
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
@ -10,7 +10,7 @@ diff -up mplayer-export-2013-01-23/configure.ffmpeg mplayer-export-2013-01-23/co
elif header_check libavutil/avutil.h -lswscale -lavformat -lavcodec -lavutil ; then
extra_ldflags="$extra_ldflags -lswscale -lavformat -lavcodec -lavutil"
ffmpeg_so=yes
@@ -7644,7 +7644,7 @@ if test "$_gui" = yes ; then
@@ -7682,7 +7682,7 @@ if test "$_gui" = yes ; then
# Required libraries
if test "$ffmpeg" != yes ||
@ -19,9 +19,9 @@ diff -up mplayer-export-2013-01-23/configure.ffmpeg mplayer-export-2013-01-23/co
die "The GUI requires libavcodec with PNG support (needs zlib)."
fi
test "$_freetype" = no && test "$_bitmap_font" = no &&
diff -up mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h
--- mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h.ffmpeg 2013-02-03 16:31:05.872615119 +0100
+++ mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h 2013-02-03 16:31:05.872615119 +0100
diff -up mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h
--- mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h.ffmpeg 2013-03-23 08:28:56.004725783 +0100
+++ mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h 2013-03-23 08:28:56.004725783 +0100
@@ -0,0 +1,32 @@
+/*
+ * copyright (c) 2001 Fabrice Bellard
@ -55,9 +55,9 @@ diff -up mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h.ffmpeg mplayer-
+} AVCodecTag;
+
+#endif /* AVFORMAT_INTERNAL_H */
diff -up mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h
--- mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h.ffmpeg 2013-02-03 16:31:05.873615127 +0100
+++ mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h 2013-02-03 16:31:05.873615127 +0100
diff -up mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h
--- mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg 2013-03-23 08:28:56.005725790 +0100
+++ mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h 2013-03-23 08:28:56.005725790 +0100
@@ -0,0 +1,110 @@
+/*
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
@ -169,15 +169,15 @@ diff -up mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-exp
+#define MANGLE(a) EXTERN_PREFIX LOCAL_MANGLE(a)
+
+#endif /* AVUTIL_X86_ASM_H */
diff -up mplayer-export-2013-01-23/Makefile.ffmpeg mplayer-export-2013-01-23/Makefile
--- mplayer-export-2013-01-23/Makefile.ffmpeg 2013-02-03 16:31:05.862615039 +0100
+++ mplayer-export-2013-01-23/Makefile 2013-02-03 16:31:05.874615134 +0100
@@ -761,7 +761,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
$(CC) -o $@ $^ $(EXTRALIBS)
codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
- $(HOST_CC) -O -DCODECS2HTML -I. -Iffmpeg -o $@ $<
+ $(HOST_CC) -O -DCODECS2HTML -I. -Iffmpeg $(CFLAGS) -o $@ $<
diff -up mplayer-export-2013-03-24/Makefile.ffmpeg mplayer-export-2013-03-24/Makefile
--- mplayer-export-2013-03-24/Makefile.ffmpeg 2013-03-23 08:28:55.000000000 +0100
+++ mplayer-export-2013-03-24/Makefile 2013-03-23 08:29:01.000760529 +0100
@@ -773,7 +773,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
codec-cfg-test$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DTESTING
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
- $(HOST_CC) $(HOSTCFLAGS) -o $@ $<
+ $(HOST_CC) $(HOSTCFLAGS) $(CFLAGS)-o $@ $<
codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
./$^ > $@

@ -1,7 +1,7 @@
diff -up mplayer-export-2013-01-23/configure.nodvdcss mplayer-export-2013-01-23/configure
--- mplayer-export-2013-01-23/configure.nodvdcss 2013-02-02 10:03:58.000000000 +0100
+++ mplayer-export-2013-01-23/configure 2013-02-03 16:35:16.537604524 +0100
@@ -780,7 +780,7 @@ _dvdnavconfig=dvdnav-config
diff -up mplayer-export-2013-03-29/configure.nodvdcss mplayer-export-2013-03-29/configure
--- mplayer-export-2013-03-29/configure.nodvdcss 2013-03-28 08:45:33.000000000 +0100
+++ mplayer-export-2013-03-29/configure 2013-03-28 08:46:54.302523303 +0100
@@ -741,7 +741,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
@ -10,34 +10,34 @@ diff -up mplayer-export-2013-01-23/configure.nodvdcss mplayer-export-2013-01-23/
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2013-01-23/Makefile.nodvdcss mplayer-export-2013-01-23/Makefile
--- mplayer-export-2013-01-23/Makefile.nodvdcss 2013-02-03 16:35:16.533604493 +0100
+++ mplayer-export-2013-01-23/Makefile 2013-02-03 16:35:16.537604524 +0100
diff -up mplayer-export-2013-03-29/Makefile.nodvdcss mplayer-export-2013-03-29/Makefile
--- mplayer-export-2013-03-29/Makefile.nodvdcss 2013-03-28 08:46:54.300523311 +0100
+++ mplayer-export-2013-03-29/Makefile 2013-03-28 08:48:09.386242474 +0100
@@ -124,11 +124,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
libmpdemux/demux_rawdv.c
-SRCS_COMMON-$(LIBDVDCSS_INTERNAL) += libdvdcss/css.c \
- libdvdcss/device.c \
- libdvdcss/error.c \
- libdvdcss/ioctl.c \
- libdvdcss/libdvdcss.c \
-SRCS_COMMON-$(LIBDVDCSS_INTERNAL) += libdvdcss/css.c \
- libdvdcss/device.c \
- libdvdcss/error.c \
- libdvdcss/ioctl.c \
- libdvdcss/libdvdcss.c \
SRCS_COMMON-$(LIBMAD) += libmpcodecs/ad_libmad.c
@@ -720,7 +715,6 @@ DIRS = . \
@@ -730,7 +725,6 @@ DIRS = . \
ALL_DIRS = $(DIRS) \
libass \
- libdvdcss \
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -847,7 +841,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
ALL_DIRS = $(DIRS) \
libass \
- libdvdcss \
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -859,7 +853,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
gui/%: CFLAGS += -Wno-strict-prototypes
-libdvdcss/%: CFLAGS := -Ilibdvdcss -D_GNU_SOURCE -DVERSION=\"1.2.12\" $(CFLAGS_LIBDVDCSS) $(CFLAGS)
libdvdnav/%: CFLAGS := -Ilibdvdnav -D_GNU_SOURCE -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)
libdvdread4/%: CFLAGS := -Ilibdvdread4 -D_GNU_SOURCE $(CFLAGS_LIBDVDCSS_DVDREAD) $(CFLAGS)
-libdvdcss/%: CFLAGS := $(CFLAGS_LIBDVDCSS) $(CFLAGS)
libdvdnav/%: CFLAGS := -Ilibdvdnav -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)
libdvdread4/%: CFLAGS := -Ilibdvdread4 $(CFLAGS_LIBDVDCSS_DVDREAD) $(CFLAGS)

@ -13,7 +13,7 @@ cleanup() {
unset CDPATH
pwd=$(pwd)
svn=$(date +%Y-%m-%d)
svn=2013-01-23
svn=2013-03-29
dirname=mplayer-export-$svn
mplayer_rev={$svn}
#mplayer_rev=HEAD

@ -1,12 +1,12 @@
%define codecdir %{_libdir}/codecs
%define pre 20130123svn
%define pre 20130329svn
%define svn 1
%define svnbuild 2013-01-23
%define svnbuild 2013-03-29
%define faad2min 1:2.6.1
Name: mplayer
Version: 1.1
Release: 5.%{?pre}%{?dist}
Release: 6.%{?pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
%if 0%{!?_without_amr:1}
@ -38,7 +38,6 @@ BuildRequires: aalib-devel
BuildRequires: bzip2-devel
BuildRequires: alsa-lib-devel
BuildRequires: desktop-file-utils
BuildRequires: em8300-devel
BuildRequires: enca-devel
BuildRequires: faad2-devel >= %{faad2min}
BuildRequires: ffmpeg-devel >= 0.10
@ -381,6 +380,12 @@ update-desktop-database &>/dev/null || :
%{_datadir}/mplayer/*.fp
%changelog
* Thu Mar 28 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-6.20130329svn
- 20130329 snapshot
- Updated the nodvdcss patch
- Updated the ffmpeg patch
- Dropped em8300-devel BR since the package was retired in Fedora
* Sun Feb 03 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-5.20130123svn
- 20130123 snapshot
- Updated the nodvdcss patch

@ -1,2 +1,2 @@
340368f4e33f767d9df109990fb29c02 Blue-1.8.tar.bz2
0d068b037182c3bba25f048d33274607 mplayer-export-2013-01-23.tar.bz2
06c3dcdb5df5715871f1798698f422c4 mplayer-export-2013-03-29.tar.bz2

Loading…
Cancel
Save