* Sun Feb 03 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-5.20130123svn

- 20130123 snapshot
- Updated the nodvdcss patch
- Updated the ffmpeg patch
el8
Julian Sikorski 12 years ago
parent f44d4919f4
commit 9ca6f9a3d2

2
.gitignore vendored

@ -1,2 +1,2 @@
Blue-1.8.tar.bz2
mplayer-export-2013-01-30.tar.bz2
mplayer-export-2013-01-23.tar.bz2

@ -1,7 +1,7 @@
diff -up MPlayer-1.1/configure.ffmpeg MPlayer-1.1/configure
--- MPlayer-1.1/configure.ffmpeg 2012-06-12 19:54:45.573647100 +0200
+++ MPlayer-1.1/configure 2012-06-12 19:55:00.444732663 +0200
@@ -6755,7 +6755,7 @@ elif test "$ffmpeg_so" = auto ; then
diff -up mplayer-export-2013-01-23/configure.ffmpeg mplayer-export-2013-01-23/configure
--- mplayer-export-2013-01-23/configure.ffmpeg 2013-02-03 16:31:05.861615031 +0100
+++ mplayer-export-2013-01-23/configure 2013-02-03 16:31:05.871615111 +0100
@@ -6935,7 +6935,7 @@ elif test "$ffmpeg_so" = auto ; then
inc_ffmpeg=$($_pkg_config --cflags libswscale libavformat libavcodec libavutil)
ld_tmp=$($_pkg_config --libs libswscale libavformat libavcodec libavutil)
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
@ -10,7 +10,7 @@ diff -up MPlayer-1.1/configure.ffmpeg MPlayer-1.1/configure
elif header_check libavutil/avutil.h -lswscale -lavformat -lavcodec -lavutil ; then
extra_ldflags="$extra_ldflags -lswscale -lavformat -lavcodec -lavutil"
ffmpeg_so=yes
@@ -7464,7 +7464,7 @@ if test "$_gui" = yes ; then
@@ -7644,7 +7644,7 @@ if test "$_gui" = yes ; then
# Required libraries
if test "$ffmpeg" != yes ||
@ -19,9 +19,9 @@ diff -up MPlayer-1.1/configure.ffmpeg MPlayer-1.1/configure
die "The GUI requires libavcodec with PNG support (needs zlib)."
fi
test "$_freetype" = no && test "$_bitmap_font" = no &&
diff -up MPlayer-1.1/ffmpeg/libavformat/internal.h.ffmpeg MPlayer-1.1/ffmpeg/libavformat/internal.h
--- MPlayer-1.1/ffmpeg/libavformat/internal.h.ffmpeg 2012-06-12 19:54:45.578647128 +0200
+++ MPlayer-1.1/ffmpeg/libavformat/internal.h 2012-06-12 19:54:45.578647128 +0200
diff -up mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h
--- mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h.ffmpeg 2013-02-03 16:31:05.872615119 +0100
+++ mplayer-export-2013-01-23/ffmpeg/libavformat/internal.h 2013-02-03 16:31:05.872615119 +0100
@@ -0,0 +1,32 @@
+/*
+ * copyright (c) 2001 Fabrice Bellard
@ -55,10 +55,10 @@ diff -up MPlayer-1.1/ffmpeg/libavformat/internal.h.ffmpeg MPlayer-1.1/ffmpeg/lib
+} AVCodecTag;
+
+#endif /* AVFORMAT_INTERNAL_H */
diff -up MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h
--- MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2012-06-12 19:54:45.615647342 +0200
+++ MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h 2012-06-12 19:54:45.615647342 +0200
@@ -0,0 +1,98 @@
diff -up mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h
--- mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h.ffmpeg 2013-02-03 16:31:05.873615127 +0100
+++ mplayer-export-2013-01-23/ffmpeg/libavutil/x86/asm.h 2013-02-03 16:31:05.873615127 +0100
@@ -0,0 +1,110 @@
+/*
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
+ *
@ -79,8 +79,8 @@ diff -up MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg MPlayer-1.1/ffmpeg/libavu
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#ifndef AVUTIL_X86_CPU_H
+#define AVUTIL_X86_CPU_H
+#ifndef AVUTIL_X86_ASM_H
+#define AVUTIL_X86_ASM_H
+
+#include <stdint.h>
+#include "config.h"
@ -156,11 +156,23 @@ diff -up MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg MPlayer-1.1/ffmpeg/libavu
+# define XMM_CLOBBERS_ONLY(...)
+#endif
+
+#endif /* AVUTIL_X86_CPU_H */
diff -up MPlayer-1.1/Makefile.ffmpeg MPlayer-1.1/Makefile
--- MPlayer-1.1/Makefile.ffmpeg 2012-06-12 19:54:45.573647100 +0200
+++ MPlayer-1.1/Makefile 2012-06-12 19:54:45.616647347 +0200
@@ -788,7 +788,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
+/* Use to export labels from asm. */
+#define LABEL_MANGLE(a) EXTERN_PREFIX #a
+
+// Use rip-relative addressing if compiling PIC code on x86-64.
+#if ARCH_X86_64 && defined(PIC)
+# define LOCAL_MANGLE(a) #a "(%%rip)"
+#else
+# define LOCAL_MANGLE(a) #a
+#endif
+
+#define MANGLE(a) EXTERN_PREFIX LOCAL_MANGLE(a)
+
+#endif /* AVUTIL_X86_ASM_H */
diff -up mplayer-export-2013-01-23/Makefile.ffmpeg mplayer-export-2013-01-23/Makefile
--- mplayer-export-2013-01-23/Makefile.ffmpeg 2013-02-03 16:31:05.862615039 +0100
+++ mplayer-export-2013-01-23/Makefile 2013-02-03 16:31:05.874615134 +0100
@@ -761,7 +761,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
$(CC) -o $@ $^ $(EXTRALIBS)
codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h

@ -1,7 +1,7 @@
diff -up mplayer-export-2011-08-16/configure.nodvdcss mplayer-export-2011-08-16/configure
--- mplayer-export-2011-08-16/configure.nodvdcss 2011-08-11 19:45:43.000000000 +0200
+++ mplayer-export-2011-08-16/configure 2011-08-16 21:53:23.000000000 +0200
@@ -731,7 +731,7 @@ _dvdnavconfig=dvdnav-config
diff -up mplayer-export-2013-01-23/configure.nodvdcss mplayer-export-2013-01-23/configure
--- mplayer-export-2013-01-23/configure.nodvdcss 2013-02-02 10:03:58.000000000 +0100
+++ mplayer-export-2013-01-23/configure 2013-02-03 16:35:16.537604524 +0100
@@ -780,7 +780,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
@ -10,10 +10,10 @@ diff -up mplayer-export-2011-08-16/configure.nodvdcss mplayer-export-2011-08-16/
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2011-08-16/Makefile.nodvdcss mplayer-export-2011-08-16/Makefile
--- mplayer-export-2011-08-16/Makefile.nodvdcss 2011-08-16 21:53:23.000000000 +0200
+++ mplayer-export-2011-08-16/Makefile 2011-08-16 21:53:55.000000000 +0200
@@ -112,11 +112,6 @@ SRCS_COMMON-$(LIBDCA) +=
diff -up mplayer-export-2013-01-23/Makefile.nodvdcss mplayer-export-2013-01-23/Makefile
--- mplayer-export-2013-01-23/Makefile.nodvdcss 2013-02-03 16:35:16.533604493 +0100
+++ mplayer-export-2013-01-23/Makefile 2013-02-03 16:35:16.537604524 +0100
@@ -124,11 +124,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
libmpdemux/demux_rawdv.c
@ -25,7 +25,7 @@ diff -up mplayer-export-2011-08-16/Makefile.nodvdcss mplayer-export-2011-08-16/M
SRCS_COMMON-$(LIBMAD) += libmpcodecs/ad_libmad.c
@@ -741,7 +736,6 @@ DIRS = . \
@@ -720,7 +715,6 @@ DIRS = . \
ALL_DIRS = $(DIRS) \
libass \
@ -33,11 +33,11 @@ diff -up mplayer-export-2011-08-16/Makefile.nodvdcss mplayer-export-2011-08-16/M
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -830,7 +824,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
@@ -847,7 +841,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
gui/%: CFLAGS += -Wno-strict-prototypes
-libdvdcss/%: CFLAGS := -Ilibdvdcss -D_GNU_SOURCE -DVERSION=\"1.2.10\" $(CFLAGS_LIBDVDCSS) $(CFLAGS)
-libdvdcss/%: CFLAGS := -Ilibdvdcss -D_GNU_SOURCE -DVERSION=\"1.2.12\" $(CFLAGS_LIBDVDCSS) $(CFLAGS)
libdvdnav/%: CFLAGS := -Ilibdvdnav -D_GNU_SOURCE -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)
libdvdread4/%: CFLAGS := -Ilibdvdread4 -D_GNU_SOURCE $(CFLAGS_LIBDVDCSS_DVDREAD) $(CFLAGS)

@ -13,7 +13,7 @@ cleanup() {
unset CDPATH
pwd=$(pwd)
svn=$(date +%Y-%m-%d)
svn=2013-01-30
svn=2013-01-23
dirname=mplayer-export-$svn
mplayer_rev={$svn}
#mplayer_rev=HEAD

@ -1,7 +1,7 @@
%define codecdir %{_libdir}/codecs
%define pre 20130130svn
%define pre 20130123svn
%define svn 1
%define svnbuild 2013-01-30
%define svnbuild 2013-01-23
%define faad2min 1:2.6.1
Name: mplayer
@ -381,8 +381,10 @@ update-desktop-database &>/dev/null || :
%{_datadir}/mplayer/*.fp
%changelog
* Wed Jan 30 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-5.20130130svn
- 20130130 snapshot
* Sun Feb 03 2013 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-5.20130123svn
- 20130123 snapshot
- Updated the nodvdcss patch
- Updated the ffmpeg patch
* Fri Nov 23 2012 Nicolas Chauvet <kwizart@gmail.com> - 1.1-4.20121008svn
- Rebuilt for x264

@ -1,2 +1,2 @@
340368f4e33f767d9df109990fb29c02 Blue-1.8.tar.bz2
f0c122df73f456479c29b38b0fc0ae15 mplayer-export-2013-01-30.tar.bz2
0d068b037182c3bba25f048d33274607 mplayer-export-2013-01-23.tar.bz2

Loading…
Cancel
Save