Rebuild for ffmpeg-3.4.5 on el7

el8
sagitter 6 years ago
commit 22db9a3aec

7
.gitignore vendored

@ -1,2 +1,5 @@
Blue-1.10.tar.bz2 Blue-1.11.tar.bz2
mplayer-export-2014-04-14.tar.bz2 MPlayer-1.3.0.tar.xz
/mplayer-export-2018-01-19.tar.bz2
/mplayer-export-2018-04-24.tar.bz2
/mplayer-export-2018-06-20.tar.bz2

@ -1,7 +1,7 @@
diff -up mplayer-export-2014-03-27/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2014-03-27/ffmpeg/libavformat/internal.h diff -up mplayer-export-2015-05-05/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2015-05-05/ffmpeg/libavformat/internal.h
--- mplayer-export-2014-03-27/ffmpeg/libavformat/internal.h.ffmpeg 2014-03-27 07:31:02.816463722 +0100 --- mplayer-export-2015-05-05/ffmpeg/libavformat/internal.h.ffmpeg 2015-05-06 07:22:42.640716026 +0200
+++ mplayer-export-2014-03-27/ffmpeg/libavformat/internal.h 2014-03-27 07:31:02.816463722 +0100 +++ mplayer-export-2015-05-05/ffmpeg/libavformat/internal.h 2015-05-06 07:26:44.614138993 +0200
@@ -0,0 +1,32 @@ @@ -0,0 +1,84 @@
+/* +/*
+ * copyright (c) 2001 Fabrice Bellard + * copyright (c) 2001 Fabrice Bellard
+ * + *
@ -33,127 +33,63 @@ diff -up mplayer-export-2014-03-27/ffmpeg/libavformat/internal.h.ffmpeg mplayer-
+ unsigned int tag; + unsigned int tag;
+} AVCodecTag; +} AVCodecTag;
+ +
+#endif /* AVFORMAT_INTERNAL_H */ +struct AVFormatInternal {
diff -up mplayer-export-2014-03-27/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2014-03-27/ffmpeg/libavutil/x86/asm.h + /**
--- mplayer-export-2014-03-27/ffmpeg/libavutil/x86/asm.h.ffmpeg 2014-03-27 07:31:02.816463722 +0100 + * Number of streams relevant for interleaving.
+++ mplayer-export-2014-03-27/ffmpeg/libavutil/x86/asm.h 2014-03-27 07:31:02.816463722 +0100 + * Muxing only.
@@ -0,0 +1,112 @@ + */
+/* + int nb_interleaved_streams;
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at> +
+ * + /**
+ * This file is part of FFmpeg. + * This buffer is only needed when packets were already buffered but
+ * + * not decoded, for example to get the codec parameters in MPEG
+ * FFmpeg is free software; you can redistribute it and/or + * streams.
+ * modify it under the terms of the GNU Lesser General Public + */
+ * License as published by the Free Software Foundation; either + struct AVPacketList *packet_buffer;
+ * version 2.1 of the License, or (at your option) any later version. + struct AVPacketList *packet_buffer_end;
+ * +
+ * FFmpeg is distributed in the hope that it will be useful, + /* av_seek_frame() support */
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of + int64_t data_offset; /**< offset of the first packet */
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU +
+ * Lesser General Public License for more details. + /**
+ * + * Raw packets from the demuxer, prior to parsing and decoding.
+ * You should have received a copy of the GNU Lesser General Public + * This buffer is used for buffering packets until the codec can
+ * License along with FFmpeg; if not, write to the Free Software + * be identified, as parsing cannot be done without knowing the
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA + * codec.
+ */ + */
+ struct AVPacketList *raw_packet_buffer;
+ struct AVPacketList *raw_packet_buffer_end;
+ /**
+ * Packets split by the parser get queued here.
+ */
+ struct AVPacketList *parse_queue;
+ struct AVPacketList *parse_queue_end;
+ /**
+ * Remaining size available for raw_packet_buffer, in bytes.
+ */
+#define RAW_PACKET_BUFFER_SIZE 2500000
+ int raw_packet_buffer_remaining_size;
+
+ /**
+ * Offset to remap timestamps to be non-negative.
+ * Expressed in timebase units.
+ * @see AVStream.mux_ts_offset
+ */
+ int64_t offset;
+
+ /**
+ * Timebase for the timestamp offset.
+ */
+ AVRational offset_timebase;
+
+ int inject_global_side_data;
+};
+ +
+#ifndef AVUTIL_X86_ASM_H +#endif /* AVFORMAT_INTERNAL_H */
+#define AVUTIL_X86_ASM_H diff -up mplayer-export-2015-05-05/Makefile.ffmpeg mplayer-export-2015-05-05/Makefile
+ --- mplayer-export-2015-05-05/Makefile.ffmpeg 2015-05-06 07:22:42.638716016 +0200
+#include <stdint.h> +++ mplayer-export-2015-05-05/Makefile 2015-05-06 07:22:42.642716037 +0200
+#include "config.h" @@ -754,7 +754,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
+
+typedef struct xmm_reg { uint64_t a, b; } xmm_reg;
+
+#if ARCH_X86_64
+# define OPSIZE "q"
+# define REG_a "rax"
+# define REG_b "rbx"
+# define REG_c "rcx"
+# define REG_d "rdx"
+# define REG_D "rdi"
+# define REG_S "rsi"
+# define PTR_SIZE "8"
+typedef int64_t x86_reg;
+
+# define REG_SP "rsp"
+# define REG_BP "rbp"
+# define REGBP rbp
+# define REGa rax
+# define REGb rbx
+# define REGc rcx
+# define REGd rdx
+# define REGSP rsp
+
+#elif ARCH_X86_32
+
+# define OPSIZE "l"
+# define REG_a "eax"
+# define REG_b "ebx"
+# define REG_c "ecx"
+# define REG_d "edx"
+# define REG_D "edi"
+# define REG_S "esi"
+# define PTR_SIZE "4"
+typedef int32_t x86_reg;
+
+# define REG_SP "esp"
+# define REG_BP "ebp"
+# define REGBP ebp
+# define REGa eax
+# define REGb ebx
+# define REGc ecx
+# define REGd edx
+# define REGSP esp
+#else
+typedef int x86_reg;
+#endif
+
+#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE))
+#define HAVE_6REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE || HAVE_EBP_AVAILABLE))
+
+#if ARCH_X86_64 && defined(PIC)
+# define BROKEN_RELOCATIONS 1
+#endif
+
+/*
+ * If gcc is not set to support sse (-msse) it will not accept xmm registers
+ * in the clobber list for inline asm. XMM_CLOBBERS takes a list of xmm
+ * registers to be marked as clobbered and evaluates to nothing if they are
+ * not supported, or to the list itself if they are supported. Since a clobber
+ * list may not be empty, XMM_CLOBBERS_ONLY should be used if the xmm
+ * registers are the only in the clobber list.
+ * For example a list with "eax" and "xmm0" as clobbers should become:
+ * : XMM_CLOBBERS("xmm0",) "eax"
+ * and a list with only "xmm0" should become:
+ * XMM_CLOBBERS_ONLY("xmm0")
+ */
+#if HAVE_XMM_CLOBBERS
+# define XMM_CLOBBERS(...) __VA_ARGS__
+# define XMM_CLOBBERS_ONLY(...) : __VA_ARGS__
+#else
+# define XMM_CLOBBERS(...)
+# define XMM_CLOBBERS_ONLY(...)
+#endif
+
+/* Use to export labels from asm. */
+#define LABEL_MANGLE(a) EXTERN_PREFIX #a
+
+// Use rip-relative addressing if compiling PIC code on x86-64.
+#if ARCH_X86_64 && defined(PIC)
+# define LOCAL_MANGLE(a) #a "(%%rip)"
+#else
+# define LOCAL_MANGLE(a) #a
+#endif
+
+#define MANGLE(a) EXTERN_PREFIX LOCAL_MANGLE(a)
+
+#endif /* AVUTIL_X86_ASM_H */
diff -up mplayer-export-2014-03-27/Makefile.ffmpeg mplayer-export-2014-03-27/Makefile
--- mplayer-export-2014-03-27/Makefile.ffmpeg 2014-03-27 07:31:02.814463712 +0100
+++ mplayer-export-2014-03-27/Makefile 2014-03-27 07:31:02.816463722 +0100
@@ -776,7 +776,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
codec-cfg-test$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DTESTING codec-cfg-test$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DTESTING
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
@ -162,15 +98,3 @@ diff -up mplayer-export-2014-03-27/Makefile.ffmpeg mplayer-export-2014-03-27/Mak
codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
./$^ > $@ ./$^ > $@
diff --git a/libmpcodecs/ad_spdif.c b/libmpcodecs/ad_spdif.c
index 542c3ff..ef3b960 100644
--- a/libmpcodecs/ad_spdif.c
+++ b/libmpcodecs/ad_spdif.c
@@ -130,7 +129,6 @@ static int init(sh_audio_t *sh)
break;
}
}
- lavf_ctx->raw_packet_buffer_remaining_size = RAW_PACKET_BUFFER_SIZE;
if (AVERROR_PATCHWELCOME == lavf_ctx->oformat->write_header(lavf_ctx)) {
mp_msg(MSGT_DECAUDIO,MSGL_INFO,
"This codec is not supported by spdifenc.\n");

@ -1,43 +0,0 @@
diff -up mplayer-export-2013-03-29/configure.nodvdcss mplayer-export-2013-03-29/configure
--- mplayer-export-2013-03-29/configure.nodvdcss 2013-03-28 08:45:33.000000000 +0100
+++ mplayer-export-2013-03-29/configure 2013-03-28 08:46:54.302523303 +0100
@@ -741,7 +741,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
-_libdvdcss_internal=auto
+_libdvdcss_internal=no
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2013-03-29/Makefile.nodvdcss mplayer-export-2013-03-29/Makefile
--- mplayer-export-2013-03-29/Makefile.nodvdcss 2013-03-28 08:46:54.300523311 +0100
+++ mplayer-export-2013-03-29/Makefile 2013-03-28 08:48:09.386242474 +0100
@@ -124,11 +124,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
libmpdemux/demux_rawdv.c
-SRCS_COMMON-$(LIBDVDCSS_INTERNAL) += libdvdcss/css.c \
- libdvdcss/device.c \
- libdvdcss/error.c \
- libdvdcss/ioctl.c \
- libdvdcss/libdvdcss.c \
SRCS_COMMON-$(LIBMAD) += libmpcodecs/ad_libmad.c
@@ -730,7 +725,6 @@ DIRS = . \
ALL_DIRS = $(DIRS) \
libass \
- libdvdcss \
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -859,7 +853,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
gui/%: CFLAGS += -Wno-strict-prototypes
-libdvdcss/%: CFLAGS := $(CFLAGS_LIBDVDCSS) $(CFLAGS)
libdvdnav/%: CFLAGS := -Ilibdvdnav -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)
libdvdread4/%: CFLAGS := -Ilibdvdread4 $(CFLAGS_LIBDVDCSS_DVDREAD) $(CFLAGS)

@ -13,17 +13,15 @@ cleanup() {
unset CDPATH unset CDPATH
pwd=$(pwd) pwd=$(pwd)
svn=$(date +%Y-%m-%d) svn=$(date +%Y-%m-%d)
svn=2014-04-14 svn=2018-06-20
dirname=mplayer-export-$svn dirname=mplayer-export-$svn
mplayer_rev={$svn} mplayer_rev={$svn}
#mplayer_rev=HEAD #mplayer_rev=HEAD
cd "$tmp" cd "$tmp"
svn checkout --ignore-externals -r ${mplayer_rev} svn://svn.mplayerhq.hu/mplayer/trunk $dirname svn checkout -r ${mplayer_rev} svn://svn.mplayerhq.hu/mplayer/trunk $dirname
cd $dirname cd $dirname
rm -rf libdvdcss libswscale
svn_revision=`LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2` svn_revision=`LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2`
sed -i -e 's/\(SVN-r[0-9]* \)/\1rpmfusion /' -e "s/UNKNOWN/SVN-r$svn_revision/" version.sh sed -i -e 's/\(SVN-r[0-9]* \)/\1rpmfusion /' -e "s/UNKNOWN/SVN-r$svn_revision/" version.sh
find . -type d -name .svn -print0 | xargs -0r rm -rf find . -type d -name .svn -print0 | xargs -0r rm -rf

@ -1,12 +1,16 @@
%define codecdir %{_libdir}/codecs %define codecdir %{_libdir}/codecs
%define pre 20140414svn %define pre 20180620svn
%define svn 1 %define svn 1
%define svnbuild 2014-04-14 %define svnbuild 2018-06-20
%define faad2min 1:2.6.1 %define faad2min 1:2.6.1
Name: mplayer Name: mplayer
Version: 1.1 Version: 1.3.0
Release: 23.%{?pre}%{?dist} %if 0%{?svn}
Release: 27.%{?pre}%{?dist}
%else
Release: 27%{?dist}
%endif
Summary: Movie player playing most video formats and DVDs Summary: Movie player playing most video formats and DVDs
%if 0%{!?_without_amr:1} %if 0%{!?_without_amr:1}
@ -21,22 +25,21 @@ Source0: mplayer-export-%{svnbuild}.tar.bz2
%else %else
Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{?pre}.tar.xz Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{?pre}.tar.xz
%endif %endif
Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.10.tar.bz2 Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
Source10: mplayer-snapshot.sh Source10: mplayer-snapshot.sh
# set defaults for Fedora # set defaults for Fedora
Patch0: %{name}-config.patch Patch0: %{name}-config.patch
# use roff include statements instead of symlinks # use roff include statements instead of symlinks
Patch1: %{name}-manlinks.patch Patch1: %{name}-manlinks.patch
# erase any trace of libdvdcss
Patch2: %{name}-nodvdcss.patch
# use system FFmpeg libraries # use system FFmpeg libraries
Patch3: %{name}-ffmpeg.patch Patch3: %{name}-ffmpeg.patch
BuildRequires: SDL-devel BuildRequires: SDL-devel
BuildRequires: a52dec-devel BuildRequires: a52dec-devel
BuildRequires: aalib-devel BuildRequires: aalib-devel
BuildRequires: bzip2-devel
BuildRequires: alsa-lib-devel BuildRequires: alsa-lib-devel
BuildRequires: bzip2-devel
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
BuildRequires: enca-devel BuildRequires: enca-devel
BuildRequires: faad2-devel >= %{faad2min} BuildRequires: faad2-devel >= %{faad2min}
@ -44,6 +47,7 @@ BuildRequires: ffmpeg-devel >= 0.10
BuildRequires: fontconfig-devel BuildRequires: fontconfig-devel
BuildRequires: freetype-devel >= 2.0.9 BuildRequires: freetype-devel >= 2.0.9
BuildRequires: fribidi-devel BuildRequires: fribidi-devel
BuildRequires: gcc-c++
BuildRequires: giflib-devel BuildRequires: giflib-devel
BuildRequires: gsm-devel BuildRequires: gsm-devel
BuildRequires: gtk2-devel BuildRequires: gtk2-devel
@ -59,7 +63,7 @@ BuildRequires: libass-devel >= 0.9.10
BuildRequires: libbluray-devel BuildRequires: libbluray-devel
BuildRequires: libbs2b-devel BuildRequires: libbs2b-devel
BuildRequires: libcaca-devel BuildRequires: libcaca-devel
BuildRequires: libcdio-devel BuildRequires: libcdio-paranoia-devel
BuildRequires: libdca-devel BuildRequires: libdca-devel
BuildRequires: libdv-devel BuildRequires: libdv-devel
BuildRequires: libdvdnav-devel >= 4.1.3-1 BuildRequires: libdvdnav-devel >= 4.1.3-1
@ -73,6 +77,7 @@ BuildRequires: libvorbis-devel
BuildRequires: lirc-devel BuildRequires: lirc-devel
#BuildRequires: live555-devel #broken - see libnemesi as an alternative #BuildRequires: live555-devel #broken - see libnemesi as an alternative
BuildRequires: lzo-devel >= 2 BuildRequires: lzo-devel >= 2
BuildRequires: perl-generators
BuildRequires: pulseaudio-libs-devel BuildRequires: pulseaudio-libs-devel
BuildRequires: speex-devel >= 1.1 BuildRequires: speex-devel >= 1.1
BuildRequires: twolame-devel BuildRequires: twolame-devel
@ -100,8 +105,9 @@ BuildRequires: libxml2
BuildRequires: libxslt BuildRequires: libxslt
%endif %endif
Obsoletes: mplayer-fonts Obsoletes: mplayer-fonts
Requires: faad2-libs >= %{faad2min} Requires: faad2-libs%{?_isa} >= %{faad2min}
Requires: mplayer-common = %{version}-%{release} Requires: mplayer-common = %{version}-%{release}
Provides: mplayer-backend
%description %description
MPlayer is a movie player that plays most MPEG, VOB, AVI, OGG/OGM, MPlayer is a movie player that plays most MPEG, VOB, AVI, OGG/OGM,
@ -155,8 +161,8 @@ MPlayer documentation in various languages.
%package tools %package tools
Summary: Useful scripts for MPlayer Summary: Useful scripts for MPlayer
Requires: mencoder = %{version}-%{release} Requires: mencoder%{?_isa} = %{version}-%{release}
Requires: mplayer = %{version}-%{release} Requires: mplayer%{?_isa} = %{version}-%{release}
%description tools %description tools
This package contains various scripts from MPlayer TOOLS directory. This package contains various scripts from MPlayer TOOLS directory.
@ -184,8 +190,6 @@ This package contains various scripts from MPlayer TOOLS directory.
%endif \ %endif \
--enable-unrarexec \\\ --enable-unrarexec \\\
\\\ \\\
--disable-dvdread-internal \\\
--disable-libdvdcss-internal \\\
%{!?_with_nemesi:--disable-nemesi} \\\ %{!?_with_nemesi:--disable-nemesi} \\\
%{!?_with_samba:--disable-smb} \\\ %{!?_with_samba:--disable-smb} \\\
\\\ \\\
@ -219,11 +223,10 @@ This package contains various scripts from MPlayer TOOLS directory.
%setup -q -n mplayer-export-%{svnbuild} %setup -q -n mplayer-export-%{svnbuild}
%else %else
%setup -q -n MPlayer-%{version}%{?pre} %setup -q -n MPlayer-%{version}%{?pre}
rm -rf ffmpeg libdvdcss libdvdnav libdvdread4 rm -rf ffmpeg
%endif %endif
%patch0 -p1 -b .config %patch0 -p1 -b .config
%patch1 -p1 -b .manlinks %patch1 -p1 -b .manlinks
%patch2 -p1 -b .nodvdcss
%patch3 -p1 -b .ffmpeg %patch3 -p1 -b .ffmpeg
mkdir GUI mkdir GUI
@ -231,24 +234,28 @@ cp -a `ls -1|grep -v GUI` GUI/
%build %build
pushd GUI pushd GUI
export CC=gcc
export CXX=g++
%{mp_configure}--enable-gui --disable-mencoder %{mp_configure}--enable-gui --disable-mencoder
%{__make} V=1 %{?_smp_mflags} %make_build V=1
popd popd
export CC=gcc
export CXX=g++
%{mp_configure} %{mp_configure}
%{__make} V=1 %{?_smp_mflags} %make_build V=1
%if 0%{?svn} %if 0%{?svn}
# build HTML documentation from XML files # build HTML documentation from XML files
%{__make} html-chunked %make_build V=1 html-chunked
%endif %endif
%install %install
rm -rf $RPM_BUILD_ROOT doc rm -rf $RPM_BUILD_ROOT doc
make install DESTDIR=$RPM_BUILD_ROOT INSTALLSTRIP= %make_install INSTALLSTRIP=
for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh` install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
done done
@ -301,17 +308,21 @@ desktop-file-install \
# Codec dir # Codec dir
install -dm 755 $RPM_BUILD_ROOT%{codecdir} install -dm 755 $RPM_BUILD_ROOT%{codecdir}
sed -i '1s:#!/usr/bin/env python:#!/usr/bin/env python2:' %{buildroot}%{_bindir}/vobshift
%if 0%{?rhel}
%post
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
%post gui %postun
gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null || : if [ $1 -eq 0 ] ; then
update-desktop-database &>/dev/null || : /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi
%postun gui
gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null || :
update-desktop-database &>/dev/null || :
%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%files %files
%{_bindir}/mplayer %{_bindir}/mplayer
@ -380,15 +391,149 @@ update-desktop-database &>/dev/null || :
%{_datadir}/mplayer/*.fp %{_datadir}/mplayer/*.fp
%changelog %changelog
* Thu Jan 12 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.1-23.20140414svn * Mon Nov 12 2018 Antonio Trande <sagitter@fedoraproject.org> - 1.3.0-27.20180620svn
- Patch for ffmpeg-2.8 - Rebuild for ffmpeg-3.4.5 on el7
- Rebuild for x264-0.148 on el7
- Add icon-cache scriptlets for epel only
* Thu Oct 04 2018 Sérgio Basto <sergio@serjux.com> - 1.3.0-26.20180620svn
- Mass rebuild for x264 and/or x265
- Fix sources
- Add BuildRequires: gcc-c++
- Fix ambiguous python shebang
* Fri Jul 27 2018 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.3.0-25.20180620svn
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Jun 20 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-24.20180620svn
- Update to latest svn
- Enable runtime cpu detection for i686 again
* Sun Jun 17 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-23.20180424svn
- Rebuild for new libass version
* Tue Apr 24 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-22.20180424svn
- Update to latest svn
* Tue Apr 24 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-21.20180119svn
- Rebuild for ffmpeg-4.0 release
* Thu Mar 08 2018 RPM Fusion Release Engineering <leigh123linux@googlemail.com> - 1.3.0-20.20180119svn
- Rebuilt for new ffmpeg snapshot
* Mon Mar 05 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-19.20180119svn
- Disable runtime cpu detection for i686
- Remove scriptlets
* Thu Mar 01 2018 RPM Fusion Release Engineering <leigh123linux@googlemail.com> - 1.3.0-18.20180119svn
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Sun Jan 28 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-17.20180119svn
- Rebuilt for libcdio
* Fri Jan 19 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-16.20180119svn
- Update to latest svn
* Thu Jan 18 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-15
- Rebuilt for ffmpeg-3.5 git
* Sun Dec 31 2017 Sérgio Basto <sergio@serjux.com> - 1.3.0-14
- Mass rebuild for x264 and x265
* Mon Oct 23 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-13
- Exclude ix86 (rfbz #4687)
* Tue Oct 17 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-12
- Rebuild for ffmpeg update
- Add build upstream build fix for newer ffmpeg
* Thu Aug 31 2017 RPM Fusion Release Engineering <kwizart@rpmfusion.org> - 1.3.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Jul 15 2017 Paul Howarth <paul@city-fan.org> - 1.3.0-10
- Perl 5.26 rebuild
* Sat Jul 12 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-22.20140414svn * Sat Apr 29 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-9
- 20140414 snapshot - Rebuild for ffmpeg update
* Thu Mar 27 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-21.20140327svn * Mon Mar 20 2017 RPM Fusion Release Engineering <kwizart@rpmfusion.org> - 1.3.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Mar 03 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-7
- Fix vo_png with recent ffmpeg (rfbz#4470)
* Mon Feb 06 2017 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-6
- Fix screenshot crash (rfbz#4391)
* Thu Nov 17 2016 Adrian Reber <adrian@lisas.de> - 1.3.0-5
- Rebuilt for libcdio-0.94
* Sat Nov 05 2016 Leigh Scott <leigh123linux@googlemail.com> - 1.3.0-4
- Add provides mplayer-backend (rfbz#4284)
- Rebuilt for new ffmpeg
* Tue Oct 25 2016 Paul Howarth <paul@city-fan.org> - 1.3.0-3
- BR: perl-generators for proper dependency generation
(https://fedoraproject.org/wiki/Changes/Build_Root_Without_Perl)
* Sat Jul 30 2016 Julian Sikorski <belegdol@fedoraproject.org> - 1.3.0-2
- Rebuilt for ffmpeg-3.1.1
* Wed May 18 2016 Julian Sikorski <belegdol@fedoraproject.org> - 1.3.0-1
- Updated to 1.3.0
* Sat Apr 02 2016 Julian Sikorski <belegdol@fedoraproject.org> - 1.2.1-2
- Fixed BuildRequires so that audio CD support actually works
* Thu Jan 28 2016 Julian Sikorski <belegdol@fedoraproject.org> - 1.2.1-1
- Updated to 1.2.1
- Removed asm.h from mplayer-ffmpeg.patch
* Thu Oct 29 2015 Julian Sikorski <belegdol@fedoraproject.org> - 1.2-1
- Updated to 1.2
- Updated Blue skin to 1.11
* Thu May 07 2015 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-33.20150505svn
- 20150505 snapshot
- Updated ffmpeg patch
* Sat Jan 31 2015 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-32.20150123svn
- 20150123 snapshot
- Internal libdvd* are no more, cleaned up the spec accordingly
* Tue Oct 21 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-31.20141020svn
- 20141020 snapshot
* Mon Oct 20 2014 Sérgio Basto <sergio@serjux.com> - 1.1-30.20140919svn
- Rebuilt for FFmpeg 2.4.3
* Wed Oct 01 2014 Sérgio Basto <sergio@serjux.com> - 1.1-29.20140919svn
- Rebuilt again for FFmpeg 2.3.x (with FFmpeg 2.3.x in buildroot)
* Sat Sep 27 2014 kwizart <kwizart@gmail.com> - 1.1-28.20140919svn
- Rebuilt for FFmpeg 2.3x
* Thu Sep 25 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-27.20140919svn
- 20140919 snapshot
* Wed Aug 06 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-26.20140806svn
- 20140806 snapshot
* Sat Jul 12 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-25.20140711svn
- 20140711 snapshot
* Thu Mar 27 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-24.20140327svn
- 20140327 snapshot - 20140327 snapshot
* Fri Mar 21 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-23.20140301svn
- Rebuilt for libass-0.10.2
* Tue Mar 18 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-22.20140301svn
- Rebuilt for x264
* Thu Mar 06 2014 Nicolas Chauvet <kwizart@gmail.com> - 1.1-21.20140301svn
- Rebuilt for x264
* Sat Mar 01 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-20.20140301svn * Sat Mar 01 2014 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-20.20140301svn
- 20140301 snapshot - 20140301 snapshot

@ -1,2 +1,2 @@
d0d7baf1e84ba95f4456c51b50d99b14 Blue-1.10.tar.bz2 de7b4438b68729089d92912f041abe54 Blue-1.11.tar.bz2
8932bba01f855abbbeedd666fdd32c98 mplayer-export-2014-04-14.tar.bz2 5ba14bca349b6afcd7624ae7dd664c5d mplayer-export-2018-06-20.tar.bz2

Loading…
Cancel
Save