epel9
Peter Robinson 4 years ago
parent 621dbb1950
commit df0087de3d

1
.gitignore vendored

@ -2,3 +2,4 @@
/mosquitto-2.0.0.tar.gz
/mosquitto-2.0.2.tar.gz
/mosquitto-2.0.3.tar.gz
/mosquitto-2.0.4.tar.gz

@ -1,70 +0,0 @@
From 9d7580fdb695efef7f27c6fb4bbb4579e283ebd8 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Fri, 18 Dec 2020 08:05:06 +0000
Subject: [PATCH 1/2] Use libdir as the install prefix for plugins
Use the libdir variable from config.mk just like lib/ uses to ensure
that the plugins are installed into the same location as the library.
This fixes systems that use lib64 for libraries like most 64 bit
Linux distributions.
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
---
plugins/dynamic-security/Makefile | 6 +++---
plugins/message-timestamp/Makefile | 6 +++---
plugins/payload-modification/Makefile | 6 +++---
3 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/plugins/dynamic-security/Makefile b/plugins/dynamic-security/Makefile
index 810a17ba..9ef728b1 100644
--- a/plugins/dynamic-security/Makefile
+++ b/plugins/dynamic-security/Makefile
@@ -77,10 +77,10 @@ test:
install: all
ifeq ($(WITH_CJSON),yes)
ifeq ($(WITH_TLS),yes)
- $(INSTALL) -d "${DESTDIR}$(prefix)/lib"
- $(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ $(INSTALL) -d "${DESTDIR}$(libdir)"
+ $(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
endif
endif
uninstall :
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
diff --git a/plugins/message-timestamp/Makefile b/plugins/message-timestamp/Makefile
index b78384dc..f76b74cc 100644
--- a/plugins/message-timestamp/Makefile
+++ b/plugins/message-timestamp/Makefile
@@ -20,8 +20,8 @@ test:
install: ${PLUGIN_NAME}.so
# Don't install, these are examples only.
- #$(INSTALL) -d "${DESTDIR}$(prefix)/lib"
- #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ #$(INSTALL) -d "${DESTDIR}$(libdir)"
+ #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
uninstall :
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
diff --git a/plugins/payload-modification/Makefile b/plugins/payload-modification/Makefile
index 9511517a..ff3bcfc2 100644
--- a/plugins/payload-modification/Makefile
+++ b/plugins/payload-modification/Makefile
@@ -20,8 +20,8 @@ test:
install: ${PLUGIN_NAME}.so
# Don't install, these are examples only.
- #$(INSTALL) -d "${DESTDIR}$(prefix)/lib"
- #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ #$(INSTALL) -d "${DESTDIR}$(libdir)"
+ #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
uninstall :
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
--
2.29.2

@ -1,15 +1,13 @@
%global with_tests 0
Name: mosquitto
Version: 2.0.3
Version: 2.0.4
Release: 1%{?dist}
Summary: Open Source MQTT v3.1/v3.1.1 Broker
License: EPL-2.0
URL: http://mosquitto.org/
Source0: http://mosquitto.org/files/source/%{name}-%{version}.tar.gz
# https://github.com/eclipse/mosquitto/pull/1964
Patch0: 0001-Use-libdir-as-the-install-prefix-for-plugins.patch
BuildRequires: c-ares-devel
BuildRequires: cjson-devel
@ -119,6 +117,9 @@ exit 0
%{_mandir}/man3/libmosquitto.3.*
%changelog
* Thu Dec 24 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 2.0.4-1
- Update to 2.0.4
* Fri Dec 18 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 2.0.3-1
- Update to new upstream release 2.0.3
- Enable DNS SRV record support

@ -1 +1 @@
SHA512 (mosquitto-2.0.3.tar.gz) = 9781259fe097a2334cd3cfec9fe2627ac4486b6289f3e8fa19646e7b4c2c59e76d6fef4d5929f43aec8861adcef7fc1736f45faec1eeb6c0cfc908b8728a3df2
SHA512 (mosquitto-2.0.4.tar.gz) = a428061c6f99c9769a5dac1517936ee5500a6ecc56de08e5aac84d6fa8c543febaddb723cb0df765c115f09ca679582914740afcfddd3e21318a4bd547f3c6bf

Loading…
Cancel
Save