You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
71 lines
2.7 KiB
71 lines
2.7 KiB
From 9d7580fdb695efef7f27c6fb4bbb4579e283ebd8 Mon Sep 17 00:00:00 2001
|
|
From: Peter Robinson <pbrobinson@gmail.com>
|
|
Date: Fri, 18 Dec 2020 08:05:06 +0000
|
|
Subject: [PATCH 1/2] Use libdir as the install prefix for plugins
|
|
|
|
Use the libdir variable from config.mk just like lib/ uses to ensure
|
|
that the plugins are installed into the same location as the library.
|
|
This fixes systems that use lib64 for libraries like most 64 bit
|
|
Linux distributions.
|
|
|
|
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
---
|
|
plugins/dynamic-security/Makefile | 6 +++---
|
|
plugins/message-timestamp/Makefile | 6 +++---
|
|
plugins/payload-modification/Makefile | 6 +++---
|
|
3 files changed, 9 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/plugins/dynamic-security/Makefile b/plugins/dynamic-security/Makefile
|
|
index 810a17ba..9ef728b1 100644
|
|
--- a/plugins/dynamic-security/Makefile
|
|
+++ b/plugins/dynamic-security/Makefile
|
|
@@ -77,10 +77,10 @@ test:
|
|
install: all
|
|
ifeq ($(WITH_CJSON),yes)
|
|
ifeq ($(WITH_TLS),yes)
|
|
- $(INSTALL) -d "${DESTDIR}$(prefix)/lib"
|
|
- $(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ $(INSTALL) -d "${DESTDIR}$(libdir)"
|
|
+ $(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
endif
|
|
endif
|
|
|
|
uninstall :
|
|
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
diff --git a/plugins/message-timestamp/Makefile b/plugins/message-timestamp/Makefile
|
|
index b78384dc..f76b74cc 100644
|
|
--- a/plugins/message-timestamp/Makefile
|
|
+++ b/plugins/message-timestamp/Makefile
|
|
@@ -20,8 +20,8 @@ test:
|
|
|
|
install: ${PLUGIN_NAME}.so
|
|
# Don't install, these are examples only.
|
|
- #$(INSTALL) -d "${DESTDIR}$(prefix)/lib"
|
|
- #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ #$(INSTALL) -d "${DESTDIR}$(libdir)"
|
|
+ #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
|
|
uninstall :
|
|
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
diff --git a/plugins/payload-modification/Makefile b/plugins/payload-modification/Makefile
|
|
index 9511517a..ff3bcfc2 100644
|
|
--- a/plugins/payload-modification/Makefile
|
|
+++ b/plugins/payload-modification/Makefile
|
|
@@ -20,8 +20,8 @@ test:
|
|
|
|
install: ${PLUGIN_NAME}.so
|
|
# Don't install, these are examples only.
|
|
- #$(INSTALL) -d "${DESTDIR}$(prefix)/lib"
|
|
- #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ #$(INSTALL) -d "${DESTDIR}$(libdir)"
|
|
+ #$(INSTALL) ${STRIP_OPTS} ${PLUGIN_NAME}.so "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
|
|
uninstall :
|
|
- -rm -f "${DESTDIR}${prefix}/lib/${PLUGIN_NAME}.so"
|
|
+ -rm -f "${DESTDIR}${libdir}/${PLUGIN_NAME}.so"
|
|
--
|
|
2.29.2
|
|
|