parent
6892237970
commit
826578ceed
@ -0,0 +1,19 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index a6deb4c..c579059 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -115,7 +115,13 @@ endif()
|
||||
# Check if zstd installation is present
|
||||
if(MZ_ZSTD)
|
||||
if(NOT ZSTD_FORCE_FETCH)
|
||||
- find_package(ZSTD QUIET)
|
||||
+ find_package(PkgConfig)
|
||||
+ if(PKGCONFIG_FOUND)
|
||||
+ pkg_check_modules(ZSTD libzstd)
|
||||
+ endif()
|
||||
+ if(NOT ZSTD_FOUND)
|
||||
+ find_package(ZSTD QUIET)
|
||||
+ endif()
|
||||
endif()
|
||||
if(ZSTD_FOUND AND NOT ZSTD_FORCE_FETCH)
|
||||
message(STATUS "Using ZSTD")
|
@ -1 +1 @@
|
||||
SHA512 (minizip-2.9.3.tar.gz) = 397a75fd36f0f0b16d7098ad4796177a40b187c220b09a8ed69e9170b9ac262644e55b5c3c27029ae53e8c4b76a04ffea2a25eba3e43c645b3bbaf568279dce4
|
||||
SHA512 (minizip-2.10.0.tar.gz) = 8717e00242ba4f8247ef60c925813bcfaf104243cdbfff4cca690e7c1f7da1132084e1b939b3adf1f019d220a1034f46f2fe2a543cca19106af5136e09d6af16
|
||||
|
Loading…
Reference in new issue