import miniupnpc-2.2.4-2.el9

i9ce changed/i9ce/miniupnpc-2.2.4-2.el9
Arkady L. Shane 8 months ago
commit 083ff22a98
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/miniupnpc-2.2.4.tar.gz

@ -0,0 +1 @@
1d76b3d7eb3a398207469a627dd3976f6b5ddf15 SOURCES/miniupnpc-2.2.4.tar.gz

@ -0,0 +1,22 @@
From ea67c29b64ff3c89a01f4fd66e8d5733f5ebe00e Mon Sep 17 00:00:00 2001
From: scribam <scribam@users.noreply.github.com>
Date: Fri, 21 Oct 2022 23:45:35 +0200
Subject: [PATCH] miniupnpc: update cmake project version
---
miniupnpc/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/miniupnpc/CMakeLists.txt b/miniupnpc/CMakeLists.txt
index fbc04709..d7742dcf 100644
--- a/miniupnpc/CMakeLists.txt
+++ b/miniupnpc/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
project (miniupnpc
- VERSION 2.2.3
+ VERSION 2.2.4
DESCRIPTION "UPnP IGD client lightweight library"
HOMEPAGE_URL https://miniupnp.tuxfamily.org/
LANGUAGES C)

@ -0,0 +1,163 @@
# Needed for RHEL/CentOS 8
%undefine __cmake_in_source_build
# Set a common one for all architectures and not _target_platform, fixes aarch64
%global __cmake_builddir build
%filter_provides_in %{python3_sitearch}/.*\.so$
Summary: Library and tool to control NAT in UPnP-enabled routers
Name: miniupnpc
Version: 2.2.4
Release: 2%{?dist}
License: BSD
URL: http://miniupnp.free.fr/
BuildRequires: cmake >= 3.5.0
BuildRequires: gcc
BuildRequires: make
BuildRequires: python3-devel
BuildRequires: python3-setuptools
Source0: http://miniupnp.free.fr/files/%{name}-%{version}.tar.gz
Patch0: https://github.com/miniupnp/miniupnp/commit/ea67c29b64ff3c89a01f4fd66e8d5733f5ebe00e.patch
%description
miniupnpc is an implementation of a UPnP client library, enabling applications
to access the services provided by an UPnP "Internet Gateway Device" present on
the network. In UPnP terminology, it is a UPnP Control Point.
This package includes upnpc, a UPnP client application for configuring port
forwarding in UPnP enabled routers.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package contains the header files and development documentation for
%{name}.
%package -n python3-%{name}
Summary: Python3 interface to %{name}
%description -n python3-%{name}
This package contains python3 interfaces to %{name}.
%prep
%autosetup -p2
# Use already built shared object for Python module
# Unversioned link is not enough to avoid a rebuild
sed -i -e 's|build/libminiupnpc.a|build/libminiupnpc.so.%{version}|g' setup.py
%build
%cmake \
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
-DCMAKE_SKIP_RPATH:BOOL=YES \
-DNO_GETADDRINFO=FALSE \
-DUPNPC_BUILD_SAMPLE=TRUE \
-DUPNPC_BUILD_SHARED=TRUE \
-DUPNPC_BUILD_STATIC=FALSE \
-DUPNPC_BUILD_TESTS=TRUE \
-DUPNPC_NO_INSTALL=FALSE
%cmake_build
%py3_build
%install
%cmake_install
%py3_install
install -p -m 0644 -D man3/%{name}.3 %{buildroot}%{_mandir}/man3/%{name}.3
install -p -m 0755 -D build/upnpc-shared %{buildroot}%{_bindir}/upnpc
%check
make CFLAGS="%{optflags} -DMINIUPNPC_SET_SOCKET_TIMEOUT" check
%files
%license LICENSE
%doc Changelog.txt README
%{_bindir}/upnpc
%{_libdir}/libminiupnpc.so.17
%{_libdir}/libminiupnpc.so.%{version}
%files devel
%{_includedir}/%{name}
%{_libdir}/cmake/%{name}/libminiupnpc-shared-noconfig.cmake
%{_libdir}/cmake/%{name}/libminiupnpc-shared.cmake
%{_libdir}/cmake/%{name}/miniupnpc-config.cmake
%{_libdir}/libminiupnpc.so
%{_libdir}/pkgconfig/%{name}.pc
%{_mandir}/man3/%{name}.3*
%files -n python3-%{name}
%{python3_sitearch}/miniupnpc-%{version}-py3.*.egg-info/
%{python3_sitearch}/miniupnpc*.so
%changelog
* Sun Jun 02 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.2.4-2
- Rebuilt for MSVSphere 9.4
* Fri Oct 28 2022 Simone Caronni <negativo17@gmail.com> - 2.2.4-2
- Restore test client binary.
* Tue Oct 25 2022 Simone Caronni <negativo17@gmail.com> - 2.2.4-1
- Update to 2.2.4.
* Sat Jan 29 2022 Simone Caronni <negativo17@gmail.com> - 2.2.3-2
- Build fixes.
* Fri Jan 28 2022 Simone Caronni <negativo17@gmail.com> - 2.2.3-1
- Update to 2.2.3.
- Update SPEC file (license, tabs/spaces, trim changelog, etc.)
- Switch to CMake build.
- Drop static libraries.
- Drop test client and obsolete documentation.
- Do not use static library when building Python module.
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.2.2-2
- Rebuilt for Python 3.10
* Wed Mar 03 2021 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 2.2.2-1
- Update to version 2.2.2
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Fri Nov 13 2020 Kalev Lember <klember@redhat.com> - 2.2.0-1
- Update to 2.2.0
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.1-6
- Rebuilt for Python 3.9
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Nov 15 2019 Miro Hrončok <mhroncok@redhat.com> - 2.1-4
- Subpackage python2-miniupnpc has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.1-3
- Rebuilt for Python 3.8
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Wed Feb 06 2019 Kalev Lember <klember@redhat.com> - 2.1-1
- Update to 2.1
* Wed Feb 06 2019 Kalev Lember <klember@redhat.com> - 2.0-13
- Fix FTBFS (#1604853)
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Loading…
Cancel
Save