commit
c4e3618a12
@ -0,0 +1 @@
|
|||||||
|
SOURCES/Vulkan-Loader-1.3.231.1.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
750e93144113da24ef9ff2f834e293ea62cd92b5 SOURCES/Vulkan-Loader-1.3.231.1.tar.gz
|
@ -0,0 +1,29 @@
|
|||||||
|
diff -rupN --no-dereference Vulkan-Loader-sdk-1.3.231.1/loader/CMakeLists.txt Vulkan-Loader-sdk-1.3.231.1-new/loader/CMakeLists.txt
|
||||||
|
--- Vulkan-Loader-sdk-1.3.231.1/loader/CMakeLists.txt 2022-10-16 20:11:22.000000000 +0200
|
||||||
|
+++ Vulkan-Loader-sdk-1.3.231.1-new/loader/CMakeLists.txt 2022-11-12 20:04:49.810001092 +0100
|
||||||
|
@@ -229,7 +229,6 @@ if(WIN32)
|
||||||
|
SHARED
|
||||||
|
${NORMAL_LOADER_SRCS}
|
||||||
|
$<TARGET_OBJECTS:loader-unknown-chain>
|
||||||
|
- ${CMAKE_CURRENT_SOURCE_DIR}/vulkan-1.def
|
||||||
|
${CMAKE_CURRENT_LIST_DIR}/loader.rc)
|
||||||
|
|
||||||
|
target_link_libraries(vulkan PRIVATE loader_specific_options loader-opt)
|
||||||
|
diff -rupN --no-dereference Vulkan-Loader-sdk-1.3.231.1/loader/extension_manual.c Vulkan-Loader-sdk-1.3.231.1-new/loader/extension_manual.c
|
||||||
|
--- Vulkan-Loader-sdk-1.3.231.1/loader/extension_manual.c 2022-10-16 20:11:22.000000000 +0200
|
||||||
|
+++ Vulkan-Loader-sdk-1.3.231.1-new/loader/extension_manual.c 2022-11-12 20:04:49.810001092 +0100
|
||||||
|
@@ -20,13 +20,13 @@
|
||||||
|
* Author: Charles Giessen <charles@lunarg.com>
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include "allocation.h"
|
||||||
|
#include "extension_manual.h"
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
-#include "allocation.h"
|
||||||
|
#include "debug_utils.h"
|
||||||
|
#include "loader.h"
|
||||||
|
#include "log.h"
|
@ -0,0 +1,201 @@
|
|||||||
|
%{?mingw_package_header}
|
||||||
|
|
||||||
|
%global pkgname vulkan-loader
|
||||||
|
%global srcname Vulkan-Loader
|
||||||
|
|
||||||
|
%define baseversion %(echo %{version} | awk -F'.' '{print $1"."$2"."$3}')
|
||||||
|
|
||||||
|
Name: mingw-%{pkgname}
|
||||||
|
Version: 1.3.231.1
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: MinGW Windows %{pkgname} library
|
||||||
|
|
||||||
|
License: Apache-2.0
|
||||||
|
BuildArch: noarch
|
||||||
|
URL: https://github.com/KhronosGroup/%{srcname}
|
||||||
|
Source0: https://github.com/KhronosGroup/%{srcname}/archive/sdk-%{version}/%{srcname}-%{version}.tar.gz
|
||||||
|
|
||||||
|
# Omit def file, results in vulkan-1.dll.a containing non @-decorated symbols, while vulkan-1.dll contains @-decorated symbols
|
||||||
|
# Fix include oder resulting in windows.h getting included before winsock2.h
|
||||||
|
Patch0: vulkan-loader_mingw.patch
|
||||||
|
|
||||||
|
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: cmake
|
||||||
|
|
||||||
|
BuildRequires: mingw32-filesystem >= 95
|
||||||
|
BuildRequires: mingw32-gcc-c++
|
||||||
|
BuildRequires: mingw32-vulkan-headers >= %{baseversion}
|
||||||
|
|
||||||
|
BuildRequires: mingw64-filesystem >= 95
|
||||||
|
BuildRequires: mingw64-gcc-c++
|
||||||
|
BuildRequires: mingw64-vulkan-headers >= %{baseversion}
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
MinGW Windows %{pkgname} library.
|
||||||
|
|
||||||
|
|
||||||
|
%package -n mingw32-%{pkgname}
|
||||||
|
Summary: MinGW Windows %{pkgname} library
|
||||||
|
|
||||||
|
%description -n mingw32-%{pkgname}
|
||||||
|
MinGW Windows %{pkgname} library.
|
||||||
|
|
||||||
|
|
||||||
|
%package -n mingw64-%{pkgname}
|
||||||
|
Summary: MinGW Windows %{pkgname} library
|
||||||
|
|
||||||
|
%description -n mingw64-%{pkgname}
|
||||||
|
MinGW Windows %{pkgname} library.
|
||||||
|
|
||||||
|
|
||||||
|
%{?mingw_debug_package}
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n %{srcname}-sdk-%{version}
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%mingw_cmake -DUSE_MASM=OFF -DENABLE_WERROR=OFF
|
||||||
|
%mingw_make_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mingw_make_install
|
||||||
|
|
||||||
|
|
||||||
|
%files -n mingw32-%{pkgname}
|
||||||
|
%doc README.md
|
||||||
|
%license LICENSE.txt
|
||||||
|
%{mingw32_bindir}/vulkan-1.dll
|
||||||
|
%{mingw32_libdir}/libvulkan-1.dll.a
|
||||||
|
%{mingw32_libdir}/pkgconfig/vulkan.pc
|
||||||
|
|
||||||
|
|
||||||
|
%files -n mingw64-%{pkgname}
|
||||||
|
%doc README.md
|
||||||
|
%license LICENSE.txt
|
||||||
|
%{mingw64_bindir}/vulkan-1.dll
|
||||||
|
%{mingw64_libdir}/libvulkan-1.dll.a
|
||||||
|
%{mingw64_libdir}/pkgconfig/vulkan.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jan 16 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.3.231.1-2
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.231.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Nov 12 2022 Sandro Mani <manisandro@gmail.com> - 1.3.231.1-1
|
||||||
|
- Update to 1.3.231.1
|
||||||
|
|
||||||
|
* Fri Sep 16 2022 Sandro Mani <manisandro@gmail.com> - 1.3.224.1-1
|
||||||
|
- Update to 1.3.224.1
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.216-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 28 2022 Sandro Mani <manisandro@gmail.com> - 1.3.216-1
|
||||||
|
- Update to 1.3.216
|
||||||
|
|
||||||
|
* Wed Apr 27 2022 Sandro Mani <manisandro@gmail.com> - 1.3.211.0-1
|
||||||
|
- Update to 1.3.211.0
|
||||||
|
|
||||||
|
* Fri Mar 25 2022 Sandro Mani <manisandro@gmail.com> - 1.3.204.0-2
|
||||||
|
- Rebuild with mingw-gcc-12
|
||||||
|
|
||||||
|
* Fri Feb 18 2022 Sandro Mani <manisandro@gmail.com> - 1.3.204.0-1
|
||||||
|
- Update to 1.3.204.0
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.198.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 23 2021 Sandro Mani <manisandro@gmail.com> - 1.2.198.0-1
|
||||||
|
- Update to 1.2.198.0
|
||||||
|
|
||||||
|
* Tue Sep 07 2021 Sandro Mani <manisandro@gmail.com> - 1.2.189.0-1
|
||||||
|
- Update to 1.2.189.0
|
||||||
|
|
||||||
|
* Sat Jul 24 2021 Sandro Mani <manisandro@gmail.com> - 1.2.182.0-3
|
||||||
|
- Drop _WIN32_WINNT define, mingw-9.0 defaults to _WIN32_WINNT=0xA00
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.182.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 08 2021 Sandro Mani <manisandro@gmail.com> - 1.2.182.0-1
|
||||||
|
- Update to 1.2.182.0
|
||||||
|
|
||||||
|
* Wed May 19 2021 Sandro Mani <manisandro@gmail.com> - 1.2.176.0-1
|
||||||
|
- Update to 1.2.176.0
|
||||||
|
|
||||||
|
* Thu Jan 28 2021 Sandro Mani <manisandro@gmail.com> - 1.2.162.0-2
|
||||||
|
- Add vulkan-loader_nodef.patch
|
||||||
|
|
||||||
|
* Thu Jan 28 2021 Sandro Mani <manisandro@gmail.com> - 1.2.162.0-1
|
||||||
|
- Update to 1.2.162.0
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.154.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 04 2020 Sandro Mani <manisandro@gmail.com> - 1.2.154.1-1
|
||||||
|
- Update to 1.2.154.1
|
||||||
|
|
||||||
|
* Mon Nov 02 2020 Sandro Mani <manisandro@gmail.com> - 1.2.148.1-1
|
||||||
|
- Update to 1.2.148.1
|
||||||
|
|
||||||
|
* Mon Aug 10 2020 Sandro Mani <manisandro@gmail.com> - 1.2.148.0-1
|
||||||
|
- Update to 1.2.148.0
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.135.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 22 2020 Sandro Mani <manisandro@gmail.com> - 1.2.135.0-1
|
||||||
|
- Update to 1.2.135.0
|
||||||
|
|
||||||
|
* Sun Feb 02 2020 Sandro Mani <manisandro@gmail.com> - 1.2.131.1-1
|
||||||
|
- Update to 1.2.131.1
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.126.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 12 2019 Sandro Mani <manisandro@gmail.com> - 1.1.126.0-1
|
||||||
|
- Update to 1.1.126.0
|
||||||
|
|
||||||
|
* Tue Oct 08 2019 Sandro Mani <manisandro@gmail.com> - 1.1.114.0-2
|
||||||
|
- Rebuild (Changes/Mingw32GccDwarf2)
|
||||||
|
|
||||||
|
* Wed Jul 31 2019 Sandro Mani <manisandro@gmail.com> - 1.1.114.0-1
|
||||||
|
- Update to 1.1.114.0
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.108.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 28 2019 Sandro Mani <manisandro@gmail.com> - 1.1.108.0-1
|
||||||
|
- Update to 1.1.108.0
|
||||||
|
|
||||||
|
* Sat Apr 20 2019 Sandro Mani <manisandro@gmail.com> - 1.1.106.0-1
|
||||||
|
- Update to 1.1.106.0
|
||||||
|
|
||||||
|
* Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 1.1.101.1-1
|
||||||
|
- Update to 1.1.101.1
|
||||||
|
|
||||||
|
* Wed Feb 13 2019 Sandro Mani <manisandro@gmail.com> - 1.1.97.0-1
|
||||||
|
- Update to 1.1.97.0
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.82.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 07 2018 Sandro Mani <manisandro@gmail.com> - 1.1.82.0-1
|
||||||
|
- Update to 1.1.82.0
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 26 2018 Sandro Mani <manisandro@gmail.com> - 1.1.77-1
|
||||||
|
- Update to 1.1.77
|
||||||
|
|
||||||
|
* Sat Jun 09 2018 Sandro Mani <manisandro@gmail.com> - 1.1.74-0.1.git1bd294a
|
||||||
|
- Initial package
|
Loading…
Reference in new issue