- Always use the native win32 thread API even when pthreads is available

- Dropped a patch which isn't necessary anymore
epel9
epienbro 16 years ago
parent b2ef773d9a
commit 8939de86b0

@ -1,11 +0,0 @@
--- testThreads.c.orig 2009-09-11 18:09:00.268640135 +0200
+++ testThreads.c 2009-09-11 18:12:43.412653512 +0200
@@ -107,7 +107,7 @@
for (i = 0; i < num_threads; i++) {
results[i] = NULL;
- tid[i] = (pthread_t) -1;
+ memset(&tid[i], 0, sizeof(pthread_t));
}
for (i = 0; i < num_threads; i++) {

@ -7,7 +7,7 @@
Name: mingw32-libxml2
Version: 2.7.4
Release: 1%{?dist}
Release: 2%{?dist}
Summary: MinGW Windows libxml2 XML processing library
License: MIT
@ -22,7 +22,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# MinGW-specific patches.
Patch1000: mingw32-libxml2-2.7.2-with-modules.patch
Patch1001: mingw32-libxml2-static-build-compile-fix.patch
Patch1002: mingw32-libxml2-win32-pthreads-compatibility.patch
BuildArch: noarch
@ -61,7 +60,6 @@ Static version of the MinGW Windows XML processing library.
%patch1000 -p1
%patch1001 -p0
%patch1002 -p0
# Patched configure.in, so rebuild configure.
libtoolize --force --copy
@ -74,14 +72,14 @@ autoreconf
mkdir build_static
pushd build_static
LDFLAGS="-no-undefined" \
%{_mingw32_configure} --without-python --with-modules --enable-static --disable-shared CFLAGS="$CFLAGS -DLIBXML_STATIC_FOR_DLL"
%{_mingw32_configure} --without-python --with-modules --enable-static --disable-shared --with-threads=yes CFLAGS="$CFLAGS -DLIBXML_STATIC_FOR_DLL"
make %{?_smp_mflags}
popd
mkdir build_shared
pushd build_shared
LDFLAGS="-no-undefined" \
%{_mingw32_configure} --without-python --with-modules --disable-static --enable-shared
%{_mingw32_configure} --without-python --with-modules --disable-static --enable-shared --with-threads=yes
make %{?_smp_mflags}
popd
@ -133,6 +131,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sat Sep 12 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 2.7.4-2
- Always use the native win32 thread API even when pthreads is available
- Dropped a patch which isn't necessary anymore
* Fri Sep 11 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 2.7.4-1
- Update to 2.7.4
- Drop upstreamed libxml2-2.7.3-ficora-parse.patch patch

Loading…
Cancel
Save