parent
28d67b0ae3
commit
7e463b22de
@ -0,0 +1 @@
|
|||||||
|
libxml2-2.7.2.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
mingw32-libxml2-2_7_2-6_fc11:HEAD:mingw32-libxml2-2.7.2-6.fc11.src.rpm:1233143139
|
@ -0,0 +1,15 @@
|
|||||||
|
--- libxml2-2.7.2/configure.in~ 2008-10-03 08:09:55.000000000 +0100
|
||||||
|
+++ libxml2-2.7.2/configure.in 2008-10-25 23:14:18.000000000 +0100
|
||||||
|
@@ -751,6 +751,12 @@
|
||||||
|
AC_DEFINE([HAVE_DLOPEN], [], [Have dlopen based dso])
|
||||||
|
])
|
||||||
|
;;
|
||||||
|
+ *-*-mingw*)
|
||||||
|
+ # If I configured --with-modules then I damn well want
|
||||||
|
+ # modules and don't try to second-guess me.
|
||||||
|
+ MODULE_EXTENSION=".dll"
|
||||||
|
+ WITH_MODULES=1
|
||||||
|
+ ;;
|
||||||
|
*)
|
||||||
|
AC_CHECK_FUNC(shl_load, libxml_have_shl_load=yes, [
|
||||||
|
AC_CHECK_LIB(dld, shl_load, [
|
@ -0,0 +1,127 @@
|
|||||||
|
%define __strip %{_mingw32_strip}
|
||||||
|
%define __objdump %{_mingw32_objdump}
|
||||||
|
%define _use_internal_dependency_generator 0
|
||||||
|
%define __find_requires %{_mingw32_findrequires}
|
||||||
|
%define __find_provides %{_mingw32_findprovides}
|
||||||
|
|
||||||
|
Name: mingw32-libxml2
|
||||||
|
Version: 2.7.2
|
||||||
|
Release: 6%{?dist}
|
||||||
|
Summary: MinGW Windows libxml2 XML processing library
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
Group: Development/Libraries
|
||||||
|
URL: http://xmlsoft.org/
|
||||||
|
Source0: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
# Not required for MinGW.
|
||||||
|
#Patch0: libxml2-multilib.patch
|
||||||
|
|
||||||
|
# MinGW-specific patches.
|
||||||
|
Patch1000: mingw32-libxml2-2.7.2-with-modules.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: mingw32-filesystem >= 23
|
||||||
|
BuildRequires: mingw32-gcc
|
||||||
|
BuildRequires: mingw32-binutils
|
||||||
|
|
||||||
|
BuildRequires: mingw32-dlfcn
|
||||||
|
BuildRequires: mingw32-gettext
|
||||||
|
BuildRequires: mingw32-iconv
|
||||||
|
BuildRequires: mingw32-zlib
|
||||||
|
|
||||||
|
BuildRequires: autoconf, automake, libtool
|
||||||
|
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
MinGW Windows libxml2 XML processing library.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n libxml2-%{version}
|
||||||
|
|
||||||
|
%patch1000 -p1
|
||||||
|
|
||||||
|
# Patched configure.in, so rebuild configure.
|
||||||
|
libtoolize --force --copy
|
||||||
|
autoreconf
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
LDFLAGS="-no-undefined" \
|
||||||
|
%{_mingw32_configure} --without-python --with-modules --disable-static
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
|
||||||
|
# Remove manpages which duplicate Fedora native.
|
||||||
|
rm -rf $RPM_BUILD_ROOT%{_mingw32_mandir}
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_mingw32_bindir}/libxml2-2.dll
|
||||||
|
%{_mingw32_bindir}/xml2-config
|
||||||
|
%{_mingw32_bindir}/xmlcatalog.exe
|
||||||
|
%{_mingw32_bindir}/xmllint.exe
|
||||||
|
%{_mingw32_libdir}/libxml2.dll.a
|
||||||
|
%{_mingw32_libdir}/libxml2.la
|
||||||
|
%{_mingw32_libdir}/pkgconfig
|
||||||
|
%{_mingw32_libdir}/pkgconfig/libxml-2.0.pc
|
||||||
|
%{_mingw32_libdir}/xml2Conf.sh
|
||||||
|
%{_mingw32_includedir}/libxml2
|
||||||
|
%{_mingw32_datadir}/aclocal/*
|
||||||
|
%{_mingw32_docdir}/libxml2-%{version}/
|
||||||
|
%{_mingw32_datadir}/gtk-doc/html/libxml2/
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 26 2009 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-6
|
||||||
|
- Rerun autoreconf after patching configure.in (Erik van Pienbroek).
|
||||||
|
- Rebuild libtool for Rawhide / libtool 2.
|
||||||
|
- Add BRs dlfcn and iconv.
|
||||||
|
|
||||||
|
* Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-5
|
||||||
|
- Use _smp_mflags.
|
||||||
|
- Disable static libraries.
|
||||||
|
|
||||||
|
* Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-4
|
||||||
|
- Requires pkgconfig.
|
||||||
|
|
||||||
|
* Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-3
|
||||||
|
- Enable modules support for libxslt.
|
||||||
|
|
||||||
|
* Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-1
|
||||||
|
- Resynch to native Fedora package + patch.
|
||||||
|
|
||||||
|
* Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.1-2
|
||||||
|
- Rename mingw -> mingw32.
|
||||||
|
|
||||||
|
* Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 2.7.1-1
|
||||||
|
- Update to 2.7.1 release
|
||||||
|
|
||||||
|
* Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-5
|
||||||
|
- Remove manpages which duplicate Fedora native.
|
||||||
|
|
||||||
|
* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-4
|
||||||
|
- Remove static libraries.
|
||||||
|
- List libdir files explicitly.
|
||||||
|
|
||||||
|
* Fri Sep 5 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-3
|
||||||
|
- Use RPM macros from mingw-filesystem.
|
||||||
|
- BuildArch is noarch.
|
||||||
|
|
||||||
|
* Mon Jul 7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-1
|
||||||
|
- Initial RPM release, largely based on earlier work from several sources.
|
Loading…
Reference in new issue