- Dropped upstreamed patches - Use the CVE-2010-4494 patch from Fedora native libxml2 (#665965)epel9
parent
167ddb8b21
commit
48c56302ac
@ -1 +1,2 @@
|
|||||||
libxml2-2.7.6.tar.gz
|
libxml2-2.7.6.tar.gz
|
||||||
|
/libxml2-2.7.8.tar.gz
|
||||||
|
@ -0,0 +1,22 @@
|
|||||||
|
--- a/xpath.c
|
||||||
|
+++ a/xpath.c
|
||||||
|
@@ -11763,11 +11763,16 @@ xmlXPathCompOpEvalPositionalPredicate(xmlXPathParserContextPtr ctxt,
|
||||||
|
|
||||||
|
if ((ctxt->error != XPATH_EXPRESSION_OK) || (res == -1)) {
|
||||||
|
xmlXPathObjectPtr tmp;
|
||||||
|
- /* pop the result */
|
||||||
|
+ /* pop the result if any */
|
||||||
|
tmp = valuePop(ctxt);
|
||||||
|
- xmlXPathReleaseObject(xpctxt, tmp);
|
||||||
|
- /* then pop off contextObj, which will be freed later */
|
||||||
|
- valuePop(ctxt);
|
||||||
|
+ if (tmp != contextObj) {
|
||||||
|
+ /*
|
||||||
|
+ * Free up the result
|
||||||
|
+ * then pop off contextObj, which will be freed later
|
||||||
|
+ */
|
||||||
|
+ xmlXPathReleaseObject(xpctxt, tmp);
|
||||||
|
+ valuePop(ctxt);
|
||||||
|
+ }
|
||||||
|
goto evaluation_error;
|
||||||
|
}
|
@ -1,11 +0,0 @@
|
|||||||
--- include/libxml/xmlexports.h 2009-09-25 00:00:03.511532978 +0200
|
|
||||||
+++ include/libxml/xmlexports.h 2009-09-25 00:01:27.058533091 +0200
|
|
||||||
@@ -115,7 +115,7 @@
|
|
||||||
*/
|
|
||||||
#if !defined(LIBXML_STATIC)
|
|
||||||
#define XMLPUBFUN __declspec(dllexport)
|
|
||||||
- #define XMLPUBVAR __declspec(dllexport)
|
|
||||||
+ #define XMLPUBVAR __declspec(dllexport) extern
|
|
||||||
#else
|
|
||||||
#define XMLPUBFUN
|
|
||||||
#if !defined(LIBXML_STATIC)
|
|
@ -1,15 +0,0 @@
|
|||||||
--- libxml2-2.7.2/configure.in~ 2008-10-03 08:09:55.000000000 +0100
|
|
||||||
+++ libxml2-2.7.2/configure.in 2008-10-25 23:14:18.000000000 +0100
|
|
||||||
@@ -751,6 +751,12 @@
|
|
||||||
AC_DEFINE([HAVE_DLOPEN], [], [Have dlopen based dso])
|
|
||||||
])
|
|
||||||
;;
|
|
||||||
+ *-*-mingw*)
|
|
||||||
+ # If I configured --with-modules then I damn well want
|
|
||||||
+ # modules and don't try to second-guess me.
|
|
||||||
+ MODULE_EXTENSION=".dll"
|
|
||||||
+ WITH_MODULES=1
|
|
||||||
+ ;;
|
|
||||||
*)
|
|
||||||
AC_CHECK_FUNC(shl_load, libxml_have_shl_load=yes, [
|
|
||||||
AC_CHECK_LIB(dld, shl_load, [
|
|
Loading…
Reference in new issue