parent
fe5f90f747
commit
e839a929ea
@ -1,29 +0,0 @@
|
|||||||
--- a/jchuff.c
|
|
||||||
+++ b/jchuff.c
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
* This file was part of the Independent JPEG Group's software:
|
|
||||||
* Copyright (C) 1991-1997, Thomas G. Lane.
|
|
||||||
* libjpeg-turbo Modifications:
|
|
||||||
- * Copyright (C) 2009-2011, D. R. Commander.
|
|
||||||
+ * Copyright (C) 2009-2011, 2014 D. R. Commander.
|
|
||||||
* For conditions of distribution and use, see the accompanying README file.
|
|
||||||
*
|
|
||||||
* This file contains Huffman entropy encoding routines.
|
|
||||||
@@ -426,7 +426,7 @@
|
|
||||||
LOCAL(boolean)
|
|
||||||
flush_bits (working_state * state)
|
|
||||||
{
|
|
||||||
- JOCTET _buffer[BUFSIZE], *buffer;
|
|
||||||
+ JOCTET _buffer[BUFSIZE + 8], *buffer;
|
|
||||||
size_t put_buffer; int put_bits;
|
|
||||||
size_t bytes, bytestocopy; int localbuf = 0;
|
|
||||||
|
|
||||||
@@ -455,7 +455,7 @@
|
|
||||||
int temp, temp2, temp3;
|
|
||||||
int nbits;
|
|
||||||
int r, code, size;
|
|
||||||
- JOCTET _buffer[BUFSIZE], *buffer;
|
|
||||||
+ JOCTET _buffer[BUFSIZE + 8], *buffer;
|
|
||||||
size_t put_buffer; int put_bits;
|
|
||||||
int code_0xf0 = actbl->ehufco[0xf0], size_0xf0 = actbl->ehufsi[0xf0];
|
|
||||||
size_t bytes, bytestocopy; int localbuf = 0;
|
|
@ -1,29 +0,0 @@
|
|||||||
--- a/jchuff.c
|
|
||||||
+++ b/jchuff.c
|
|
||||||
@@ -408,7 +408,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
|
|
||||||
-#define BUFSIZE (DCTSIZE2 * 2)
|
|
||||||
+#define BUFSIZE (DCTSIZE2 * 2) + 8
|
|
||||||
|
|
||||||
#define LOAD_BUFFER() { \
|
|
||||||
if (state->free_in_buffer < BUFSIZE) { \
|
|
||||||
@@ -443,7 +443,7 @@
|
|
||||||
LOCAL(boolean)
|
|
||||||
flush_bits (working_state * state)
|
|
||||||
{
|
|
||||||
- JOCTET _buffer[BUFSIZE + 8], *buffer;
|
|
||||||
+ JOCTET _buffer[BUFSIZE], *buffer;
|
|
||||||
size_t put_buffer; int put_bits;
|
|
||||||
size_t bytes, bytestocopy; int localbuf = 0;
|
|
||||||
|
|
||||||
@@ -472,7 +472,7 @@
|
|
||||||
int temp, temp2, temp3;
|
|
||||||
int nbits;
|
|
||||||
int r, code, size;
|
|
||||||
- JOCTET _buffer[BUFSIZE + 8], *buffer;
|
|
||||||
+ JOCTET _buffer[BUFSIZE], *buffer;
|
|
||||||
size_t put_buffer; int put_bits;
|
|
||||||
int code_0xf0 = actbl->ehufco[0xf0], size_0xf0 = actbl->ehufsi[0xf0];
|
|
||||||
size_t bytes, bytestocopy; int localbuf = 0;
|
|
@ -1,14 +0,0 @@
|
|||||||
--- libjpeg-turbo-1.3.1/CMakeLists.txt.orig 2014-05-29 17:00:31.775255437 +0200
|
|
||||||
+++ libjpeg-turbo-1.3.1/CMakeLists.txt 2014-05-29 17:01:07.174824178 +0200
|
|
||||||
@@ -3,7 +3,10 @@
|
|
||||||
#
|
|
||||||
|
|
||||||
cmake_minimum_required(VERSION 2.8.8)
|
|
||||||
-cmake_policy(SET CMP0022 OLD)
|
|
||||||
+# Use LINK_INTERFACE_LIBRARIES instead of INTERFACE_LINK_LIBRARIES
|
|
||||||
+if(POLICY CMP0022)
|
|
||||||
+ cmake_policy(SET CMP0022 OLD)
|
|
||||||
+endif()
|
|
||||||
|
|
||||||
project(libjpeg-turbo C)
|
|
||||||
set(VERSION 1.3.1)
|
|
Loading…
Reference in new issue