Something got stricter at parsing URL query parameters and now the

parameters need to be separated by "&"; ";" is no longer allowed. See
issue6504 for details
i8-stream-4.8
Arkady L. Shane 4 months ago
parent 4b503cec8b
commit fc5efe612c
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,38 @@
From 6eba4365d9085a1c89f55f381e381e24b58ea7d0 Mon Sep 17 00:00:00 2001
From: Martin von Zweigbergk <martinvonz@google.com>
Date: Fri, 21 May 2021 12:03:33 -0400
Subject: [PATCH] tests: make test-archive.t pass on py3.9 (issue6504)
Something got stricter at parsing URL query parameters and now the
parameters need to be separated by "&"; ";" is no longer allowed. See
issue6504 for details.
Differential Revision: https://phab.mercurial-scm.org/D10472
Origin: upstream, https://www.mercurial-scm.org/repo/hg/rev/dc8976cc3a6e
Bug-Debian: https://bugs.debian.org/986514
Bug-upstream: https://bz.mercurial-scm.org/show_bug.cgi?id=6504
---
tests/test-archive.t | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/test-archive.t b/tests/test-archive.t
index 209d269..4c4edce 100644
--- a/tests/test-archive.t
+++ b/tests/test-archive.t
@@ -326,10 +326,10 @@ invalid arch type should give 404
> pass
> if len(sys.argv) <= 3:
> node, archive = sys.argv[1:]
- > requeststr = 'cmd=archive;node=%s;type=%s' % (node, archive)
+ > requeststr = 'cmd=archive&node=%s&type=%s' % (node, archive)
> else:
> node, archive, file = sys.argv[1:]
- > requeststr = 'cmd=archive;node=%s;type=%s;file=%s' % (node, archive, file)
+ > requeststr = 'cmd=archive&node=%s&type=%s&file=%s' % (node, archive, file)
> try:
> stdout = sys.stdout.buffer
> except AttributeError:
--
2.45.0

@ -3,7 +3,7 @@
Summary: Mercurial -- a distributed SCM Summary: Mercurial -- a distributed SCM
Name: mercurial Name: mercurial
Version: 4.8.2 Version: 4.8.2
Release: 1%{?dist} Release: 1%{?dist}.inferit
# Release: 1.rc1%{?dist} # Release: 1.rc1%{?dist}
@ -15,6 +15,7 @@ URL: http://www.selenic.com/mercurial/
Source0: https://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz Source0: https://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz
Source1: mercurial-site-start.el Source1: mercurial-site-start.el
Source2: blacklist Source2: blacklist
Patch0: 0001-tests-make-test-archive.t-pass-on-py3.9-issue6504.patch
BuildRequires: python2 python2-devel bash-completion BuildRequires: python2 python2-devel bash-completion
BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils
BuildRequires: gcc BuildRequires: gcc
@ -54,6 +55,7 @@ documentation.
%prep %prep
%setup -q -n %{name}-%{upstreamversion} %setup -q -n %{name}-%{upstreamversion}
%patch -P0 -p1 -b .py392
# Patch files to use python2 instead of (since lately) non existent python binary. # Patch files to use python2 instead of (since lately) non existent python binary.
sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile
@ -150,6 +152,11 @@ grep -v locale %{name}-base.files > %{name}-base-filtered.files
cd tests && %{__python2} run-tests.py -t 360 --blacklist %{SOURCE2} cd tests && %{__python2} run-tests.py -t 360 --blacklist %{SOURCE2}
%changelog %changelog
* Mon May 20 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 4.8.2-1.inferit
- Something got stricter at parsing URL query parameters and now the
parameters need to be separated by "&"; ";" is no longer allowed. See
issue6504 for details
* Sun Dec 10 2023 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.8.2-1 * Sun Dec 10 2023 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.8.2-1
- Rebuilt for MSVSphere 8.8 - Rebuilt for MSVSphere 8.8

Loading…
Cancel
Save